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Introduction 

Welcome to word processing with ProWrite. This introductory 
chapter will outline the general capabilities of word processing and 
the special features of ProWrite. Next, you will see how to use this 
manual to best suit your needs, and a bit about how to operate the 
Amiga, in case you are new to it. Finally, you will be shown how to 
install ProWrite on your system. 

The sections in this chapter are: 

• If You're New to Word Processing 

• How to Use This Manual 

• About Pro Write 

• Installing ProWrite 
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The keyboard of a word processor is very similar to that of a typewriter, but its 
capabilities extend much further. For example, in word processing you don't have 
to press the RETURN key at the end of every line-the line "wraps around" when it 
reaches the margin so you can continue typing without interruption. You only 
press RETURN when you want to start a new paragraph or insert blank lines. If you 
make a mistake while typing, you can simply backspace to erase it. But that's not 
where your editing options stop, far from it! 

Editing functions such as inserting, deleting, moving, and copying words, lines, 
and even blocks of text are fast and easy with only a few keystrokes or clicks of 
the mouse. Advanced programs like ProWrite will number pages, repeat material 
in the same place on every page automatically, and check the spelling of every 
word in your document. You don't need to print your document until it looks on 
the screen exactly the way you want it to. Finally, since copies of all your docu
ments can be stored on a disk, you can retrieve, re-edit, and re-print them at any 
time. 

Word processing lets you forget the technical aspects of writing and concentrate 
on the creative. It really is that easy! 

ProWrite's Special Features 

ProWrite has all the standard capabilities of advanced word processing and much 
more. You use the Amiga' s mouse to move a screen pointer which can be used to 
select text or choose commands from a menu. There's no need to remember any 
special codes-the menu commands are simple and logical. When you are ready to 
print, just choose Print. And when you do print, you get exactly what you see on 
the screen. 

With ProWrite, you can get proportionally spaced characters simply by using a 
proportionally spaced font. There are many different fonts you can use for your 
text, as well as many type styles, sizes, and seven different colors. 

ProWrite supports the multi-tasking capability of the Amiga, which means you can 
use more than one program at the same time; for instance, you can edit a document 
in ProWrite and an outline in Flow simultaneously. With ProWrite, you can open 
several documents at a time in different "windows" on your screen, then Cut text 
from one document and Paste it into another. If the other programs you use 
support the Amiga's clipboard, you can even cut and paste text or pictures between 
ProWrite and these programs! 
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ProW rite can also read picture files created by Amiga paint programs, so you can 
place pictures in ProWrite documents. Pictures created by DeluxePaint have 
transparent backgrounds, so you can type in the picture's empty space and even 
automatically wrap the text around its graphic. 

ProWrite also has many advanced word processing features, such as spell check
ing, a thesaurus, multiple columns, print merge, and macros. These features help 
you in creating professional results. 

ProWrite also supports the HotLinks system from Soft-Logik Publishing Corp. 
With HotLinks you can dynamically exchange text or pictures between pro
grams-for example, you can modify a picture in a paint program and have the 
changes automatically brought into ProWrite. This gives you a very close integra
tion between ProWrite and other programs you own. 
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This manual is divided into four parts: Introduction, Learning ProWrite, Using 
ProWrite, and ProWrite Reference. In the back of the manual is an Appendix, 
Glossary, and Index. If you are new to the Amiga, be sure to read the next section 
in this Introduction, entitled About the Amiga. Also refer to the Amiga user's 
manual that was included with your Amiga. 

If you are familiar with the Amiga but have no experience with word processing in 
general, you will need to study the Learning ProWrite chapter and do its practice 
exercises. The chapter will teach you how to load ProWrite, open a sample 
document, type and edit text, and then save, print, and close the document. 

If you have used other word processing programs, you may wish to skip to Using 
ProWrite. This chapter is a function-by-function guide that discusses all 
ProWrite's features. It is divided into several parts which discuss text editing, 
character and paragraph formatting, document layout and spell-checking, pictures, 
loading, saving, and printing documents, and ProWrite's user set-able options. 

ProWrite Reference is designed for quick reference for those who are already 
familiar with the basic operations of ProWrite. It contains summaries of all the 
commands (arranged in the menu's order), a discussion of how to use the ruler, a 
list of keyboard shortcuts, an explanation of screen options, and information about 
ProWrite's AREXX port. 

If You Don't Read Anything Else 

Make copies of your ProWrite disks and store the originals in a safe place! 

You might find ProWrite to be so easy to use that you will be tempted to set aside 
the manual and learn on your own. Whether you decide to learn from the manual 
or learn by doing, you should take a look at the Shortcuts section of the ProW rite 
Reference chapter to learn some time-saving key commands that make more 
efficient use of ProWrite's many features. 



About ProWrite 

Introduction 

To use ProWrite, you will need to know how to use the Amiga computer. You 
should already know how to: 

Select and drag with the mouse 
Use icons on the Workbench 
Depth-arrange windows using their front and back gadgets 
Re-position and re-size windows using the title bar and sizing gadget 
Scroll a document by using scroll bars and scroll arrows 
Pull down menus and choose commands 
Close windows with the close box 

Refer to your Amiga user's manual if you are unfamiliar with these items and 
actions. 

System Requirements 

The minimum requirements for using ProWrite 3.0 are an Amiga computer with 
one megabyte of memory and version 1.2 or later of the Amiga's Kickstart 
operating system, although Kickstart 2.0 or later is recommended. A second disk 
drive (or hard disk) is also required, and a printer is highly recommended. 

ProWrite can be run either from the Workbench or command line interface (CLI), 
and you can optionally create icons when you save your documents. For more 
information about the CLI, refer to your Amiga user's manual. 

Printer Support 

ProWrite works with the Amiga's built-in printing system, which means you can 
use ProWrite with any printer that you can select from the Amiga Preferences 
program. Although ProWrite will support several different letter quality and dot 
matrix printers, it is necessary to have a printer with graphics and color capabilities 
to fully utilize all of ProWrite's features. 

Display Options 

ProWrite will normally display its own screen with eight colors and the same 
width, height, and mode (interlaced or non-interlaced) as the Workbench screen. 
However, you can load ProWrite using the screen settings of your choice, includ
ing up to 256 colors (depending upon hardware), and interlaced or non-interlaced. 
You can also have Pro Write use the Workbench screen instead of using its own 
screen. 
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To get the best correspondence between screen display and printed output, 
ProWrite should be run using an interlaced display (also called "high resolution" 
mode). Unfortunately, this display mode uses more memory than the "medium 
resolution" mode, and will flicker noticeably on standard monitors. You can 
reduce this f1icker by decreasing the contrast of your monitor, or by reducing the 
brightness of the white color using ProWrite's Screen Colors requester. 
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Installing ProWrite 

ProWrite comes on three disks: a "Program" disk, a "Fonts & Devices" disk, and 
an "Extras" disk. There are several kinds of files included on these disks; here is a 
brief description of these files: 

Program disk: 
Pro Write program 
Main Dictionary file (small dictionary containing 50,000 words) 
Thesaurus file 
PostScript Prep file (needed for PostScript printing) 
Sample macros 

Fonts & Devices disk: 
System Mover program 
Fonts directory (contains several fonts and metric files) 
Libs directory (contains system software) 
Devs directory (contains system software and printer drivers) 

Extras disk: 
Documents drawer (contains several sample documents) 
Big Dictionary file (100,000+ word dictionary) 
RAMS tart program (for starting up RAM disk from Workbench) 
Installation program 

The steps you need to take in order to install ProWrite on your system will vary 
depending upon whether you have a hard drive or not. 

Floppy Installation 

If you are using a floppy-only Amiga system, you can use ProWrite as-is. Simply 
make a copy of the program disk, and use that as your main disk; the program disk 
contains the ProWrite program, a small (50,000 word) dictionary, thesaurus, and 
several sample macros already set up. 

There is not enough room on ProWrite's program disk for the large (100,000+ 
word) dictionary, but you can still use it for your spell checking. There are several 
ways of doing this: 

Once you have started ProWrite, you can use the Change Diet command to 
have ProWrite use the big dictionary on the Extras disk. 

You can copy the big dictionary from the Extras disk to the RAM disk, and 
rename it as "Main Dictionary". When ProWrite first starts up, it will look for 
the dictionary there and use it if found. 
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You can assign the name "Pro Write" to the Extras disk, and rename the 
dictionary as "Main Dictionary", and ProWrite will automatically use it. 

For more information on these options, see the section on Spell Checking in the 
Using ProW rite chapter. 

Hard Drive Installation 

If you have a hard disk drive, you can use the installation program on the "Extras" 
disk to install ProWrite on your system. Simply double-click on the "Hard Drive 
Install" icon, specify the technical level you would like to use (either Intermediate 
or Advanced), and proceed. If you choose the "Intermediate" level, the installation 
will take place for the most part automatically; if you choose "Advanced" you will 
be asked confirm all operations during the installation. 

Manual Installation 

If you wish to install ProWrite on your system manually (rather than use the pre
configured Program disk or installation program), keep these points in mind: 

In order for ProWrite to automatically find and use a dictionary, it must be 
called "Main Dictionary" and be located either on the RAM disk, in the 
drawer containing the ProWrite program, or in any location to which you've 
assigned the name "ProWrite:". 

Similar requirements apply to the location of the Thesaurus. 

If you will be printing to a PostScript printer, the "PostScript Prep" file must 
be in the same location as the ProWrite program. 

To be easily accessible, any macros you create should be saved in the same 
location as the ProWrite program. 

When installing the Times, Helvetica, and Courier fonts from the Fonts & 
Devices disk, you should first remove any such fonts you may have already 
installed from Commodore's Amiga Extras disk. The fonts provided on the 
ProWrite disk are more accurately designed than the ones provided by 
Commodore. 



Learning ProWrite 

The first step in learning ProWrite is to load the application and open 
a document. After showing you this, this chapter will then continue 
with step-by-step instructions for typing, deleting, and editing text in 
a sample document provided on the ProWrite disk. You will then 
learn how to save and print the document, and how to close the 
document and leave the program. 

If you have never used the Amiga or do not have any word process
ing experience, it may take a few hours to carefully read and study 
this chapter and complete all the practice exercises. Refer to the 
section at the end of this chapter entitled Closing a Document and 
Quitting ProWrite if you cannot finish the tutorial in one sitting. 

The sections in this chapter are: 

• Loading ProWrite and Opening a Document 

• Manipulating Text in a Document 

• Saving and Printing a Document 

• Closing a Document and Quitting ProWrite 

• Where to Go From Here 
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Starting ProWrite and opening a document is easy. First follow these instructions: 

Tum on the Amiga computer. 

When you see the picture of the Workbench disk, insert a Workbench disk 
into your first disk drive and your ProWrite Program disk into your second 
disk drive. After a few seconds, two icons representing these disks will appear 
on the Workbench screen. 

The Getting Started section of the Introduction told you to make copies of your 
ProWrite disks for personal use. This is especially important because you will be 
altering a sample document on the Extras disk while you do the practice exercises 
in this chapter, and you will want to leave the document unchanged on the original 
ProWrite disk. 

Use the mouse to place the pointer on the Program disk icon and double-click 
the left mouse button (the selection button). Icons representing the contents of 
the Program disk will appear on the Workbench screen in a window entitled 
"Program." Notice the ProWrite program icon. 

Double-click on the ProWrite program icon. ProWrite will start loading, and 
in a few minutes you will see an empty ProWrite window on your screen. 

You will be opening an existing document called "Memo" which is stored in the 
"Documents" drawer of the Extras disk. 

Press the right mouse button (the menu button) and choose the Open com
mand from the Project menu. A requester will appear. 

Click on the "Disks" button in the requester. A list of disks will be shown in 
the list box. 

Remove your Program disk from your second disk drive and insert your 
Extras disk. After a few seconds, the name "Extras" will be shown in the list 
box. 

Double-click on the name "Extras". After a few seconds a list of files and 
drawers on the Extras disk will be shown in the list box (a drawer is listed in 
italics, and has a hyphen in front of its name). 

Double-click on the name "Documents" in the list box. In a few seconds the 
contents of the "Documents" drawer will appear in the list box. Notice the 
document entitled "Memo". 

Double-click on the name "Memo" to load that document. 



Learning ProWrite 

Using the Mouse 

Take a few minutes to get used to moving the pointer in the window with the 
mouse. 

The right mouse button, the menu button, is for choosing commands from the 
menu only. Any other kind of selecting or clicking, such as selecting icons or text, 
or clicking gadgets, is done with the left mouse button, the Selection Button . The 
selection button can even be used in combination with the menu button to select 
several menu commands at a time. This will be discussed later. For now, remem
ber that the left button is used for clicking and selecting. 

Controlling the Window 

You can scroll in the window in order to see portions of the document which are 
currently hidden. If you wish to scroll a little bit at a time, place the pointer on one 
of the scroll arrows next to the scroll bars on the right side and bottom of the 
window and click with the left mouse button. For continuous scrolling, click and 
hold the left mouse button. To move quickly to another part of the document, place 
the pointer on the rectangular scroll box in the scroll bar, click and hold the left 
mouse button, and drag the box in the scroll bar. The size of the box in the scroll 
bar is indicative of the percentage of the document that is visible, for example if 
the scroll box is one quarter of the size of the containing rectangle then the 
window is displaying one quarter of the entire document. 

~~LL __ ~==========================~"~~ 
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If you are working with a large document, the page indicator near the window's 
lower left comer shows the number of the page being viewed. Click the arrows 
next to the page indicator to scroll up and down one page at a time. 

The window may be re-sized by placing the pointer on the sizing gadget in the 
lower right comer of the window, clicking and holding the left mouse button, and 
dragging the box. As you drag the sizing gadget, lines will follow your move
ments, indicating what size the window will be when you release the mouse 
button. Also, after making the window smaller, you can re-position it on the screen 
by placing the tip of the mouse pointer on, or pointing to, the title bar at the top of 
the window, clicking and holding the left mouse button, and dragging the window. 

Practice scrolling in the document and re-sizing and re-positioning the window 
now. 

You may need to click in a window with the left mouse button to place the 
insertion point before typing any new text or editing any old text. If you forget to 
do this and begin typing, either nothing will happen or you will type into the 
wrong window. Click somewhere in the "Memo" document window now. 

About the Menus 

To give a command to ProWrite, you first click and hold the right mouse button, 
the Menu Button, to show the menu bar above the window. Then you point to a 
menu title to pull down the menu. Finally, while still holding the menu button, 
drag the pointer to a command name so that it highlights, then release the mouse 
button. If you want to choose more than one command at a time, keep holding the 
right mouse button, point to each command, and click the left mouse button. 

A few menu commands may appear in lighter print, or dimmed. These are menu 
items that are not currently available because they are contingent on some other 
action and thus cannot be chosen until that other action is completed. For instance, 
the Erase command in the Edit menu is dimmed because you cannot erase text 
until text is selected. Once you have selected text, the Erase command will show 
in normal print and then can be chosen. 

Some menu commands may have a check mark next to them. This indicates a 
chosen option. For example, in the View menu, ProWrite has automatically chosen 
to display pictures that are in your document by putting a check mark next to the 
Show Pictures command. If you select this command now, the check mark will 
disappear, and pictures will be replaced with a box. Choose the command again to 
tum it back on, and so forth. Some check mark commands are "exclusive," which 
means that choosing one will tum off another. 
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Some menu items display a submenu. Submenus list groups of options that are 
related to each other. 

To see an example of a submenu, click and hold the right mouse button to 
view the menu bar. Point to the Format menu title to pull down the menu, 
then, still holding the menu button, point to the Style command to display its 
submenu. A list of character styles will appear, with a check mark beside any 
that are in effect. 

Many commands have an Amiga symbol and a character beside them on the menu. 
These are keyhoard equil'G/ents for the commands. By pressing the right Amiga 
key on the keyboard with the appropriate character, you can give ProWrite a 
command without using the mouse and the menu (see Shortcuts in the Using 
ProWrite chapter). Other commands can be performed from the keyboard by 
pressing a/unction key. These commands do not show any symbol next to the 
menu item, you will need to refer to the Shortcuts section for a list of these 
commands. 

Some of the menu commands have an ellipsis ( ... ) after them. Choosing these 
commands will cause a requester to appear in the window. A requester allows you 
to supply additional information and/or select options before confirming the 
command. 

Requester Gadgets 

There are several types of gadgets in requesters. The left mouse button is used to 
select them all. 

A button is a small, bordered rectangular box drawn around an option name. Most 
requesters have "OK" and "Cancel" buttons to confirm or cancel the command, 
and some have additional buttons as well. Select an option by clicking on its 
button. Pressing the RETURN or ENTER key will select the outlined button (usually 
the "OK" button), and pressing the ESC key will select the "Cancel" button. 

A radio button is a small triangle with an option name beside it. Select this option 
either by clicking on the triangle, or directly on the text of the option itself. Radio 
buttons behave like a car radio's buttons-there is always a group of two or more, 
and they are linked so that when you select one the others are turned off. 

A check box is a small square box with an option name beside it. As with radio 
buttons, you may select or de-select the option either by clicking on the box or 
directly on the text of the option itself. The difference is that check boxes may be 
selected in any desired combination. 
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A list box contains a list of several items from which you may select one. If the list 
is too long to fit inside the list box, the box will have a scroll bar and scroll arrows 
for you to use to see the rest of the items on the list. To see the other items in the 
list, either click on the scroll arrows or drag the scroll box. To select an option, 
click on it and then click on the "OK" button. 

A pop-up menu is like a button, but has a downward pointing arrow at the right. 
Clicking on it will display a menu of choices; drag down and release the mouse 
button over the option you wish to choose. 

A text box is a long rectangular box in which text is typed. A cursor in the text box 
(displayed as a small rectangle) indicates where a typed character will appear. You 
use the cursor keys on the keyboard to move within the text box, and the BACK

SPACE and DEL keys to delete text. 
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Manipulating Text in a Document 

You will use the sample document "Memo" to learn about manipulating text in a 
document. Manipulating text involves entering (typing), inserting, deleting, editing 
(changing), moving, and copying operations. 

- © 1987-92 Hew Horizons Software, Inc. 

January 31,1991 

On March 1 ,1991, the national office 'Will 

be launching a nev and exciting sales 

incentive progl8.m. The gl8.nd prize is a 

slick and shiny 1991 POl3che! 

Supervisol3 'Will meet next veek vith the Assistant to the V ice President to discuss the ne'W incentive 

progl8.m . Please revie'W the agenda and the progl8.m infoonation in order to be vell prepared for the 

meeting. 

Entering Text 

The sample document "Memo" is not quite finished. Practice entering text by 
adding a concluding paragraph according to the following instructions. 

) . 

Scroll down through the memo by using the mouse pointer to point at the 
down arrow beneath the scroll bar on the right side of the window and either 
click for step-by-step movement or click and hold for continuous movement. 
Stop when the last paragraph of the memo is near the top of the window. 

Point at the left margin of the memo just below the last paragraph and click 
the left mouse button. This places the insertion point on the next line beneath 
the paragraph to indicate where the next action or command will take place. 
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Begin typing the memo's concluding paragraph as it appears below and press 
the RETURN key when you're done. You do not have to press RETURN at the end 
of a line-ProWrite wraps the text around for you automatically within the set 
margins. Press the RETURN key only if you want to start a new paragraph. If 
you make a mistake while you are typing, use the BACKSPACE key to erase it. 
Every time you press the BACKSPACE key, the insertion point moves backward 
one character, erasing as it goes. 

Finally, be sure to visit the lobby of the 
Vice President's office February 15 through 
March 2 to see the grand prize on display. 
Sorry, no test driving allowed! 

Inserting Text 

When you insert text, the ends of the lines will re-wrap, pushing the old text down 
the page to make room for the inserted text. Practice inserting text in the following 
exercise. 

Point at the beginning of the fourth paragraph of the memo and click to place 
the insertion point. 

Type the following paragraph and end it with a RETURN. 

The Vice President's office welcomes 
inquiries from sales associates about the 
incentive program and will have someone 
available to answer questions. For aid in 
compilation of individual achievement 
outlines, the Resources office is open from 
8:00 a.m. to 10:00 p.m. weekdays and 10:00 
a.m. to 3:00 p.m. on Saturdays. 

The new paragraph is now positioned between the original third and fourth 
paragraphs of the memo. 

Selecting Text 

Now suppose after finishing the paragraph you find that you made a mistake in the 
very first line. Instead of backspacing to the error, which would erase the rest of 
the paragraph, you have several other options. Many of these options, and many 
other commands as well, require that you select text. 

Selected text will appear highlighted in white print on a black background. You 
may select characters, words, lines, and even the whole document in this way. 
After selecting text, the next command or action will affect only the selected text. 
You may de-select text by clicking anywhere else in the window. 
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Complete the following practice exercises and then spend a few additional minutes 
experimenting with selecting text. 

Select any two- or three-word phrase in the sample document "Memo" by 
pointing just to the left of it, clicking and holding the left mouse button, 
dragging the pointer across the text, and releasing the mouse button. 

Select any word by double-clicking anywhere in the word with the left mouse 
button; continue to hold the left mouse button and drag the pointer to select 
words at a time. 

Select any sentence by triple-clicking anywhere in the sentence with the left 
mouse button; continue to hold the left mouse button and drag the pointer to 
select sentences at a time. 

Select any paragraph by holding down the ALT key and double-clicking 
anywhere in the paragraph; continue to hold the mouse button and drag to 
select paragraphs at a time. 

Select the entire document by holding down the ALT key and triple-clicking 
anywhere in the document. You can also select the entire document by 
choosing Select All from the Edit menu. 

Select any block of text by clicking at the beginning of the block, holding 
down the SHIFT key, and clicking at the end of the block. 

Click anywhere in the window to de-select the text. 

Deleting Text 

Now, you can go back to any part of your document to fix a mistake by deleting or 
changing what you typed. There are several ways to delete text; with experience, 
you will find that each is appropriate in a particular circumstance. Note that as you 
delete or replace text, ProWrite automatically re-wraps the line endings, closing up 
empty spaces or moving words forward to make room. 

Practice deleting and replacing text by completing the following exercises. 

Select the phrase "new and exciting" in the first paragraph of the memo. Press 
the BACKSPACE key to delete it. 

Select the word "packet" in the second line of the third paragraph. Type the 
word "folder" to replace it. 

Point just to the right of the word "marketing" in the last line of the fifth 
paragraph and click to place the insertion point. Backspace to remove the 
"ing." 
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Undoing Changes 

Pro Write keeps track of most operations you make that change the contents of the 
document, so if you change your mind you can undo these changes. You can also 
easily re-do the operation you just undid, allowing you to quickly switch between 
two alternate possibilities. The types of operations you can undo include typing, 
deleting, cutting and pasting, and style and format changes. 

Practice undoing and redoing a deletion by completing the following exercises. 

Select the word "folder" in the second line of the third paragraph. Type the 
word "packet" to replace it. 

Choose Undo Typing from the Edit menu to change it back to "folder." 

Notice that the undo command in the Edit menu has changed to read Redo 
Typing. Choose Redo Typing from the Edit menu to change the text to 
"packet" again. 

Moving Text (Cutting and Pasting) 

Moving text involves two operations: first you cut the text to be moved, and then 
you paste it back into the document. The Cut and Paste commands in the Edit 
menu are used to move text from one part of a document to another. 

When you select and cut a portion of a document, the selected text is deleted from 
the document and stored in an internal clipboard, replacing text that may already 
be stored there from a previous Cut (or Copy) command. You may then place the 
insertion point, or select text to be replaced, and tell ProWrite where to paste the 
cut text back into the document. A copy of the cut text will remain in the clip
board, even after you paste it back into a document, until you cut (or copy) other 
text from a document. 

In the following exercise you will move the paragraph that you just inserted in the 
previous exercise to a new position in the memo. 

Select the paragraph beginning with "The Vice President's office ... ". Be sure 
to select the entire paragraph, including the RETURI\ at its end, by dragging 
from the beginning of the paragraph to the beginning of the following 
paragraph. 

Choose the Cut command from the Edit menu. The selected text will disap
pear from the document and be stored in the clipboard. 

Click just to the left of the first word of the paragraph beginning with "Fi
nally, be sure to ... " to place the insertion point. 
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Choose the Paste command from the Edit menu; the cut text will be inserted 
at the location of the insertion point. 

Copying Text 

The procedure for copying text from one part of a document to another is very 
similar to moving text. When you choose the Copy command from the Edit menu, 
a copy of the selected text is stored in the clipboard until you copy or cut other text 
to replace it. The only difference from the Cut command is that the portion of text 
being copied to the clipboard remains in its original position in the document as 
well. 

Practice copying text in the following exercise, which will instruct you to copy and 
paste the date at the top of the memo so it will appear again at the bottom of the 
memo. 

Select the phrase "January 31, 1991" at the beginning of the memo. 

Choose the Copy command from the Edit menu. The selected text will 
remain in the document unchanged but a copy of it is stored in the clipboard. 

Click at the left margin beneath the last paragraph of the memo to place the 
insertion point. Press RETURN to move the insertion point down one more line. 

Choose the Paste command from the Edit menu. The copied text will be 
inserted at the location of the insertion point. 

Finding Text 

ProWrite will find specific text for you. This is especially useful in long docu
ments, saving a lot of time and effort. You use the Find command in the Search 
menu. A requester will appear for you to supply additional information before 
confirming the command. 

o Find 

Find: '~~Y isor 

.J Hho I e Word :..J Match lJpper/lower Case 

The search will start at the insertion point and continue to the end of the document. 
If the text was not found and you didn ' t start at the beginning of the document, 
ProW rite will ask if you want to continue searching from the beginning. 
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The first item in the Find requester is a text box containing a red cursor where you 
type in the text you want ProWrite to find; it will hold up to 100 characters. As 
you type and fill up the text box, the text will scroll from right to left so that you 
always see what you are typing. The cursor will move along to the right of the new 
text as you type. If you need to go back in the text to correct an error or make a 
change, use the left cursor key to move the cursor back through the text. Press the 
SHIFT key with the left or right cursor key to move quickly to the beginning or end 
of text in a text box. 

Note that if you ask ProWrite to find the word "can," it will find these three letters 
even if they are a part of another word such as "cannot," "candle," or "incanta
tion." You may specify that you want ProWrite to find "can" only where it appears 
as a whole word by clicking on the "Whole Word" check box. 

ProWrite also will not distinguish between capital and lower case characters in its 
search unless you select the "Match UpperlLower Case" check box. 

After typing the text to be found in the text box and selecting any options you 
wish, click on the "Find" button or press RETUR~ or ENTER to begin the search. The 
requester will disappear. 

ProWrite will find the first occurrence of the text and select it in the document. If 
ProWrite did not find the text, a requester will display the message "Text Not 
Found." 

If you want Pro Write to find the next occurrence of the text, choose the Find Next 
command from the Search menu. 

To find the phrase "market and sales research" in the memo in order to change it, 
using the "Find" command would be much easier and faster than scrolling through 
the document. Find this phrase now by completing the following exercise. 

Go to the beginning of the memo and place the insertion point at the top. 

Choose the Find command from the Search menu. A requester will appear. 

Type the phrase "market and sales research." 

Click on the "Find" button. The located text will appear highlighted in the 
document. 

Finding and Changing Text 

Not only will ProWrite find text for you, it will also change it. The procedure for 
finding and changing text is similar to that of simply finding text. You will use the 
Change command in the Search menu to bring up a requester for additional 
information before confirming the command. 
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find: ~Isor.. wr _ .1 
Change to: 1'""~~~tMI...::.n""'-"t ........ ~HMd~. ~==""",----"""""""'_--!!o. ____ ~1 

. Watch lJpperA..ower Case 

The Change requester contains two text boxes, one for you to type in the text you 
want to find and one for you to type in what you want to change it to. The red 
cursor will be in the "Find" text box. As in the Find requester, you may instruct 
ProWrite to find only whole words or to match capital and lower case letters by 
selecting those options. You then click on the "Find" button. 

After ProWrite finds and selects the text, the "Change to" text box will be selected 
for you to type in the new information. Then you have several options. You can 
click on the "Change" button to change the located text. Or you may instruct 
ProWrite to change the text and then find the next occurrence in the document by 
clicking on the "Change, Then Find" button. If you click on the "Change All" 
button, ProWrite will find and change all the occurrences of the text in the 
document without stopping. 

If you leave the "Change to" text box empty and select one of the change buttons, 
ProWrite will delete the located text. 

For practice in instructing ProW rite to change text, change every occurrence of the 
phrase "Vice President" in the memo to "Chairman." 

Place the insertion point at the top of the memo. 

Choose the Change command from the Search menu. A requester will 
appear. 

Type the phrase "vice president." It will appear in the "Find" text box. It 
doesn't matter if you capitalize the initial character or not because ProWrite 
will find the phrase anyway unless you select the option to match upper and 
lower case characters. 

Click on the "Find" button. 

When the text is located and selected in the document and the "Change to" 
text box is selected, type the phrase "Chairman." Do capitalize the word here 
because you do want ProWrite to capitalize it in the memo. 

Click on the "Change All" button. 
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After changing all occurrences, ProWrite will tell you how many changes 
were made. 

Checking the Spelling 

Once you have typed the entire document, ProWrite can check the spelling of 
every word in it with its built-in 100,000 word spelling checker. If misspellings are 
found, you can choose to ignore them, save them to your own custom dictionary 
(for words that are correctly spelled but not in ProWrite's dictionary), change them 
directly , or have Pro Write give you a list of possible alternatives. 

Like the Find and Change operations, the spelling check will start from wherever 
the insertion point is and go to the end of the document. If you did not start from 
the beginning, Pro Write will ask if you wish to continue from there. 

Practice using the spelling checker by performing the following exercise: 

Place the insertion point at the top of the memo. 

Drag to Spelling in the Document menu; a submenu will appear. For now, 
choose Check, which is what you use to check a document's spelling. 

A requester will appear. To begin the spelling check, click on "Start" (the 
button name will change to "Skip"). It may take a few minutes to complete the 
spelling check. 

D 

Nord: gueess 
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If a word is found that ProWrite doesn't recognize, it will be highlighted in 
the document and shown in the dialog box. To skip this word, click on "Skip." 
To save the word to your own custom dictionary, click on "Learn." To change 
the word, first type the replacement in the text box, then click on "Change." If 
you want ProWrite to give you a list of suggested alternative words, click on 
"Guess," and a list of suggestions will be shown in the list box. If you see the 
correct word in the list box, you can click on the word and click on "Change," 
or simply double-click on the word. 

ProWrite will tell you when it has finished checking the memo. 

The "Done" button will change to read "Stop" during a spell check, to show that 
you can click it to interrupt the process if you want to. 

Pictures 

As you can see in the sample document "Memo," ProWrite allows you to put 
pictures as well as text in a document. A picture, or graphic file must be created in 
another Amiga application specifically designed for painting. ProWrite will read 
these files and place the picture in your document. ProWrite lets you move a 
picture around in a window, re-size the picture, have your text automatically wrap 
around the picture, and even give each picture a name that can be used when 
searching for the picture. You can even type in the background area of pictures 
created with DeluxePaint or DeluxePaint II. 

Manipulating pictures in a document is discussed in the Using ProWrite chapter. 
For now, we will continue with how to save and print a document. 
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As you are working on a document, it is very important to save your work periodi
cally. This way if there is a power failure or other mishap you will only lose the 
work you have done since the last time you saved the document. 

Saving a Document 

To save a document, choose the Save command from the Project menu. If the 
document has been saved before, ProW rite will replace the old version of the 
document with the new version. The document will remain on the screen. It takes a 
few seconds for ProW rite to save a document, and during this time the pointer 
image in the window will change to a clock face image indicating that you must 
wait. 

If the document is a new document (i .e. it hasn't been saved before), the Save As 
requester will appear in the window. Refer to the discussion of the Save As 
command in the chapter Using ProWrite for instructions on how to save a new 
document. 

Choose the Save command from the Project menu to save the sample 
document "Memo" that you have been working with. Because it is a previ
ously saved document, no requester will appear and the document will remain 
on the screen. 

Printing a Document 

After perfecting and saving a document, you will want to print it by using the 
Print command in the Project menu. This command will bring up a requester 
where you can adjust several printing options before confirming the command, 
such as the print quality, the number of copies, and the range of pages you want to 
print. 

Print 

cp.lltv: 
pages: 

, Caple.: 

1'Ep8onQ11 

p ....... feed: flYtoMtlc v Hand ft.ed 
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Print", to front 
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The print quality will initially be set to "Normal" (unless you are using a non
graphics printer), which signifies a graphics print. You must use either this option, 
or the "High" option, if you want to get the fonts, pictures, and format exactly as 
shown in the window. You can also select "NLQ" (Near Letter Quality) or "Draft" 
printing, however with these two options you will not get a printout using the fonts 
on the screen, nor will you get pictures unless you set another option, "Print 
Pictures." There is also a "PostScript" option for use with PostScript printers. 

The "Copies" text box in the requester is pre-selected (containing a red cursor) and 
a suggested number of copies (I) is already typed in. If you want to change the 
number of copies to be printed, press the DEL key and type the number of copies 
you want; the number will appear in the "Copies" text box. 

For the range of pages to print, the "All" radio button will be pre-selected-most 
of the time you will want to print all of a document. You can print a specific range 
of pages by selecting the "From" option. The red cursor will move to the first text 
box beside the "From" label where you can type in a beginning page number. Then 
press the RETURN key to move the cursor to the second text box and type in an 
ending page number. If you simply want to print a single page from a mUlti-page 
document, type the same page number in both boxes. 

Finally, the "Paper Feed" setting is initially "Automatic." If you are using single 
sheets that you must manually feed into your printer, select "Hand Feed." 

For details about the remaining controls in this requester, see Printing a Docu
ment in the Using ProWrite chapter of this manual. 

Print a copy of the sample document "Memo" following these instructions: 

Follow the instructions in Introduction to the Amiga to make sure your printer 
is properly connected to your computer, and make sure that it is turned on. 
Also be sure you have made the necessary Amiga Preferences settings, 
discussed in Appendix C: Printing Considerations. 

Choose the Print» Print command from the Project menu. A requester will 
appear. 

Change the options to reflect your printing preferences. 

Click on the "Print" button. 

While ProWrite is printing, the page number indicator near the bottom left comer 
of the window will show which page is currently being printed, and a requester 
will appear in which you may click "Stop" if you want to interrupt the print. 
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After finishing a work session in ProWrite, you may close a document window 
and exit, or quit, the ProWrite program. There are two ways to close a window: 
choose the Close command from the Project menu or click in the close box at the 
top left comer of the window. 

If you tell ProWrite to close a window before saving any changes you have made 
to the document in that window, ProWrite will ask if you want to save the changes 
before closing the window. Otherwise, if you haven't made any changes, or if you 
have already saved the document, the window will immediately close. 

Click in the close box to close the window containing the sample document 
"Memo." 

When you close the last window, it will disappear and you will see an empty blue 
screen. If you click and hold the right mouse button, you will see that all of the 
menu commands are dimmed except New, Open, and Quit. 

Choose the Quit command from the Project menu to quit ProWrite. 

After quitting ProWrite, you will return to the Workbench. 

You may quit ProWrite without first closing a document window by choosing the 
Quit command from the Project menu. As with closing a window, ProWrite will 
prompt you to save a document if you try to quit without saving any changes you 
may have made to that document. 
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Where to Go From Here 

This chapter has taught you the basics of loading ProWrite and opening a docu
ment, entering and editing text, and saving and printing your document. You have 
also learned how to close a document and quit ProWrite. 

So far, you have only used ProWrite's most essential features. The Using 
ProWrite chapter that follows gives a complete description of all ProWrite's 
functions. It is organized on a feature-by-feature basis and does not use a sample 
document with exercises. You may still use your sample document "Memo" to 
explore the additional features discussed in the next chapter. 
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Using ProWrite 

This chapter all of ProWrite's features in detail, arranged by subject. 
The sections in this chapter are: 

• Getting Started 

• Editing Text 

• Undoing Changes 

• Formatting Characters 

• Formatting Paragraphs 

• Formatting Documents 

• Spell Checking, Thesaurus, and Sorting 

• Pictures in a Document 

• HotLinks 

• Speaking 

• Loading and Saving a Document 

• Printing a Document 

• Project Information and Passwords 

• Setting ProWrite Options 

• Saving ProWrite Preferences 

• 
I 

Macros and AREXX 

• Miscellaneous 
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Getti ng Started 

To load ProWrite and 
create a new document: 

To load ProWrite and 
open an existing 
document: 

To load ProWrite and 
open several 
documents: 
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You should make a copy of your Pro Write disks to use while working; see your 
Amiga User's manual for instructions on how to copy a disk. ProWrite is not copy 
protected. 

Before loading ProWrite, make sure you have chosen the correct driver for your 
printer by choosing from the list of printers in the Amiga's Preferences program. 
Refer to your Amiga User's manual for information about specific printers, and to 
Appendix B: Printing Considerations to see what Preferences settings you need 
to make. 

Or: 

Or: 

Or: 

From the Workbench: double-click on the ProWrite program icon. 

From the eLI: type "ProWrite" and press RETURN. 

From the Workhench: click on the document icon, then hold the SHIFT key and 
double-click the ProWrite icon. (Or, if your ProWrite disk's name has not 
changed since you saved the document, you can simply double-click the 
document's icon.) 

From the eLI: type "ProWrite", a space, and then the document name. Then 
press RETURN. 

From the Workbench: click on the first document icon, then hold down the 
SHIff key and click on the second document icon, the third, and so forth 
Finally, still holding the SHIFT key, double-click the ProWrite program icon. 

From the eLI: type "ProWrite", a space, the first document name, a space, the 
second document name, and so forth. Then press RETURN. 

Start-up Options 

ProWrite will normally open its own eight-color screen using the same screen 
mode as the Workbench screen. However, you can override this and specify any 
screen mode and number of colors that the Amiga is capable of providing. When 
using Workbench 2.0, you can even have ProWrite use another program's screen if 
that program declares its screen as "Public". 
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Display options are specified when you first load the program. To specify a 
display option from the Workbench, you must add one or more of the following 
options to ProWrite's "Tool type" list. From the CLI, simply type a dash (-) and 
the option (e.g. type "ProWrite -HiRes" to run ProWrite in a high-res screen). 
Most options have both an abbreviated and a full form. The options supported by 
ProWrite are: 

"HiRes" or "HR" 
Use a 640 by 400 screen (640 by 512 in PAL). 

"MedRes" or "MR" 
Use a 640 by 200 screen (640 by 256 in PAL). 

"LoRes" or "LR" 
Use a 320 by 200 screen (320 by 256 in PAL). Using a low resolution screen may 
require the use of shortcuts to access some requester items, as some requesters 
may be too large to completely fit the screen unless you have installed the "System 
Thin" font on your system. 

"Productivity" or "PR" 
Use a productivity mode screen (640 by 480 non-interlaced). This option requires 
AmigaDOS 2.0, the enhanced chip set, and a VGA or mUltisync monitor. Only two 
and four color screens are supported in this mode. 

"Super HiRes" or "SR" 
Use a super high resolution mode screen (1280 by 400). This option requires 
AmigaDOS 2.0 and the enhanced chip set. Only two and four color screens are 
supported in this mode. 

"Colors:number" or "Colors=number" 
Where numher is 2, 4, 8, 16, or 32. This command specifies the number of colors 
that the screen is to use. Note that 32 colors can only be used with low resolution 
screens (see the "LoRes" option above). You can also use a spelling of "Colours" 
for this command (e.g. "Colours: 16"). 

If your Amiga computer supports more than 32 colors per screen, you can use 
higher values with this command (e.g. "Colors:256" will cause ProWrite to use a 
256 color screen on machines that support it). 

"Screen:screen name" or "Screen=screen name" 
Where screen name is the name of an existing public screen. This option requires 
AmigaDOS 2.0, and the presence of a public screen with the given name. Ex
amples of screen names are "Workbench" for the Workbench's screen, and 
"DesignWorks" for DesignWorks' screen (DesignWorks is a structured drawing 
program from New Horizons). This option overrides other screen options. 
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Normally when ProWrite opens its own screen, it declares it a public screen with 
the name of "ProWrite". However, if you use the "Screen" option to specify a 
screen name that does not exist, ProWrite will use the name you provide as the 
screen name. 

"Workbench" or "WB" 
Use the Workbench screen. This options overrides other screen options. 

"SmartWindows" or "SW" 
Use "smart refresh" windows. This option makes window displays slightly faster 
when dealing with several overlapping windows, at the expense of consuming 
more memory. 

"ASL" 
Use the "ASL" file requesters for choosing files to open or save. This option only 
works with Kickstart 2.0 or later, and only if the "asl.library" file is installed on 
your Amiga. Note that since there is no way for ProWrite to add its own buttons to 
the ASL requesters, all saves will be done in ProWrite's "Normal" format. 

Color Handling 

ProWrite internally tracks colors using the full Amiga palette of 4,096 colors, and 
automatically translates from those internal color values to the closest matching 
screen color when drawing pictures or text. Therefore, the more colors you have 
available on the screen, the more accurate the representation of pictures and text 
display. In addition, ProWrite can print using the Amiga's full 4,096 color palette, 
so your printouts can exactly match the original picture colors. 

ProWrite also automatically adapts to any changes in the color palette. If you 
change the color palette while running ProWrite, both the text and pictures will be 
redrawn using the new palette. 



Editing Text 

The mouse: 

The window: 

Using ProWrite 

Some of the operations involved in editing a document are entering, inserting, and 
deleting text. Text may be moved or copied within a document or between 
different documents. ProWrite will also find and change not only text but also non
text items such as spaces, non-breaking spaces, and tabs. All of these functions 
may be used in page headers and footers as well. 

About the Mouse, Windows, Menus, and Gadgets 

You need to be familiar with the mouse, the window, the menus, and the types of 
gadgets in order to use ProWrite. The following are summaries of the characteris
tics and functions of these items; a more detailed description is contained in the 
previous chapter, Learning ProWrite. 

The mouse is used to move the pointer in the window. 

The right mouse button, the Menu Button, is for choosing commands from the 
menu only. Press and hold the right mouse button to show the menu bar above 
the window. Then point to a menu title to display the menu. Finally, point to a 
command name (it will be highlighted) and release the mouse button. 

You can choose more than one menu command at a time by holding the menu 
down with the Menu Button, and clicking the left mouse button to choose 
each command. 

The left mouse button, the Selection button, is primarily for selecting items 
such as icons, text, gadgets, and options, and for placing the insertion point. If 
you are told to click on something, use the left mouse button. 

A document's window must be active before you can type in it. The active 
window will contain the insertion point, a blinking vertical bar which shows 
where new characters will appear as you type. If a window is not active, you 
must click in it to place the insertion point before you begin typing. 

In high resolution, almost half a page of text will be visible in the window; in 
medium resolution you will see about one quarter of the page. 

To scroll vertically through a document, use the left mouse button to click 
and/or hold either of the scroll arrows beneath the scroll bar on the window's 
right side. Scrolling through a document does not move the insertion point. 
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To scroll more quickly, click and drag the scroll box in the scroll bar. The size 
of the box in the scroll bar represents the fraction of the entire document that 
is currently visible in the window. 

A similar scroll bar is situated at the bottom of the window. This may be used 
to scroll to the left and right sides of a page. It has a pair of scroll arrows at its 
far right end. 

At the far left end of the window's bottom is a page indicator with another 
pair of arrows. Click these arrows to scroll vertically in a document by pages. 

Re-size the window by clicking and dragging the sizing gadget in the lower 
right comer of the window. 

Re-position the window on the screen by clicking and dragging the title bar at 
the top of the window. 

Click the front and back gadgets in the top right comer of the window to move 
the window behind or in front of other windows. 

Any menu commands that are dimmed are contingent upon some other action 
and cannot be chosen until that action is completed. 

A check-marked command indicates a chosen option; you may tum it off in 
some cases by choosing it again, or in other cases by choosing something else. 

Some menu commands access a submenu instead of a list of commands. A 
submenu lists very closely related options and commands. 

Certain commands have an ellipsis (three dots: " ... ") after them, which 
indicates that choosing that command will bring up a requester in which to 
provide additional information and confirm the command. 

Many menu commands have a keyboard equivalent listed beside them. These 
are discussed fully in the Shortcuts s~ction at the end of this chapter. 

A button is a labelled rectangle that is clicked (with the left mouse button) to 
confirm or cancel a command. If there is no text box active (see below), you 
may press the RETURN or ENTER key to activate the outlined button (usually 
"OK") or the ESC key to select the "Cancel" button. 

A radio button is a triangle with an option label beside it; click either in the 
triangle or on the text of the label to select it. Selecting a radio button will 
automatically de-select any radio button that is grouped with the one you 
select (they are "exclusive"). 
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A check hox is a square with an option label beside it; click either in the 
square or on the text of label to select it. Check boxes may be selected in any 
combination. 

A list hox contains several options, click on one to select it. If there are more 
options listed than fit in the box, you can either use the provided scroll box or 
drag past the list's top or bottom to see additional entries. You can also use the 
cursor up/down keys to select an option. If there are two list boxes, select 
from the second one by holding the SHwr key while using the cursor keys. 

A pop-up menu is a rectangle with the name of an selection and a downward 
pointing arrow at the right end. Clicking on the rectangle will show a menu of 
choices that you can select. 

A text hox is a rectangle in which text is typed; use the left and right cursor 
keys to move within the box. To move to the beginning of the text, press 
sHiFf-left cursor; to move to the end press sHiFf-right cursor. To erase the 
contents of the text box, hold down the riF,ht Amiga key and press "X". 

If there is a text box in a requester but it is not active, you can activate it by 
pressing the TAB key. 

If several text boxes are grouped together, pressing RETURN will move you 
from one to the next, while pressing SHIFI-RETURN will move you back. 
Pressing SHiFf-RETURN in the first box or RETURN in the last box is the same as 
clicking the button with the red outline (usually "OK"); ENTER will select this 
button in any case. 

If you are using Workbench 2.0 or later, pressing the TAB key will move you 
from one text box to the next. Pressing SHiFf-TAB will move in the reverse 
order. 

Nearly all gadgets in requesters (buttons, radio buttons. and check boxes) can 
be selected from the keyboard by typing the key corresponding to the under
lined character. You can move up and down in a list box by using the up and 
down cursor keys (if there two list boxes, you can move up and down in the 
second one by holding down the shift key when you use the cursor keys). 
Finally, if there are up and down arrow buttons, you can use the up and down 
cursor keys to select them as well. 
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Entering 

As you type, the characters will be placed in the document at the insertion point. If 
you have a range of text selected, the typed text will replace the selection. 

Simply begin typing. Entered text will appear to the left of the insertion point 
as it moves to the right. The text will automatically wrap around at the right 
margin; press the RETURN key only when you want to begin a new paragraph. 

If you want to start a line without creating a new paragraph (for example, 
when typing a tab-delimited table) hold the shift key and press return. This 
creates a forced line break; text to the right of the break starts on the next line, 
but it will always keep the same paragraph formatting as the previous line. 

To keep words from being separated when ProWrite wraps text, insert a non
breaking space between them by holding ALT and pressing the space bar. 

To insert a "soft" hyphen, hold ALT and press the "n" key. A soft hyphen will 
not be displayed unless ProW rite needs to break the word at a line end, 
hyphenating words with soft hyphens will give a more professional appear
ance to your documents. You may also type soft hyphens by pressing ALT with 
the "-" key instead of "n," but this alternative will not work in requesters. 

If you make a mistake while typing, press the BACKSPACE key to erase it. 

ProWrite automatically creates new pages as you type. Page breaks are marked in 
the document window by a blue gap between the white page displays. 

Accents to be placed above characters are not shown on the keyboard, but may be 
created by holding the AL T key while typing certain character keys. These key 
combinations are called "dead" keys because they do not insert characters by 
themselves. Immediately after typing a dead key, type the character which is to 
carry the accent. Accents will only appear over appropriate characters. The 
following table shows the accents produced by the standard USA keymap, other 
keymaps may have different dead keys. 

ALT-f acute accent 
ALT-g grave accent 
ALT-h 1\ circumflex 
ALT-j tilde 
ALT-k umlaut 

Many fonts provide a number of special characters that don't appear on your 
keyboard, such as "®." You may enter any of a font's printable characters by 
dragging down the Edit menu to Insert Item, then choosing Literal from the 
submenu that appears. This displays a requester showing all of the available 
characters in the current font. Simply click the character you want to enter. 
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Most other items in the Insert Item submenu are discussed in the section Format
ting a Document, later in this chapter. 

Invisible Characters 

Certain characters-such as spaces, tabs, and paragraph break markers-are not 
normally visible on the screen. Sometimes it is convenient to make these "invis
ible" characters show up in the display. 

Choose Show Invisibles from the View menu. A check mark will appear 
beside the menu item when invisibles are being shown. To hide invisibles, 
simply choose the Show Invisibles command again. 

After you choose this command, invisibles will be shown in the display as graphic 
symbols. The invisible characters and other items that will be shown are: 

Item 

SPACE 

TAB 

Paragraph break (RETURN) 

Forced line break 
Forced column break 
Forced page break 

Window Display 

small dot 
bold right-arrow 
bold arrow angled down then left 
plain arrow angled down then left 
bold down arrow 
doubled bold down arrow 

(The items in this list that haven't already been discussed are explained in For
matting Paragraphs and Formatting Documents, later in this chapter.) 

When Show Invisibles is turned on, ProWrite will also draw a dotted line around 
the printable area of the page. Any text or pictures that is outside of this dotted line 
will not be printed. See Printing a Document in this chapter for more information 
about the printable area of the page. 

Inserting 

You needn't always enter text at the end of a document. You can simply click the 
spot in the document where you want to insert new text. This places the insertion 
point at the spot you clicked. When you start typing, new text will appear to the 
left of the insertion point as it pushes the rest of the text to the right. Text pushed 
off the right margin will re-wrap and push old text down the page. 

It is possible to select a special-purpose "typeover" editing mode, in which the 
characters you type are not inserted, but simply replace any text that might already 
be present to the right ofthe insertion point. See Setting ProWrite Options, later 
in this chapter. 
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There are many keyboard shortcuts for moving the insertion point in the document, 
a summary is listed below. 

Use the left and right cursor keys to move left and right by a single character. 
Use the up and down cursor keys to move up or down by one line. 

Press sHIff-left and sHIff-right to move left or right by a word. 
Pless SHIff-UP and SHIff-down to move up or down by a window-full. 

Press ALT-left and ALT-right to move to the beginning and end of a sentence. 
Press ALT-Up and ALT-down to move to the beginning and end of the docu
ment. 

Selecting 

If you want to do anything to old text (besides just push it aside), you must first 
select the text you wish to work with. A list of selection techniques follows. 
Selected text will appear white on a black background if the character color was 
black; otherwise the text will appear in a contrasting color on a black background. 
Most commands and actions affect only the selected text, if there is any. To de
select the text, just click somewhere else in the window. 

Here is a summary of ways to select text: 

Click (with the left mouse button) just to the left of the text to be selected and 
drag the pointer to the right across the text. Then release the mouse button. 
You can drag across multiple lines if desired. 

To select a whole word at once, double-click anywhere on the word; then drag 
to select additional complete words at the same time. 

To select a whole sentence at once, triple-click anywhere in the sentence; then 
drag to select additional sentences at the same time. 

To select a whole paragraph at once, hold ALT and double-click anywhere in 
the paragraph; then drag to select additional paragraphs at the same time. 

To select a large block of text click at the beginning of the block, scroll the 
document in the window if necessary, then hold down the SHIff key and click 
at the end of the block. SHIff-double-click will extend the selection to include 
the rest of any partially selected words. sHIff-triple-click includes the rest of 
any partially selected sentences. 

To select the entire document, choose Select All from the Edit menu. Holding 
ALT and triple-clicking does the same. 
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Use the CTRL (control) key with the cursor keys to select text that the insertion 
point passes over (see Shortcuts later in this chapter for additional informa
tion on selecting text from the keyboard). 

Deleting 

After entering text you may want to correct an error or make a change that requires 
a deletion. As with selecting text, there are several ways to do this: each may be 
best suited to a certain type of deletion, according to your own preference. You 
can undo any of these delete operations by choosing Undo from the Edit menu. 

Select the text to be deleted. Then choose Erase from the Edit menu. 

Select the text to be deleted. Then choose Cut from the Edit menu. The 
selected text will be erased from the document but will be stored in an internal 
clipboard (See Cutting, Copying, and Pasting in this chapter). 

Select the text to be deleted. Then press the BACKSPACE key or the DEL key. 

Select the text to be deleted. Then simply begin typing; the new text will 
replace the selection. 

Place the insertion point just to the right of the error and BACKSPACE over it. 

Place the insertion point just to the left of the error and press the DEL key. This 
will erase one character at a time; the text to the insertion point's right will 
flow in to fill the space. 

Place the insertion point to the right of a word you want removed and press 
SHIFf-BACKSPACE. This will delete to the beginning of the previous word. 

Place the insertion point at the beginning of a word you want removed and 
press SHIFf-DEL. This will delete to the beginning of the next word. 

Place the insertion point at the end of a sentence you want removed and press 
ALT-BACKSPACE. This will delete to the beginning of the sentence. 

Place the insertion point at the beginning of the sentence you want removed 
and press ALT-DEL. This will delete to the beginning of the next sentence. 
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Cutting, Copying, and Pasting 

To move selected text within a document, you Cut it from one place and Paste it 
into another. You can also Copy selected text without removing it, then paste the 
copy as many times as you like. The cut or copied text is stored in an internal 
clipboard, replacing any text that may already be there from a previous Cut or 
Copy command, and remaining there until the next one. Below is the sequence 
involved in moving or copying text within a document. You can undo any of these 
operations by choosing Undo from the Edit menu. 

Select the text to be moved or copied. 

• To move the selected text, choose Cut from the Edit menu. The selected 
text will disappear from the document and be stored in the clipboard. 

• To copy the selected text, choose Copy from the Edit menu. The selected 
text will remain in the document unchanged, but a copy of it will be 
stored in the clipboard. 

Place the insertion point where you want the cut or copied text to be placed, or 
select text to be replaced. 

Choose Paste from the Edit menu. The cut or copied text will appear after the 
insertion point or in place of the selected text. 

This technique can also be used to move or copy text between documents. First 
Open both of the documents (they will appear in separate windows, which you 
may arrange by using their "front" and "back" gadgets). Use Cut or Copy to copy 
a selection from one document, then activate the other document's window and 
use Paste as usual to put the copied text into it. 

Clipboard 

ProWrite supports the Amiga's system "clipboard" for cutting and pasting both 
text and pictures. This allows you to use ProWrite's Cut, Copy, and Paste 
commands to directly exchange text and pictures between ProWrite and other 
programs that support the system clipboard. 

In order for ProWrite to be able to use the system clipboard, you must have the 
files "clipboard.device" in the "devs" directory of your system disk, and the file 
"iffparse.library" in the "libs" directory of your system disk. If these system files 
are not available, ProWrite will warn you that full clipboard support is not avail
able (you can turn off this warning if you don't plan on using the system clip
board). These files are included on ProWrite's "Fonts & Devices" disk; you can 
use the "System Mover" program on that disk to install them on your system disk. 
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When ProWrite cuts or copies text to the clipboard, it copies two versions: a 
version with full formatting information, and a version with only the text of the 
selection. Programs which understand ProWrite's full formatting will automati
cally use that version from the clipboard, others will use the text-only version. 

Unfortunately, not all programs which support the system clipboard support it 
properly. Some programs may have problems reading information from the 
clipboard when both versions of the information are present. To exchange text 
with these programs, you need to tum off ProWrite's "full" clipboard support, so 
that ProWrite will only save the text version of the information. 

Choose Preferences» General from the Edit menu. A requester will appear. 
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Tum off the "Full clipboard support" check box . 

Click the "OK" button , or press the RETURN or ENTER key. 

Turning off full clipboard support will also disable the error message that appears 
when the c1ipboard.device or iffparse.library files are not installed. You can make 
this your default setting by choosing Settings » Save from the Project menu. See 
the Program Settings section later in this supplement for more information about 
default settings. 

Changing Capitalization 

ProWrite makes it easy to quickly change the capitalization of a character or a 
selected range of characters, even for accented characters. You can change the 
selected letters to all capitals, all lower case, or mixed case (so the first letter of 
each word is capitalized). You can undo this operation by choosing Undo from the 
Edit menu. 

Select the text you want to change. 
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Click on the Edit menu title and drag to Change Case. A submenu will 
appear that lists the three choices. 

Choose UPPER CASE, lower case, or Mixed Case from the submenu, 
depending on the capitalization required. 

Finding and Changing 

You can tell Pro Write to search a whole document for a specific word or phrase 
and, if desired, replace any or all occurrences of that text with something else. If 
you choose Find from the Search menu, a requester will appear that has a text box 
for you to enter the text to search for. If you choose Change, a similar requester 
appears, but this one has a second box for you to type new, replacement text. 

The text boxes will hold up to 100 characters and will scroll as you type in text. 
Use the left and right cursor keys to move within a text box, holding the SHIFf key 
as well to move quickly to the beginning or end of its contents. To erase the 
contents of the text box, hold down the right Amiga key and press "X". 

In both the Find and Change requesters you may select check boxes to indicate 
that ProWrite should find the text only where it appears as a whole word and/or 
where a prospective word's upper and lower case characters match the search text. 

ProWrite will also search for certain non-text characters. To find a space, type a 
space into the "Find" text box by pressing the space bar. Locate a tab by pressing 
the TAB key. To find a soft hyphen, use ALT-n. 

To simply find text, follow the procedure outlined below. 

Place the insertion point in the document where you want the search to start. 

Choose Find from the Search menu. A requester will appear. 

c tim 

Find: ~isor · 

Itlole Nord ~tch UpperJ'lower Case 

Type the text you want ProWrite to find (the text box is preselected; you don't 
have to click in it). 

Select the "Whole Word" option if you wish to match only whole words. 
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Select the "Match Upper!Lower Case" option if you wish an exact match of 
upper and lower case. 

Click on the "Find" button, or press RETURN or ENTER to start the search. 

After confirming the "Find" operation, the Find requester will disappear from the 
window and the located text will appear highlighted in the document. Choose Find 
Next from the Search menu if you want Pro Write to find the next occurrence of 
the text in the document. 

The search goes from the insertion point to the end of the document, at which 
point you are asked if you want to start over at the beginning (unless that is where 
you started). If the text has not been found, ProWrite will display the message 
"Text Not Found." 

To find and change text, follow this procedure: 

c 

Place the insertion point in the document where you want the search to start. 

Choose Change from the Search menu. A requester will appear. 

Find: scr 

ChMge to: PJijiit~tMnt Hiid 
ata1ch ~Aawer Case 

Cha1ge. !hen r Inti [ChAnGe RII 

Type the text you want ProWrite to find. It will appear in the "Find" text box, 
which is preselected (you don't have to click in it). 

Select the "Whole Word" option if you wish to match only whole words. 

Select the "Match Upper!Lower Case" option if you wish an exact match of 
upper and lower case. 

Click on the "Find" button, or press the RETURN or ENTER key to start the 
search. 

When the text is located and selected in the document, the "Change to" text 
box will be selected. Type what you want ProWrite to change the located text 
to. If you leave the "Change to" text box empty and select one of the change 
buttons, ProWrite will delete the located text. 
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Now you have several options. You can click on the "Change" button to change 
the located text. Or, you may instruct ProWrite to change the text and then find the 
next occurrence in the document by clicking on the "Change, Then Find" button. If 
you click on the "Change All" button, ProWrite will find and change all the 
occurrences of the text in the document automatically. 

Click on the appropriate button to begin the change. 

The search goes from the insertion point to the end of the document, at which time 
you will be asked if you want to start over at the beginning (unless that's where 
you started). 

Going to Specific Pages 

In addition to finding and changing text in the document, you can also go directly 
to a specific page. For example, if you want to start working on a section of your 
document that is on page three, you can send the insertion point directly to that 
page rather than scrolling around the document hunting for it. 

Choose Go To Page from the Search menu. A requester will appear with a 
text box where you can type the number of the page you want to go to. 

Go to page: 

Type the page number and press RETURN or ENTER, or click the "OK" button. 

The page number indicator in the bottom left comer of the window indicates which 
page is currently being displayed in the window. You can click this indicator to 
call up the Go To Page requester directly, without using the menus. 

Going to the Selection 

There may also be times when you have been scrolling around in a document and 
you want to return to the place you were editing. You can do this easily by 
choosing Go To Selection from the Search menu. The document will be scrolled 
in the window so that the insertion point or selection is visible. 
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Setting and Going to Bookmarks 

ProWrite can set a mark to hold the current editing spot, then return to that spot at 
a later time. Each open document has its own bookmark, but there is only one 
bookmark per document. 

Place the insertion point where you wish to set the bookmark. 

Choose Set Bookmark from the Search menu. 

Now you are free to edit anyplace in the document; the bookmark will remain set 
until you quit ProWrite, or delete the paragraph containing the bookmark. You can 
return to that bookmark at any later time, so long as the paragraph containing the 
bookmark has not been deleted. 

Choose Go To Bookmark from the Search menu. 
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ProWrite is capable of undoing many of the common mistakes made when 
creating a document. Whenever you perform an operation on the document, the 
first command in the Edit menu (which we'll just call Undo) changes to show 
whether the last action was undoable. For instance, if the last command was a Cut, 
the Undo command reads "Undo Cut." If the last command is one of the few that 
can't be undone, the Undo menu item is dimmed and says "Can't Undo." If the 
last command you chose was Undo, then an appropriate "redo" command (such as 
Redo Cut) will appear in the Edit menu so you can undo the undo. 

Note that the Undo command must be chosen immediately after the operation you 
want to undo. Even moving the insertion point will make it impossible to undo the 
last action, although you can use the scroll bars to scroll around in the document 
without affecting the undo operation. 

The operations that ProWrite can Undo are: 

Cut 
Paste 
Retain Format 
Apply Format 
Change Case 
Style changes 
Alignment changes 
Line Height changes 
Show Invisibles 
Moving a picture 
Typing 

Copy 
Clear 
Retain Style 
Apply Style 
Font changes 
Color changes 
Spacing changes 
Ruler changes 
Show Ruler 
Re-sizing a picture 
Deleting 

Examples of operations that ProWrite cannot undo include opening a document, 
closing a document, saving a document, quitting, and so on. 
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Formatting Characters 

To specify a font: 

Text formatting involves character type, style, size and color, as well as paragraph 
formatting and document layout considerations which are covered by the follow
ing two sections. This section describes how to set the format of individual 
characters. You can undo any of these operations by choosing Undo from the Edit 
menu. 

Character formatting commands may be found in the top section of the Format 
menu. These commands can be used to either change text you have already typed, 
or to affect how the text you are currently typing is to be displayed and printed. 

Changing Character Fonts 

Afont is simply a specification of what shape and size each character of your text 
will be. You can set text to any font which is installed in your system; for details 
about installing fonts and other system files, see Appendix A: Moving System 
Files. ProWrite can handle over 32,000 fonts installed on your system, allowing 
you virtually unlimited flexibility in font handling. 

With ProWrite, you can use any font size, not just those you have installed on your 
system. If you request a font size that is not installed, ProWrite will handle it 
slightly differently, depending upon which version of the operating system you are 
using: 

If you are using Kickstart 1.2 or 1.3, ProWrite will use the closest smaller font 
SIze. 

If you are using Kickstart 2.0 or later, ProWrite will automatically create a 
font of the correct size by scaling an existing font. 

If you have the Compugraphic outline font system installed in your system 
(which is supplied with Kickstart 2.04 and later), ProWrite will generate a font 
of the correct size from the font outline information. 

Specifying font is very simple. 

Choose Font» Other from the Format menu. The font requester will appear. 
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Font 1laIIIe: 

L.ist In Font Wenu 
Show SaRple 

Size: 

~he quick brown fox jumps ov 

Choose the name of the font you wish you use by clicking on the font name. 

If you wish to use a font size that is already installed in your system, click on 
the size in the size list. 

If you wish to use a different size than those listed, click in the size text box 
and type the size. 

Click on the "Use" button to use the selected font. 

The Font command on the Format menu also displays a submenu of a list of fonts, 
for quick access. You can specify which fonts to have listed in the submenu, and 
this custom list is saved with your ProWrite Defaults file when you choose 
Settings» Save. 

Choose Font» Other from the Format menu. The font requester will appear. 

Select the font you want to have added or removed from the font submenu. 

Tum on or off the "Show In Font Menu" check box. Up to 18 fonts can be 
listed in the font submenu. 

Click on "Done" to keep the changes to the font submenu without changing 
the currently used font. Click "Use" to also use the selected font. 
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When using the font requester, Pro Write will nonnally show a sample of the 
selected font in the bottom of the requester. However, when using the outline fonts 
that are supplied with Kickstart 2.04, generating the font sample display can be 
time consuming. Therefore, ProWrite gives you a method of turning off the font 
sample display. 

Tum off the "Show Font Sample" check box in the font requester. 

ProWrite's System disk includes a number of fonts which are specifically designed 
for use in the NLQ and Draft printing modes. They are named "Pica," "Pica 
Wide," "Elite." "Elite Wide," "Condensed," "Condensed Wide," 
"UltraCondensed," and "UltraCondensed Wide." These screen fonts closely match 
the sizes of common print pitches found in most printers, so that you can use 
whatever pitches the printer supp0l1s simply by choosing the appropriate fonts and 
printing in NLQ or Draft mode. For more details about printing modes, see 
Printing a Document later in this chapter. 

The "Pica" and "Elite" fonts should closely match your printer's similarly named 
print pitches; their widths are 10 and 12 characters per inch (cpi), respectively, and 
their "Wide" variants are twice as wide (5 and 6 cpi). 

The condensed fonts are a special case: although there are two condensed pitches 
commonly in use, 15 and 17 cpi, the Amiga's printing software only supports one. 
Since there is no way for ProWrite to know the actual size of your printer's 
"condensed" printing, both "Condensed" (15 cpi) and "UltraCondensed" (17 cpi) 
fonts are provided so you can edit in the condensed type size that your printer 
supports. These font's "Wide" variants are sized to 7.5 and 8.5 cpi, respectively. 
You may need to test your printer to see which condensed font yields the most 
accurate margins; a list of which fonts you should use on printers we have tested is 
included with ProWrite. 

Changing Character Styles 

The Style submenu controls style and position (superscript or SUbscript) of 
characters. There are several different character styles that you can use with 
ProWrite. You can have your characters appear in Bold, Italic, Underlined or 
Shadow style, or any combination of the four. You can also have characters 
appear in superscript or subscript locations on the line. 

Select the text that you want to change. 

Choose the character style or styles you want (Bold, Italic, Underline, or 
Shadow) from the Style submenu of the Format menu. If the selected text 
already has the style you choose, then choosing that style again will tum it off 
(for example, if the selected text is already bold, choosing Bold again will 
remove the bold style). 
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For best results with the Shadow style, set the shadowed text to be some other 
color besides black (color will be discussed in a moment). 

If you want the selected text to be in superscript or subscript positions, choose 
Superscript or Subscript from the Style submenu. As with other style 
options, if the selected text is already in a superscript or subscript position, 
choosing the command again will tum the style off. For the best appearance, 
you should decrease the font size of superscripts and subscripts; for example if 
your text is in the font Topaz-II then you should have all superscripts and 
subscripts in the font Topaz-8. 

If you want to remove all character styles from the selected text, choose Plain 
from the Style submenu. 

Changing Character Colors 

You can set the colors of your text to any of the seven colors available on most 
color printers. 

Select the text that you want to change. 

Choose the color you want (Black, Red, Yellow, Green, Cyan, Blue, or 
Magenta) from the Color submenu of the Format menu. If you are not using 
an eight-color screen, the color's names will be spelled out; otherwise the 
equivalent screen colors will be shown in the submenu. 

Affecting New Text 

If you don't first select a range of text before you choose a font, style, or color, 
then the attributes you have set will be used only for newly typed text. For 
example, if instead of selecting text you place the insertion point, then choose 
Bold and start typing, the text you type will be in bold. 

Retaining and Applying Character Styles 

Once you have set up a particular character style, it is easy to copy that style to 
another selection of characters, as well as the character's font and color. You can 
undo either the retain style or apply style operation by choosing Undo from the 
Edit menu. 

Either select a character or place the insertion point immediately to the right 
of a character whose formatting you wish to copy. 

Drag down the Edit menu to the Retain item, a submenu will appear. 

Choose Style from the Retain submenu. 
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Select the range of text that you wish to copy the formatting to. 

Drag down the Edit menu to the Apply item, a submenu will appear. 

Choose Style from the Apply submenu. The selected text will now have the 
font, style, and color of the character you copied from. 
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In ProWrite, a paragraph is considered to be any combination of characters you 
type before pressing the RETURN key, which creates an invisible paragraph mark 
and starts a new paragraph. Paragraph marks can be made visible by choosing 
Show Invisibles from the View menu; a check mark by the command will indicate 
that it has been chosen~hoose this command again to tum it off. 

Each paragraph may be formatted by changing attributes such as margins, justifi
cation, tabs, and spacing. Every paragraph has its own format. When you join two 
paragraphs by deleting any paragraph marks between them, the upper paragraph's 
formatting attributes are used to format the new joined paragraph. 

Setting Paragraph Format 

The lower two sections of the Format menu control most paragraph formatting 
attributes, such as justification, spacing, and tab type. A paragraph's tab stops and 
margins are set by using the ruler. We'll discuss the menu commands first. 

To format a paragraph, first place the insertion point in the paragraph you wish to 
change, or select a range of paragraphs that you wish to change (any paragraph 
whose text is even partially selected will be affected). Then choose the formatting 
options or set the ruler to the desired settings. You can undo these changes by 
choosing Undo from the Edit menu. 

There are four types of text alignment to choose from: left aligned, centered, 
right aligned, and justified (aligned on both left and right margins). Choosing 
a particular alignment will automatically tum the previous alignment off. 

Lines of the selected paragraphs may be set to Single spaced, 1-112 spaced, or 
Double spaced by choosing the appropriate command from the Spacing 
submenu, under Format. As with alignment, choosing one of these spacings 
will tum the others off. 

If you want an extra blank line automatically placed before the beginning of 
the paragraph, choose Space Before from the Spacing submenu. This will 
save you from pressing RETURN twice when starting a new paragraph (it also 
uses less memory). If you prefer, you can choose Space After to have the 
space placed after the paragraph instead, or choose both for the same para
graph. 
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Nonnally the lines of a paragraph increase or decrease in height as needed to 
accommodate each line's largest font without overlapping adjacent lines. 
There may be times when you don't want the line height to change, though, 
for example when using superscripts or subscripts in NLQ or Draft mode. At 
such times, choose Fixed from the Line Height submenu of the Format 
menu; this presents a requester in which you may set a specific line height in 
pixels. There are pre-set options for "6 Ipi" (six lines per inch, good for Pica 
text) and "8 lpi" (for Elite). To return to automatic line heights, choose Auto. 

Using the Ruler 

The horizontal ruler is used to place markers for paragraph margins, first line 
indent, and tab stops. The vertical ruler is designed to help you position text and 
pictures. These rulers can be graduated in any of several different measures, 
including inches and centimeters. As with the paragraph fonnatting commands in 
the Format menu, the changes you make to the ruler affect only the selected 
paragraphs. You can undo individual changes to the ruler by choosing Undo from 
the Edit menu. 

Choose Show Ruler ~~ Horizontal from the View menu to show or hide the 
horizontal ruler. Choose Show Ruler» Vertical from the View menu to show 
or hide the vertical ruler. 

Note that the most of the ruler is a light color, but near the right, left, top, and 
bottom edges of the page it is shaded grey; this denotes a region of the page on 
which you cannot print-most printers cannot print all the way to the edge of the 
paper. Beyond the edge of the page the ruler's top portion is black. For best results 
you should make sure your margin settings are always in the light colored region 
of the ruler. 

There may also be a strip of icons beneath the main part of the horizontal ruler. For 
infonnation about how to use these icons, see Using Ruler Icons later in this 
chapter. 

Drag down the View menu to the Ruler Type item. A submenu will appear 
listing various ruler graduation options. 

Choose the ruler type you wish to work with. The choices are: Inch, CM 
(centimeter), P 10 (10 pitch), P 12 (12 pitch), Picas (6 picas per inch), and 
Points (72 points per inch). 

Inch and centimeter measurement are self explanatory. Picas and Points are 
traditional typesetting measurements which may be convenient at times. 
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The P 10 and P 12 ruler types are designed to match the horizontal spacing of 
mono-spaced Pica (10 cpi pitch) and Elite (12 cpi pitch) printer fonts. Also, while 
the other rulers are marked off from the edge of the page, the P 10 or P 12 types 
start at the edge of the printable region, which is where mono-spaced character 
spacing starts. 

To change the paragraph first line indent setting, click and drag the indent 
marker (the upper half of the triangle pointing to the right) along the ruler. 
The position of the first line indent is indicated by the left side of the marker. 
If you want to create a block-style paragraph (with no first line indentation), 
simply place the first line indent marker directly above the left margin marker, 
so that their left edges line up. 

To change the left margin setting for the rest of the lines of the paragraph, 
click and drag the left margin marker (the lower half of the triangle pointing to 
the right) along the ruler. The position of the margin is indicated by the left 
side of the marker. 

To change the paragraph left indent and left margin at the same time, hold 
down the ALT key and click and drag either the top or bottom markers along 
the ruler. Both markers will then move by the same relative amount. 

To change the paragraph right margin, drag the right margin marker (the 
triangle pointing left) along the ruler. This marker's right edge marks the 
exact location of the right margin. 

You can create a "hanging indent" (like the bulleted items above) by placing the 
first line indent to the left of the left margin. When you create a hanging indent, 
the left margin marker position is treated like a left aligned tab stop, so pressing 
the TAB key will advance to the left margin position. 

Note that when dragging the indent or margin markers you must click exactly on 
the marker, otherwise you will create tab stops (which look like upward pointing 
arrows) on the ruler. 

If you do not create tab stops, then ProWrite will default to having one left-aligned 
tab stop at every half-inch position on the ruler. For most purposes these default 
tab stops will be sufficient, however you can easily create your own specific tab 
stops at any position on the ruler. Each paragraph can have up to ten tab stops 
specified. They can be left-aligned, center-aligned, right-aligned, or decimal
aligned. Right-aligned and decimal-aligned tabs are useful for creating tables 
where each entry is aligned on the right for textual entries, and on the decimal 
point for numeric entries. 



To set tab stops: 

To set the decimal tab 
character: 

To hide or show the 
ruler icon strip: 
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Choose the type of tab stop you would like to create by choosing Left, 
Center, Right, or Decimal from the Tab Type submenu in the Format 
menu. Left creates left aligned tab stops (the normal type); Center creates tab 
stops that align text by its center; Right creates tab stops that align text on the 
right; and Decimal creates tab stops that align on the decimal point. 

Click on the blank part of the ruler just beneath the graduated part, wherever 
you want to place a tab stop; a tab marker will appear. The four different tab 
stop markers look slightly different so you can tell them apart. 

To move an existing tab stop along the ruler, click and drag the tab marker 
along the ruler. 

Remove a tab stop by clicking and dragging the tab marker down until it is off 
of the ruler, then release the mouse button. 

You can specify which character you want decimal tab stops to align on. For 
example, if the number format used in your country uses a comma for the decimal 
point, you can have the decimal tab stops align on a comma. 

Choose Tab Type» Decimal Char from the Format menu; a requester will 
be displayed. 

~IMI char: 

Type the character which you want ProWrite to use for decimal tab alignment 
and click the "OK" button or press the RETURN key. 

Using Ruler Icons 

As mentioned above, you can choose to have the ruler display a strip of icons 
which let you choose any of several paragraph formatting options without using 
the menus or keyboard equivalents. Clicking on one of these icons is equivalent to 
choosing the corresponding menu command. The icon strip itself may be hidden 
even while the ruler is still shown; this is useful for medium resolution screens. 

Double-click the upper, graduated part of the ruler to show or remove the icon 
strip. If the strip is already shown, you may also remove it by double-clicking 
any blank part of the icon strip itself. Remember that clicking in the blank part 
of the ruler will create tab stops. 
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The "Tab Type" icons control the type of tab stop that will be created the next time 
you click on the ruler's margin/tab area; the choices are left, centered, right, or 
decimal-aligned tabs. 

The "Justification" icons control the justification of the selected paragraphs; the 
choices are left-aligned, centered, right-aligned, or fully justified. 

The "Spacing" icons control the spacing of selected paragraphs; the choices are 
single, 1-1/2, or double spacing. 

The "Extra Space" icons control the presence of an optional automatic blank line 
before and/or after each paragraph that is selected; the choices are none, space 
before, and space after. Note that you can select both space before and space after 
for the same paragraph. 

Retaining and Applying Paragraph Formats 

Just as you were able to copy character styles, it is easy to copy a paragraph's 
format to other paragraphs. The format of the paragraph consists of its justification 
(left, center, right, or full justified), spacing (one, one and a half, or double), line 
height (auto or fixed height), space before and/or after, first line indentation, left 
and right margins, and all tab stop settings. You can undo either the retain format 
or apply format operation by choosing Undo from the Edit menu. 

Place the insertion point in the paragraph that has the format you wish to 
copy. If the paragraph does not yet have the format you want, then set its 
format with the Format menu commands and the ruler. 

Drag down the Edit menu to the Retain item, a submenu will appear. 

Choose Format from the Retain submenu. 

Place the insertion point in the paragraph you wish to copy the format to, or 
select the range of paragraphs that you wish to copy the format to. 

Drag down the Edit menu to the Apply item, a submenu will appear. 

Choose Format from the Apply submenu. The selected paragraphs will now 
have the format of the paragraph you copied from. 
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Formatting Documents 

To change document 
margins: 

The Document menu contains commands for laying out document margins and 
columns, and using headers and footers. This section also discusses page and 
column breaks, page numbering, date and time items. This menu's spell checking 
and sorting commands are discussed later in the chapter. 

Document Margins 

In addition to letting you set margins and indentation for individual paragraphs, 
ProWrite lets you set overall margins for your whole document. When you change 
a document's overall margins, the paragraph margins are adjusted by the same 
amount, so that any insets or other indentation you have used will be preserved. 

Choose Layout from the Document menu, a requester will appear. The left 
part of the requester has a set of text boxes for margin settings. 

Margins 
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Set the "Top," "Bottom," "Left," and "Right" margins for your document. 
These numbers are in the units you have specified in the "General Prefer
ences" requester (inches or centimeters), with about three digits of accuracy. 
They are initially set to the edges of the page's maximum printable region 
(that is, the margins outside of which most printers cannot print). 

When you have typed a number into one text box, you can press RETURN to go 
to the next one or SHIFf-RETURN to go to the previous one. If you are at the last 
or first text box, pressing RETURN or SHIFT-RETURN, respectively, is the same as 
clicking "OK." 
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Set the "Binding" margin for your document, if you will be using one. This 
value will be added to either the left or right margin of each page to allow 
room for a binding. See the next two steps for more details. 

Select "Odd/Even Pages" if you want the binding margin added alternately to 
the left margin of odd pages and the right margin of even pages. Otherwise it 
will always be added to the left margin. 

Select the "Title Page" option if you want the binding margin added to the 
first page's left margin, even if it is an even numbered page (as set in the Edit 
menu's Item Formats requester), and "Odd/Even Pages" is tumed on. "Title 
Pages" also disables multiple columns, headers. and footers on the first page. 

When you have finished setting margins, click "OK" or press the ENTER key. 

Multiple Columns 

ProWrite also allows you to set up multiple column documents of two different 
types. In newspaper-style "snaking" columns, the text continues from the bottom 
of one column to the top of the next. In "side by side" columns, each new para
graph starts on the next column over, with the paragraph's first lines aligned side
by-side. The column type icons in the Layout requester illustrate the two types of 
columns. 

Choose Layout from the Document menu, a requester will appear. The right 
part of the requester has a group of column options. 

Click the up or down arrow gadgets next to the "Number" label to increase or 
decrease the number of columns to be used in your document. You may have 
as many as ten columns per page. 

Set the "Gap Between" text box to the desired column separation in inches. 
This represents the minimum separation, any paragraph margin and indenta
tion settings that you have made will be repositioned relative to the column 
margins. This could cause odd effects if you set deep indentations and then 
choose multiple columns. 

Click the left-hand column icon to set "Snaking" columns. Click the right
hand icon to set "Side-by-Side" columns. 

Select the "Title Page" option in the Document menu's Layout requester if 
you want to disable multiple columns on the first page of your document. This 
option also disables headers and footers, and forces the binding margin to 
always be added to the left margin of the first page. 

When you have finished setting up columns, click "OK" or press the RETURN 

or ENTER key. 



To show page guides: 

To insert a page break: 
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Page Guides 

You can have the boundaries of the margin and column settings shown in the 
document window. This is useful for determining the appearance of the layout 
before you place the text into the document. 

Choose Show Page Guides from the View menu. A check mark will appear 
beside the command. To hide the page guides, simply choose the Show Page 
Guides command again. 

The page guides will appear as dotted lines showing the page and column margins. 
Note that these page guides are different from the outline of the page's printable 
area shown by the Show Invisibles command, although the two will coincide 
when you are using ProWrite's default margin and column settings. 

Page Breaks 

When you type past a page's lower margin, ProWrite automatically creates a new 
page and moves the insertion point to its top line. Sometimes you might want to 
force a page break at a specific location in the document, such as when you want 
to begin a new section of the document. 

Make sure you are currently editing the document, not a header or footer, by 
choosing Edit Document from the Document menu. 

Put the insertion point where you want the page break to appear. 

Choose Page Break from the Insert Item submenu of the Edit menu. The 
insertion point will move to the beginning of the next page. Pressing ENTER has 
the same effect, but only if you are editing in the document display. 

To remove a page break place the insertion point at the beginning of the next 
page and press the BACKSPACE key; or put the insertion point at the end of the 
previous page and press DEL. 

Column Breaks 

If you have set multiple columns, ProWrite will automatically proceed to the next 
column if you either type off the column's end (in snaking columns) or press 
RETURN (in side-by-side columns). Sometimes you might want to force a column 
break at a specific location in the document. In snaking columns, a column break 
forces editing to the top of the next column (or the next page, if the last column 
has been reached). In side-by-side columns, a column break forces editing to the 
next position down in the page's first column (or to the next page, if the bottom of 
the first column has been reached). 
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Make sure you are currently editing the document, not a header or footer, by 
choosing Edit Document from the Document menu. 

Put the insertion point where want the column break to appear. 

Choose Column Break from the Insert Item submenu of the Edit menu. The 
insertion point will move to the next column. Pressing SHU-T-ENTER has the 
same effect, but only if you are editing in the document display. 

To remove a column break, place the insertion point at the beginning of the 
next column and press the BACKSPACE key; or put the insertion point at the end 
of the previous column and press DEL. 

Headers and Footers 

A header or footer is text that will appear at the top or bottom of every page. A 
separate editing display is used to edit a header or footer, but you can use any of 
the normal document editing techniques in the header and footer displays; see 
Editing Text if you need to review these techniques. Once they are created, you 
can choose to make them disappear or reappear in the document. 

To create a new header or footer or edit an existing one, choose Edit Header 
or Edit Footer from the Document menu, or simply double-click on an 
existing header or footer in the document. Then type and format your header 
or footer text exactly as you want it to appear. A header or footer can have 
several lines, and you can use any character or paragraph formatting you want. 

When you begin editing a header or footer, the respective Show Header or 
Show Footer menu option will be turned on automatically. 

To move back to the main document, choose Edit Document from the 
Document menu or click the header or footer display's close box. 

The Show Header or Show Footer menu options appear with a check mark 
beside them if they are active, in which case the corresponding text will be 
displayed and printed with the document. Choosing either option while it is 
active will tum it off; choosing it again turns it back on. 

Choose Layout in the Document menu and select the "Odd/Even Pages" 
option if you want different headers and footers on odd and even pages. When 
you have chosen this option, the Edit Header and Edit Footer menu items 
will display submenus from which you can choose to edit either the odd or 
even header or footer. If you tum "Odd/Even Pages" off again, the odd-page 
header and footer will be used for all pages. 



To insert page numbers: 

To change page 
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Choose Layout in the Document menu and select the "Title Page" option if 
you do not want headers or footers to appear on the first page of your docu
ment. This option also disables columns and forces the binding margin to the 
left on the document's first page. 

Page Numbering 

You can have page numbers automatically show up anywhere in your document. 
These are especially useful in headers and footers. A document's page numbers 
can be one of several different fomlats, such as Arabic, upper or lower case roman, 
and upper or lower case alphabetic. Page numbers can be shown in any font or 
character style, and are treated just like a single character for editing purposes. 
You can also have the page numbering start from a number other than one. This is 
useful if you have a title page and you want the second page to be page number 
one, or if you are writing a long article or book and you have each chapter in a 
different file. 

Place the insertion point at any place in the document, header, or footer 
display where you want to insert a page number. 

Choose Page Number from the Insert Item submenu of the Edit menu (in 
the header or footer editing display , you can just press the ENTER key instead). 
The current page number will appear at the insertion point. In the header or 
footer editing display, this number is always the starting page number; 
otherwise the number will always match the number of the page it is on. The 
page number's digits are treated like a single character for editing purposes, so 
you can select them and change their formatting just as you would a single 
character. 

You can change the format of page numbers either before or after you enter them. 
ProWrite provides several different to choose from. 

Choose Item Formats from the Edit menu. A requester will appear. 
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Click on the page number style you wish to use, and type a starting page 
number. If your document has a title page and you want page number one to 
be the second page of the document, make the starting page number zero. 
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When you have set the page numbering style and starting page number, click 
the "OK" button or press the RETURN or ENTER key. 

Page Count 

You may want to use a page numbering format like "Page (which) of (how many)" 
in your documents. To do this, you can insert a page count item in much the same 
way that you inserted page numbers. 

Place the insertion point at any place in the document, header display, or 
footer display where you want to insert a page count. 

Choose Page Count from the Insert Item submenu of the Edit menu (in the 
header or footer editing display, you can just press SHIfT-ENTER instead). The 
current page count will appear at the insertion point. The page count will use 
the same numbering style set for the page number, and it may be moved and 
edited in the same way. If you have set a starting page number other than one, 
the page count will adjust itself accordingly. 

Date and Time 

ProWrite can place the Amiga system's current date and/or time anywhere in the 
document. The date can be inserted either as fixed text (just as if you typed it 
yourself), or as an item, like a page number, that keeps itself up to date. You can 
also choose 12 or 24-hour time format, and one of six common date styles. 

Place the insertion point at any place in the document, header, or footer 
display where you want to insert a date or time item. 

To insert an updating date or time item, choose Date or Time from the Insert 
Item submenu of the Edit menu. The date or time will appear at the insertion 
point. The number will be treated as a single character for fomlatting, and it 
will be updated whenever the document it is in is re-drawn or printed. 

To insert non-updating date or time text, hold down the ALT key and choose 
Date or Time from the Insert Item submenu of the Edit menu. The date or 
time will be inserted just as if you had typed it yourself. 

You can change the format of the date or time markers either before or after 
entering them into the document. 

Choose Item Formats from the Edit menu. A requester will appear. 

Click on the time and date style you wish to use. 
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When you have set the time and date style, click the "OK" button or press the 
RETURN or ENTER key. All updating date and time markers will be changed to 
the new format. Non-updating text items will not change, but newly inserted 
ones will be in the new style. 
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ProWrite has a built-in spelling checker with a dictionary of over 100,000 words 
(there is also a smaller dictionary of 50,000 words on the ProW rite Program disk 
which is more convenient to use if you do not have a hard disk). You can also add 
your own words to a "User Dictionary" for words that are not in ProWrite's main 
dictionary, words such as personal names and technical tenns that are unique to 
your occupation or interests. You can create the user dictionary yourself or have 
ProWrite create it for you as it comes across words it does not know. 

ProWrite also has a thesaurus containing over 300,000 synonym cross references. 
With ProWrite's thesaurus you can always find the word that conveys the exact 
nuance of meaning you are searching for. 

ProWrite is also able to sort paragraphs, either alphabetically or reverse-alphabeti
cally. This comes in handy when you are creating an alphabetized list, or when 
you are manually editing ProWrite's user dictionary. 

ProWrite's Dictionary 

Since ProWrite's dictionary is very large, spell-checking a document may take 
some time, especially if you are using the main dictionary on the floppy disk. 
However, ProWrite will automatically use the main dictionary from the RAM disk 
if you have copied it there first. This does use about 250K of memory, but it 
speeds up spell checking by six times or more. Having the main dictionary on the 
RAM disk makes spell checking even faster than having it on a hard disk (about 
twice as fast). 

If the RAM disk does not appear on your Workbench screen, double-click on 
the "RAMStart" icon to start the RAM disk. It may take a few seconds for the 
Workbench to recognize the presence of the RAM disk and put its icon on the 
screen. 

Drag the "Main Dictionary" icon from the Program disk to the RAM disk. The 
copying process could take quite a while. 

If you have already been using the dictionary and do not want to re-start Pro Write, 
you may choose the Change Diet command from the Spelling submenu of the 
Document. A nonnal Open requester will appear in which you may find and 
choose the main dictionary that you want ProW rite to use. 

The "Main Dictionary" and "Thesaurus" files will actually be looked for in three 
places: The RAM disk, the drawer containing ProWrite, and the location of the 
logical assignment "ProWrite:" (if any). This last location is useful if you want to 
put the dictionary or thesaurus on a different disk than ProWrite. For example, if 
you enter the following eLi command before you start using ProWrite: 



To spell-check text: 
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Assign ProWrite: DF1 : 

then ProWrite will also look for the dictionary and thesaurus files on drive DFI: 
(after checking the RAM disk, but before checking the ProWrite drawer). 

Spell Checking a Document 

The spelling checker starts checking at the insertion point and proceeds to the end 
of the document. If you didn't begin the check at the beginning of the document, 
ProWrite will ask if you want to continue from there. You can also have ProWrite 
check only a specific range of text, which is useful if you have just entered some 
new text and don't need to check the whole document. 

Place the insertion point at the location you want the spelling check to begin, 
or select a range of text to be checked. 

Choose Check from the Spelling submenu in the Document menu. A 
requester will appear. 

Click on the "Start" button, or press the RETURN or ENTER key, to start the 
spelling check. The title of the "Start" button will change to "Skip". (If a 
range of text is selected when you choose Spelling» Check, the spelling 
checker will start automatically. This makes it easy to check a single word or 
sentence.) 

If ProWrite comes across a word it doesn't recognize, it will highlight it in the 
document and display it in the requester. You now have several options: 

If the word is spelled correctly and you don't want to save it to your user 
dictionary, click on the "Skip" button. 
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If the word is spelled correctly and you do want to save it to your user 
dictionary, click on the "Learn" button. 

If the word is not spelled correctly, you can type the correctly spelled word in 
the text box and then click on the "Change" button. The word will be replaced 
by the word you type. The new word will be checked as well. 

To see a list of possible alternatives, click on the "Guess" button. After a few 
seconds ProWrite will display all similar words in the list box. If you see the 
correct word in the list box, either click on the word and click on the 
"Change" button, or simply double-click on the word. The word will be 
replaced by the word you selected. 

When ProWrite has reached the end of the document, it will tell you that no 
more misspellings were found. 

The user dictionary is saved as a text file on the same disk and drawer as the 
ProWrite program and is automatically kept in alphabetical order. If you want to 
edit the user dictionary directly (either to add or remove words), you should make 
sure you add words in the correct alphabetical place, and you must be sure to save 
it in "Text Only" form. An easy way to sort the words is by choosing Select All 
from the Edit menu, then choosing A to Z from the Sort submenu of the Edit 
menu. Changes you make this way will not take effect until the next time you run 
ProWrite. 

Note: ProWrite considers all words of a single character to be valid words. It also 
considers any word that contains numbers to be a valid word. Although contrac
tions are checked (words like don't, isn't, and so on), all possessives ('s) are 
removed before checking the word, as are all initial and trailing apostrophes. 

Looking Up Spellings 

In addition to having ProWrite check the spelling of the words you have already 
typed, you can have it look up the correct spelling for words that you are not sure 
about, and have the correct word automatically entered into the document. 

Choose Look Up from the Spelling submenu of the Document menu. A 
requester will appear. 

Type in the approximate spelling of the word you want, and click on the 
"Look Up" button or press RETURN or ENTER. After a few seconds a list of 
similarly spelled words will appear, with the best matching word selected in 
the list and entered in the text box. 
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If you want one of the listed words inserted into your document, either click 
on the word (if it is not the one that is already selected) and click on the 
"Insert" button, or simply double-click the word itself. The selected word will 
be inserted just as if you typed it yourself. 

Automatic Spell Checking 

You can also have ProWrite continuously check the spelling of the words you 
type. This will guarantee that every word you type is correctly spelled, without the 
need of going through a separate spell-checking routine. Note, however, that this 
option is only recommended for those who have their dictionary on the RAM disk 
or on a hard disk. 

Choose Spelling» While Typing from the Document menu. A check mark 
will be shown next to the option when it is turned on. 

With this option turned on, ProWrite will notify you by beeping and/or flashing 
the screen whenever you type a word that is not in its dictionary. At this point you 
can either correct the misspelling yourself, or let ProWrite find and substitute the 
correctly spelled word for you. 

Immediately choose Look Up from the Spell submenu of the Document 
menu. The misspelled word will already be entered into the text box. 

Click on the "Look Up" button or press RETURN or ENTER. In a few seconds the 
list of similar words will be shown, with the best choice selected as usual. 

If you see the correct word, either click on the word in the list (if it is not the 
one that is selected) and click on the "Insert" button, or simply double-click 
on the word. The selected word will replace the misspelled word in the 
document. 

Using the Thesaurus 

In addition to a spelling dictionary, ProWrite provides a thesaurus with over 
300,000 cross-references. This thesaurus may be used to find a list of synonyms, 
or words with meanings similar to that of a word of your choice. Like the spelling 
dictionary, the thesaurus must either be in the same drawer with ProWrite, or in 
the RAM disk. 

If the word that you want synonyms for is in your text, either select that word 
or just place the insertion point within it. 

Choose Thesaurus from the Document menu. A requester will appear. The 
word you have placed the insertion point in will be selected in your text and 
pre-entered into the "Look Up" text box, and ProWrite will automatically look 
up the synonyms. 
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After a few seconds a list of words with similar meanings will appear. The list 
is divided into sub-lists by parts of speech and similar meaning. 

If you want to see more synonyms for one of the listed words, click that word 
and click the "Look Up" button again. A new list of synonyms will appear. 
You can look up the synonyms for listed synonyms as many times as you like, 
browsing through the thesaurus to find just the right shade of meaning. 

After you have looked up a "synonym's synonyms," you can return to the 
previous word and its synonym list by clicking "Prior." If you have browsed 
far, you may click this button repeatedly until you return to the first word that 
was entered into the requester. 

If, at any point, you want one of the listed words inserted into your document, 
either click on the word and click "Insert," or simply double-click the word 
itself. The selected word will be inserted just as if you typed it yourself. 

Document Summary 

In addition to helping you spell check your document, ProWrite can give you 
information about the number of characters , words, lines, pages, sentences, 
paragraphs, and pictures that are in it. This is useful if you need to create a 
document of a particular size or number of words, or if you simply want to get an 
estimate of how large the document will be when you save it to your disk. 

The same facility also shows you the document's average word length, average 
sentence length, and a rough estimate of the minimum grade level at which the text 
would be considered readable. 

Choose Summary from the Document menu. A requester giving the docu
ment statistics will be displayed. 
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When you have noted the numbers of interest to you, simply click on the 
"OK" button or press the RETURN or ENTER key. 

Sorting Text 

You can sort a selected range of text into ascending or descending alphabetical 
order. The items to be sorted must be separated by paragraph breaks. The Sort 
commands make it easy to enter items into a table in any particular order and then 
alphabetize them later. An example would be to edit your personal spelling 
checker dictionary, adding words at random, then sort the dictionary before saving 
so that ProWrite can use it properly (be sure to save as "Text Only"). 

Select the paragraphs you wish to sort. The Sort menu item will be dimmed 
(and therefore unavailable) unless at least two paragraphs are selected. 

Pull down Sort from the Edit menu. A short submenu will appear. 

Choose A to Z for an ascending sort, Z to A for a descending one. 
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Pictures in a Document 

To insert a picture: 
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ProWrite can read picture files created in Amiga paint programs, allowing you to 
place pictures in your document along with the text. ProW rite can read normal IFF 
pictures, such as those created with DeluxePaint, as well as HAM (Hold and 
Modify) pictures, such as those created by DigiPaint, and "Half-Brite" pictures, 
which can have up to 64 colors. 

Picture Data 

When ProWrite loads pictures into your document, it retains the original picture's 
color information. When the picture is displayed on the screen, a translation is 
made from the picture's colors to the closest available screen colors. Therefore, 
pictures will be displayed more accurately if you use screens with more colors. 

ProWrite also maintains the entire picture data, and re-sizes pictures from that. 
This means that repeated picture resizing will not lose any picture information, and 
that you will always get the best quality printout of your pictures. 

ProWrite also supports HAM pictures, as well as 64-color "Half-Brite" pictures 
(also called EHB pictures). However, because of the number of color translations 
involved, displaying these pictures will be slower than other picture types. When 
working with HAM or Half-Brite pictures, you should either leave picture caching 
turned on, or tum off the picture display for best performance. 

Getting Pictures 

To place a picture in your document, you simply specify the picture file name. 

Choose Insert» Picture from the Project menu. The Open requester will 
appear allowing you to pick the picture you want to load. For information 
about using the "Open" requester, refer to the section Loading and Saving a 
Document, later in this chapter. 

The picture will be loaded and displayed in the window's upper right comer. 

You can move a picture around in the Pro Write document by clicking directly on 
the picture (not the background color around it) and dragging it. If you drag the 
picture above or below the window borders the document will automatically scroll 
in the desired direction. 



To re-size a picture: 
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You can also move pictures to other documents by clicking on the picture, 
choosing Cut or Copy from the Edit menu, activating the window you want to 
move it to, and choosing Paste from the Edit menu. You cannot paste pictures 
while editing headers or footers-you must be in Edit Document mode. However, 
while in this mode you can manually drag a picture into the displayed header or 
footer on every page. 

As you insert and delete text in a document, the text that is related to a picture can 
move around. To allow for this, if automatic text wrap is off ProWrite will try to 
move a picture along with whatever paragraph that it's upper edge is closest to. 
This will usually keep the text and pictures in agreement, but unexpected things 
might happen if you are using multiple columns. 

Re-Sizing Pictures 

You can also change the size of pictures you have placed in your document. 

Click on the picture to select it. A "frame" will be drawn around the picture 
that has three small "handles" located on the right side, bottom side, and 
bottom right comer of the frame. 

To re-size a picture horizontally only, click and drag on the right side's 
handle. 

To re-size a picture vertically only, click and drag on the bottom side's 
handle. 

To re-size a picture both vertically and horizontally at the same time, click and 
drag on the bottom right comer's handle. If you want to keep the picture in the 
same proportions while you re-size it, hold down the SHIFf key before you 
click and drag the comer's handle. 

When you release the handle the picture will be re-sized to the new size you 
have indicated. 

Pictures created by DeluxePainflM and DeluxePaint IFM automatically have a 
transparent region wherever the background color of the picture is (refer to the 
DeluxePaint manual for infonnation on how to specify the background color). You 
can type text in the background color of the picture by setting the margins of the 
paragraphs to be inside the transparent portions of the picture (see Using the 
Ruler under Formatting Paragraphs in this chapter, and the examples included 
on the ProWrite System disk). 

In addition to dragging on a picture's handles to re-size a picture, you can also 
specify exact percentages by which you wish to scale a picture. 
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To set text wrap: 
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Select the picture you wish to re-size by clicking on it. 

Choose Picture )) Settings from the Format menu. A requester will appear. 
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In the scaling text boxes, type the percentages by which you wish to scale the 
picture, both horizontally and vertically. Note that these values are relative to 
the picture's original size, not its current size. To restore the picture to its 
original size, type 100 into both text boxes. 

Click on the "OK" button to re-size the picture. 

Automatic Text Wrap 

You can have ProWrite automatically wrap text around the pictures in your 
document. You can have a picture wrap text to the left or right, and either as a 
block or following the curves of the picture. You can also control the amount of 
stand-off distance between the picture and the text. 

Select the picture which you wish to change by clicking on it. 

Choose Picture )) Settings from the Format menu. A requester will appear. 

Click on the icon representing the type of text wrap you want. 

Type the amount of stand-off you want into the "Distance from picture" text 
box. 

Click on the "OK" button to put these settings into effect. 
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Hiding and Showing Pictures 

Pictures can slow down the speed with which a document's display is re-drawn as 
you scroll about in the document. Sometimes it is unnecessary to actually see 
pictures in the document all the time, so ProWrite allows you to hide pictures. 

Choose Show Pictures from the View menu. This item usually is shown with 
a check mark beside it, indicating that pictures will be shown. Choosing the 
command removes the check mark and hides the document's pictures. To 
reveal the pictures, simply choose the Show Pictures command again. 

Pictures are never hidden entirely. When Show Pictures is turned off, pictures are 
replaced by outlines which indicate their size and position in the document. These 
outlines can be re-drawn much more quickly by ProWrite. 

Naming and Finding Pictures 

When you load a picture with the Insert Picture command, ProWrite remembers 
the picture's name. You can use this name to find the picture in the document. 

Choose Find Picture from the Search menu. A requester will appear. 

Click on the name of the picture you wish to find and then click on the "Find" 
button, or simply double-click on the picture's name. 

You can also change the name of the picture. 

Select the picture you wish to rename by clicking on it. 

Choose Picture» Settings from the Format menu. A requester will appear. 

Type the name you wish to give this picture and click on the "OK" button. 

Note that if pictures pasted from the system clipboard, or pictures that are from 
documents created with ProWrite 3.2 or earlier will not have names. To find them 
with the Find Picture command you first must give them a name. 

Arranging Pictures 

When you have pictures that overlap, you can control which pictures appear on top 
of the others. 

Select the picture you wish to change by clicking on it. 

Choose Picture» Move to Front to move the picture on top of the others, or 
Picture» Move to Back to move the picture behind the others. 
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To set picture caching: 
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If you have three overlapping pictures, you can control their overlap with a 
sequence of these commands. For example, to have picture 1 on top of picture 2, 
which in tum in on top of picture 3, follow these two steps: 

1. Click on picture 2 and choose Picture» Move to Front. This will put picture 
2 on top of picture 1 and 3. 

2. Click on picture 1 and choose Picture» Move to Front. This will put picture 
1 on top of picture 2, while picture 2 will still remain on top of picture 3. 

Picture Caching 

As already mentioned, ProWrite keeps the original picture's data and color 
infom1ation, and must translate this information into the screen's number of colors 
and palette when it needs to display the picture. When dealing with large pictures, 
or pictures with a large number of colors, this can be a slow process. 

To avoid having delays when displaying pictures, you can have ProWrite pre-build 
the screen versions of a document's pictures and keep them for when they are 
needed. This is called "Caching" the pictures. 

Choose Preferences» General from the Edit menu. A requester will appear. 

Click on the "Cache Pictures" check box to tum it on or off. 

Click "OK" to use the new setting. 

With picture caching turned on, pictures will be displayed much more rapidly
after a one-time delay to build the cache, which takes place when the picture is 
first displayed. However, since two copies of each picture are maintained (the 
original version and the screen version), this can use up much more memory. 

If you prefer to not use ProWrite's picture caching, you can improve performance 
by using the fewest number of colors in your pictures, and by using only "brushes" 
that contain just the portion of your picture that you need, rather than full-screen 
pictures. t '~ernatively, you can tum off the Show Pictures option in the View 
menu. When Show Pictures is turned off, a picture placeholder will be drawn 
instead of the full picture. 

Miscellaneous 

When you re-size or drag a picture, markers will appear on the horizontal and 
vertical rulers showing the exact location and size of the picture. This helps you to 
position and size the picture to the exact location and dimension you want. 
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You can move a selected picture in single pixel increments by using the cursor 
keys. If you hold down the ALT key when using the cursor keys, the picture will be 
re-sized in single pixel increments. If you hold down the SHIFf and ALT keys 
together when using the cursor keys, the picture will be re-sized proportionally 
(just as if you were holding down the SHIFf key when dragging a picture's handle). 

Finally, double-clicking on a picture will bring up the "Picture Settings" requester 
for that picture. Holding down the ALT key while double-clicking on a picture will 
cause the picture to revert to its original size. 
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To publish a HotLinks 
edition: 

To subscribe to a 
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To update an edition: 
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HotLinks is a dynamic data exchange system developed by Soft-Logik Publishing 
Corp. It is similar to ProWrite's cut and paste operations using the system clip
board, except that a dynamic link is maintained with the original file. 

To use HotLinks, you must first have the HotLinks system installed on your 
system (contact your Amiga dealer or Soft-Logik Publishing Corp. for infonnation 
on obtaining the HotLinks system). You then "Publish" a section of text or a 
picture, either from ProWrite or another HotLinks-aware program, and "Sub
scribe" to it in another program. Published text and pictures are referred to as 
"Editions. " 

If you have subscribed an edition with ProWrite and another program changes the 
contents of the edition, the changes will be automatically incorporated into the 
ProWrite document. Similarly, if you use ProWrite to change the contents of an 
edition that another program has subscribed to, the changes will be automatically 
transferred to the other program as well. 

The following paragraphs describe the basics of using HotLinks with ProWrite. 
For more complete infonnation, refer to your HotLinks User Manual. 

Note: When ProWrite publishes or subscribes to text, the entire text of the 
ProWrite document becomes the edition. If you change and update the 
edition with another HotLinks-aware program, the changes will replace 
the entire ProWrite document. Also, while ProWrite can subscribe to both 
text and pictures, it can only publish text (typically, you would only 
publish pictures from programs that are used to create pictures). 

Place the insertion point anywhere in the document's text. 

Choose HotLinks » Publish from the Edit menu. A requester will appear. 

Specify the name and location for the edition you are publishing. 

Choose HotLinks » Subscribe from the Edit menu. A requester will appear. 

Select the edition you wish to subscribe to. It will be inserted into your 
document. 

HotLinks editions will automatically be updated when you close and save the 
document. You can also have ProWrite perfonn an immediate update. 

Place the insertion point in the text of the document. 

Choose HotLinks» Update from the Edit menu. 



To display information 
about a HotLinks 
edition: 

To break a link: 
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You can also obtain infonnation about editions you have published or subscribed 
to. 

• To display infonnation about published or subscribed text, place the insertion 
point anywhere in the document's text. To display infonnation about a 
subscribed picture, select the picture. 

Choose HotLinks » Information from the Edit menu. 

If for any reason you wish to break the link created by publishing or subscribing to 
a HotLinks edition, you can easily do so. 

• Place the insertion point in the text of the document if you wish to break a text 
link, or select the picture if you want to break a picture link. 

Choose HotLinks » Break Link from the Edit menu. 
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To speak the document: 

To change speaking 
options: 
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ProWrite can use the Amiga's built-in speech synthesizer to read back to you 
either your entire document, selected portions, or each character while you are 
typing. In order for the speaking command to operate, you must have the 
"translator.library" file in your "UBS:" directory, and the "narrator.device" in 
your "DEVS:" directory. 

Select the text you wish to have spoken, or place the insertion point anywhere 
in the document to have the entire document spoken. 

Choose Speaking» Speak Now from the Document menu. The selected text, 
or entire document, will be spoken using the currently set speak settings. 

Speaking occurs in two phases: translation and the actual speaking. During 
translation, the text is translated from English into phonetics, including stress on 
appropriate syllables. The speaking phase takes the phonemes generated by the 
translation and generates the appropriate sounds. Unfortunately, the translation 
phase is not always accurate, and is appropriate only for the English language. 
Therefore ProWrite provides an option to bypass the translation phase and send the 
phonetic codes directly to the speaking phase. You can also adjust several speak
ing parameters, such as speed, pitch, and voice. 

Choose Speaking )) Options from the Document menu. A requester will 
appear. 
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Select the voice, speed, and pitch you want for speaking. 

If you wish to bypass the text translation and send phonetic codes directly to 
the speaking phase, tum on the "Text Is Phonetic" check box. 

To use these speaking options and speak the document, click on "Speak". To 
use these speaking options later without speaking the document now, click on 
"Use". 



To speak while typing: 
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If you are sending phonemes directly to the speaking phase and a phoneme is 
encountered that the Amiga doesn't understand, the speaking will stop and an error 
message will be displayed. You will need to know the phonetic alphabet recog
nized by the Amiga to use this option effectively; refer to the Appendix of the 
Amiga BASIC reference manual, or the "Translator Library" chapter of the Amiga 
ROM Kernel Reference Manual: Libraries and Devices book published by 
Addison Wesley for more information. 

You can also have ProWrite speak every character that you enter into your 
document as it is typed. This may be useful if you have a visual impairment which 
makes it difficult to read the screen-you can hear the name of the characters you 
type and be sure you have typed the correct character. 

Choose Speaking» While Typing from the Document menu. A check mark 
will appear next to the command to show that it is turned on. 

To tum off speaking while typing, choose the Speaking» While Typing 
command a second time. 

The Amiga's speaking system does not currently understand accented characters, 
so those characters will not be spoken. All other alphabetic, numeric, and punctua
tion characters will be spoken. It may also help to increase the speaking speed with 
the "Speak Options" requester when using the speaking while typing feature. 
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Loading and Saving a Document 

To load a document: 
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You may work in more than one window at a time, moving or copying text 
between documents, or just referring to one document as you edit another. Each 
document will appear in its won window on the screen. You can have up to ten 
documents open at the same time in ProWrite, depending upon how much memory 
you have in your system. 

Loading a Document 

Normally, ProWrite will not automatically close existing windows when you open 
another document. This makes it easy to copy material from one document to 
another. Remember, however, that the more windows you have open, the less 
memory you will have available in your computer for editing. Therefore you 
should try to keep as few windows open as possible. 

There is one case when ProWrite will automatically close a window for you: if the 
active window is a New document that you have not typed into, or altered in any 
way, then the document you open will replace the empty window. 

To open an empty, untitled document, choose New from the Project menu. A 
new, empty document window will be displayed. Any existing windows will 
not be closed. 

To open an existing document, choose Open from the Project menu. A 
requester will appear. 

O Show All Files 
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The Open requester contains a list box showing the contents of the disk; drawers 
are listed in italic and have a dash in front of their name. Use the scroll arrows and 
scroll box to see all of the list, or simply click in the list and hold the mouse button 
while you drag the pointer past its top or bottom. 

To select a document to open, click on the name of the document and click on 
the "Open" button, or simply double-click on the name of the document. 

To view the contents of a drawer in order to find a document to open, click on 
the name of the drawer and click on the "Enter" button, or simply double-click 
on the name of the drawer. This will list the documents contained in that 
drawer. 

To exit from a drawer and back up one level in the directory hierarchy, click 
on the "Back" button. Note that the icon in the upper left of the requester 
indicates whether you are currently looking at the contents of a drawer on the 
disk or the contents of the disk itself. 

To see a list of all mounted disks and logical "assignments," either click on 
the "Disks" button, or continue clicking on the "Back" button until you are as 
far back as you can go. The list box will show mounted disks in the top, and 
assignments (in italics) in the bottom. Double-click on any name in the list to 
switch to that disk or location. 

To directly switch to a disk or location to which you know the path, type the 
path name in the text box. The contents of that location will be shown. 

If you know the path and file name you want to open, you can simply type 
both the path and file name into the text box. 

You can also use the right cursor key as an equivalent to the "Enter" button, the 
left cursor key as an equivalent to the "Back" button, and the ALT-left cursor key as 
an equivalent to the "Disks" button. 

You do not need to wait until the list of files and directories is displayed before 
clicking on the "Back" or "Disks" buttons; you can click on these even while the 
clock pointer is shown to switch back a level in the directory or to a different disk. 

If you want to swap disks in a drive while using the Open requester, you can 
follow these steps: 

Wait a few moments to make sure the list of files is fully displayed and the 
disk drive light has gone out. 

Eject the disk from the drive you want to use and insert the new disk that you 
want to access. 
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Wait until the disk drive light goes on then off. Then click on the "Disks" 
button to get a list of disks. 

Double-click on the name of the disk you just inserted to get a list of files and 
drawers on that disk. 

Use the "Enter" and "Back" buttons as described above to find the document 
you want to load. 

Normally ProWrite will only list files in its Open requester that it knows how to 
load. This is to avoid listing files such as CLI commands and system libraries in 
the file list. ProWrite will list all ProWrite files, Flow files, all files that have a 
"Tooltype" of "FILETYPE=text", and files whose name ends with either" .txt" or 
".text". 

There may be times however, when you want to list all files in ProWrite's Open 
requester. You can do this by holding down the ALT key when you choose Open, 
or by clicking on the "Show All Files" check box in the Open requester. Make 
sure that you only load ProWrite files, Flow files, or Text files (also called 
"ASCII" files), no other file formats are recognized by ProWrite. 

You can also set a ProWrite option to have the Open requester list all files, 
regardless of whether you hold down the ALT key or not. See Setting ProWrite 
Options later in this chapter for more information. 

When you load a text file, ProWrite will ask you whether the file has line feeds 
only at the end of each paragraph, or at the end of every line. If you are transfer
ring this file from another word processor, you should specify line feeds at the end 
of each paragraph. If you have captured this file from a BBS you should choose 
line feeds after each line. Choosing line feeds after each line will cause ProWrite 
to combine adjacent lines into a single paragraph; new paragraphs are started only 
when there is an empty line in the file. 

You can also load text files you have exported from the Professional Pr.ge desktop 
publishing program by clicking on the "Convert PPage Codes" check box. 
ProWrite will then convert all Professional Page codes that it can, and display the 
formatted text in the window. Any codes that ProWrite cannot convert are left in 
the file so you can edit them directly. 

ProWrite will automatically detect and properly load text files that have end-of
line markers consisting of either line feeds only (Amiga format), carriage return/ 
line feed combinations (IBM format), or carriage returns only (Macintosh format). 



To save a document: 
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Saving a Document 

The procedure for saving a document is similar to that for opening one. 

Activate the window that contains the document you wish to save by clicking 
on it. 

Choose Save from the Project menu. 

If the document has been saved before, ProWrite will replace the old version 
of the document with the new version (the document will be saved in "Nor
mal" format; see below). 

If the document is a new, untitled document, the "Save As" requester will 
appear. 
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Type a name for the document in the text box. 

Select the "Normal", "PPage Text", or "Text Only" format to specify the file 
format you wish to use. The "Normal" option is preselected. 

The "Normal" option saves the complete document, including all formatting 
information. 

Use the "Text Only" format when you want to transfer your document to another 
program that cannot read ProWrite's "Normal" format. Saving in this format will 
lose all formatting information (such as headers and footers) that the document 
contains. This option is equivalent to an "ASCII" save in other programs. 
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documents: 
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Use the "PPage Text" fonnat when you wish to import your document into the 
Professional Page desktop publishing program. When you choose this fonnat, 
ProWrite will save some fonnatting infonnation, such as paragraph justification, 
character styles, and colors, but you will still lose some infonnation such as 
document margins, headers, and footers. 

Use the "Enter" and "Back" and "Disks" buttons as described previously to 
specify the disk and drawer where you want the document saved. If you want 
to swap disks while using this requester, use the same procedure described for 
finding files in the Open requester. 

Click on the "Save" button or press the RETURN or ENTER key to save the 
document. 

It is a good idea to save your document(s) frequently while working so that you 
will not lose too much work if a power failure or other mishap occurs. 

If you want to save a revised existing document under a new name, choose Save 
As from the Project menu. The "Save As" requester will be displayed for you to 
type in a new name. If you type the name of a file that already exists, ProWrite 
will warn you, and ask if you want to replace that file. Once you have saved an 
existing file with a new name, the old version still exists with its old name; so you 
can open the old version and refer back to it if you need to. If you keep several 
versions of a file, though, you will need to keep track of which one is current. 

If you have made revisions to a document that you decide you don't want to save, 
choose Revert from the Project menu. After confinning your command, ProWrite 
will re-Ioad the document in the last version that you saved. 

Automatic Saves and Backups 

It is a good idea to save your documents frequently while working so that you will 
not lose too much work if a power failure or other mishap occurs. There may also 
be times when you wish to keep older versions of documents you are working on 
as a backup. ProWrite provides ways of accomplishing both of these tasks auto
matically. 

Choose Preferences» Open & Save from the Edit menu. A requester will 
appear. 

Click on the "Auto-save every _ minutes" check box to tum it on. 

Type the number of minutes you wish to have between automatic saves. 

• Click the "OK" button to enable the auto-save feature. 



To automatically make 
backups when you 
save: 

To insert another 
document: 
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Once you have enabled this option, ProWrite will automatically save each of your 
open documents after (1) the specified time has elapsed since the last save, and (2) 
more than 15 seconds have elapsed since you last performed an editing operation 
(such as typing or formatting) on the document. This guarantees that you will not 
be interrupted with an automatic save while you are in the middle of your typing. 

Choose Preferences» Open & Save from the Edit menu. A requester will 
appear. 

Click on the "Make Backups" check box to tum it on. 

Click the "OK" button. 

When this option is turned on, Pro Write will rename any existing version of your 
document to a different name before saving the document. The name of the backup 
document will be the same as the name of the original document, with the charac
ters ".old" appended to it. For example, if your document is named "Sample 
Document", the backup copy will be named "Sample Document.old". Only one 
level of backup is maintained; any previous backup document with the same name 
will be erased. 

Inserting Documents 

You can insert text from another file directly into a ProWrite document, without 
having to open the other document and cut and paste the contents. 

Place the insertion point where you wish to have the document inserted, or 
select a range of text you wish to have replaced. 

Choose Insert» Text from the Project menu. The "Open" requester will 
appear. 

Select the document you wish to insert, and click the "Open" button. The text 
from the selected document will be inserted at the current insertion point. 

If you insert a ProWrite document, only the text from the document body will be 
inserted; the headers, footers, and pictures from the inserted document will not be 
inserted. 

Closing and Quitting 

You may close a window or windows and/or quit the Pro Write program at any 
time. If you have made changes to any documents, ProWrite will ask if you want 
to save those changes before closing the window or quitting. 
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To close a document, either choose Close from the Project menu or click on 
the close box at the top left comer of the window. 

To close all ProWrite's open documents, hold the ALT key and either choose 
Close or click the close box on one of the document windows. 

To quit ProWrite, either before or after closing a document window, choose 
Quit from the Project menu. This will cause the program to close all its 
windows and remove its screen. 

If you are running ProWrite on the Workbench screen, it will quit automati
cally when you close its last window. 
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Printing a Document 

To specify the page 
format: 

ProWrite gives you several options when it comes to printing your documents. 
You can specify one of several different page sizes and orientations (even printing 
sideways), and you can print either in Normal or High quality mode, which are 
both a graphics output, Near-Letter-Quality (NLQ) or Draft mode, which are 
character outputs, or in PostScript mode for high quality results PostScript-capable 
printers. You can "Merge" information from a text file into a form letter and 
automatically print the results-this feature is called "Print Merge" or "Mail 
Merge". You can even preview on your screen a reduced version of entire pages of 
your document. 

ProWrite will read any printer values that it needs from the current Amiga Prefer
ences settings, but you can set or change most of the ones that apply from within 
ProWrite itself. The settings ProWrite does not change are the printer name, 
printer port, and graphics shading; see Appendix B: Printing Considerations for 
how to make sure you have Preferences set up properly before printing your 
document. 

Setting the Page Format 

Before you begin printing you must specify the page format. This information 
includes the paper size and orientation. You need to do this only once for each 
document. If you do not specify a page format, ProWrite will use its current 
default settings. 

Choose Page Setup from the Project menu. A requester will appear. 

P~ Setup II[psonQI1 

Paper size: ~ fer 

.. Idth ~~ 
Reduce or en large: rIOOl :c 

Print density: lE 188 x U. dpl (3) 

Orientation Options: 
ftapect Adjusted 
No Iiapa Bebleen PageS 

Select the paper size from the pop-up menu. The possibilities are "US Letter", 
"US Legal", "A4 Letter" (an intemationalletter size), and "Wide carriage" 
(for wide-platen printers). A "Custom" option is also available, with associ
ated text boxes for entering a custom page size in inches. 
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Set the "Reduce or enlarge" option to whatever value is desired, between 25% 
and 400% of the page's original size. 

Click the arrows of the "Print density" option (if they are not dimmed) to 
choose one of the densities that is supported by your printer driver. Print 
density is given in dots per inch (dpi); the number in parentheses beside this 
setting corresponds to the equivalent Amiga Preferences print density setting. 
The actual resolution produced depends on how well your printer driver is 
matched to your printer. 

Select the icon representing the orientation you want. The possibilities are 
Portrait (upright) and Landscape (sideways) printing. 

Select whether you want "Aspect Adjusted" printing. This option controls 
how ProWrite will scale the printout to the printer's resolution. When it is 
selected, graphics will always be properly proportioned (circles will be round, 
not oval) but text might not be perfect in "Normal" printing mode (especially 
in thin-lined fonts). On the other hand, the "NLQ" and "Draft" print modes 
will not be available at all unless this option is set. 

Select or deselect the "No Gaps Between Pages" option, as desired. This 
setting determines whether ProWrite will attempt to print any text or graphics 
that fall within I/2-inch of the page's top or bottom edge. 

Click the "OK" button or press RETURN or ENTER to set the page format. 

For more information about these settings, see Appendix B: Printing Consider
ations. 

Print Preview 

ProWrite has a "Print Preview" feature which will let you see, in reduced size, the 
final appearance of the pages of your document. This is convenient for looking at 
the overall layout of each page, or for seeing the positioning of large pictures 
relative to the text. 

Choose Print» Preview from the Project menu. A requester will appear 
showing a reduced-size display of the entire current page. 



Using ProWrite 

PreYiew 
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To see the next page in the document, click on the "Next" button. 

To see the previous page in the document, click on the "Previous" button. 

To display a specific page of the document, type the page number in the "Page 
#" text box, then click on the "Go" button or press RETURN. 

When you are done with the Print Preview requester, click on the "Done" 
button. 

Printing 

ProWrite can print either in "High" or "Nonnal" quality mode, which are graphics 
based output modes, in "NLQ" or "Draft" character based modes, or in 
"PostScript" mode to special PostScript-capable printers. 
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The advantages of the "High" and "Normal" modes over the "NLQ" and "Draft" is 
that it yields a full reproduction of the document, including multiple fonts and 
pictures, exactly as they appear in the document window. "Normal" quality prints 
at screen resolution, regardless of your printer's print density. The "High" quality 
mode gives better results by using larger fonts (either bitmap or outline fonts) and 
printing in high-resolution on your printer. By using "High" quality mode and 
outline fonts you can get excellent results even on inexpensive printers. 

The advantage of the "NLQ" and "Draft" modes is somewhat faster printing. But 
you do not get multiple fonts, and you must choose "Portrait" orientation and 
"Aspect Adjusted" in the Page Setup requester before you can select "NLQ" or 
"Draft" mode printing. 

ProWrite gets its information about line spacing and word positions from the 
dimension of the fonts used in the document, so if you print in "NLQ" or "Draft" 
mode (where you are using the printer' s own internal font for the final output) you 
must use a font in the document that matches the printer's font dimensions. A 
number of fonts have been provided with ProWrite that closely match the dimen
sions of common print pitches. For details, see Formatting Characters, earlier in 
this chapter. 

Make sure your printer is properly connected to your computer and turned on. 

Make sure the paper is properly positioned in the printer. If you have the "No 
Gaps Between Pages" option in the "Page Setup" requester turned off, then 
position the top edge of the paper 1/2 inch above the top of the print head. If 
you have this option turned on, position the top edge of the paper at the top of 
the print head (so the first line printed will be on the very top of the page). 

Choose Print » Print from the Project menu. A requester will appear. 

Print "1[paonQ"" 

Quellty: 
Pagee: 
Copln: 

Paper feed: ... Au.ta.tlc :00" ..... Fa.ed 
Paper handling: D Co!late 

Print .... to Frant 
Pr Int Odd Then E!!!,en Pagn 

If you want more than one copy of your document, type the number of copies 
in the "Copies" text box. 
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To print only certain pages of the document, select the "From" option and 
type a beginning page number. Then press the RETURN key to move the cursor 
to the second text box and type an ending page number. To print a single page 
from a multi-page document, type the same page number in both boxes. 

Specify whether you will be using "Automatic" or "Hand Feed" paper feed. If 
you select "Hand Feed" you will be prompted for the next sheet of paper 
whenever each page finishes printing. 

Select the print quality you want, either "PostScript", "High", "Normal," 
"NLQ", or "Draft". Note that the "NLQ" and "Draft" settings cannot be 
selected if you haven't selected "Portrait" orientation and "Aspect Adjusted" 
in the "Page Setup" requester. 

If you are printing a multi-page document and/or multiple copies, you can 
select any combination of the "Collate," "Print Back to Front," and "Print Odd 
Then Even Pages" options. This fills a wide range of paper handling needs. 

Click on the "OK" button or press the RETURN or ENTER key to begin printing. 

When printing begins, a requester will appear allowing you to cancel the printing 
at any time. While ProWrite is printing, the page number indicator on the bottom 
left of the window will indicate which page is currently being printed. 

PostScript Printing 

ProWrite has built-in support for PostScript printing, giving you nearly typeset 
quality results when you use ProWrite with a PostScript-capable printer. You can 
have the PostScript output sent to either your Amiga's serial port, parallel port, or 
to any other device or file. Saving the PostScript output in a file is particularly 
useful if you don't own a PostScript printer, since you can take the PostScript file 
to a service bureau for final printing. 

To use ProWrite's PostScript printing, a few additional conditions must be set up 
properly: 

1. You must have the "PostScript Prep" file in the same directory as the 
ProWrite program. This file contains several PostScript definitions that 
ProWrite must send to the printer before beginning a print job. 

2. You must have PostScript screen fonts and metric files installed on your 
system. The metric files tell ProWrite that the font is a PostScript font which 
is available in your particular printer. If you use fonts that don't have corre
sponding metric files, when you print the document Pro Write will substitute 
the PostScript Times font for any non-PostScript fonts you are using. 
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The System Mover program provided with ProWrite automatically installs metric 
files, if any, when it installs fonts on your system. If you manually install fonts (by 
copying them from the CLI, or with a disk utility program), you will need to copy 
the metric file manually as well. Metric files are identified by the suffix ".metric" 
as part of the file name; for example, the font "Times" will have a metric file with 
the name 'Times.metric". 

Several PostScript screen fonts are provided on the ProWrite "Extras" disk; the 
fonts provided are Times, Helvetica, Courier, and Symbol in sizes ranging from 9 
to 24 points (these four fonts are guaranteed to be available on all PostScript 
printers). If you are using a printer that has more fonts available, you will need 
screen fonts and metric files for those fonts as well. ProWrite's screen fonts and 
metric files are compatible with those from the Professional Page desktop publish
ing program, so you can use the fonts and metric files from that program with 
ProWrite. 

Choose Print» Print from the Project menu. A requester will appear. 

Select "PostScript" as the print quality, and set the other print options as 
appropriate. The name of the device or file that the PostScript output will be 
sent to will be shown in the top of the requester. 

Click "Print" to begin printing. 

You can specify different PostScript options to control the output generated by 
ProWrite. 

Choose Print from the Project menu. A requester will appear. 

Select the "PostScript" as the print quality . 

Click on the "Options" button. A second requester will appear for setting 
PostScript options. 

PostScr ipt Opt iana 

Send to: e..-allel Serial Part 

Print: 

Options: 

v CyatOR: !i=1 =======nn 

E-ter Plctu'"e Printing 
Inc lude ElF (1) WrIter 

Choose "Serial Port" or "Parallel Port" to specify the port to which your 
PostScript printer is connected. 
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If your printer is connected to some other AmigaDOS device, or if you want 
to save the output to a file, click on "Custom" and type the name of the device 
or file to which you wish to send the output. 

If you are using a black and white PostScript printer, click on "Gray Scale". If 
you are using a color PostScript printer, click on "Color". 

Normally you should leave the "Faster Picture Printing" check box turned on. 
However, if you have pictures in your document which that overlap and have 
transparent regions (so that you can see parts of one picture through another), 
you will need to tum this option off. 

Normally you should leave the "Include EOF ("D) Marker" check box on. 
However, if you are having problems printing to a PostScript print spooler, or 
you are printing to a printer that does not properly handle control-D charac
ters, you will need to tum this option off. 

Click "OK" to use the PostScript settings. 

When you use the "Gray Scale" PostScript option, all colored text will be printed 
in black. Also, if you have pictures in your document, you cannot use the "Color" 
setting on black and white printers; you must be printing to a color PostScript 
printer. 

The PostScript options apply to all documents, and are not saved as part of anyone 
document file. However, they are saved as part of a ProWrite Settings file. See 
Setting Program Options later in this supplement for more information about 
Settings files. 

When you are printing to a PostScript printer, you can cancel at any time after the 
print has started. However, when printing documents containing pictures, you will 
not be able to interrupt the printout while a picture is in the process of being 
downloaded to the printer. If you click on the "Cancel" button while a picture is 
being sent, the printout will be cancelled only after the picture has been completely 
sent to the printer. 

High Quality Printing 

With Pro Write you do not need an expensive PostScript printer to get jaggie-free 
results; you can get very high quality results with a dot-matrix printer-results that 
are as good as the printer is capable of producing. ProWrite's "High" quality 
printing mode will automatically use larger fonts and scale them down to a finer 
resolution for true jaggie-free results using any Amiga font. 
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With Kickstart 1.2 or 1.3, ProWrite will try to use a double-size font, and scale it 
down by a factor of two, in order to get high quality printing. With Kickstart 2.0 or 
later, Pro Write will look for even larger fonts if your printer is set for very high 
print densities (300 dpi or greater). Therefore, to get the best results with high 
quality printing, you should either: 

Have double-size versions of the fonts you use, so ProWrite can use these 
larger fonts for the printout. For example, if you use the Times-12 font, you 
should also install the Times-24 font in order to get the best results with high 
quality printing. 

Have the outline font system (supplied with Kickstart 2.04) installed. 
ProWrite can use the outline font system to automatically create large size 
fonts that are scaled down to your printer's resolution. 

If you do not have either of these two conditions met, the results you get will be 
slightly different depending upon which version of Kickstart you are using: 

If you are using Kickstart 1.2 or 1.3, ProWrite will find the closest font that is 
smaller than twice the font size, and substitute that font in the printout; the 
word and character spacing will be adjusted to match the original word and 
character spacing as closely as possible. 

If you are using Kickstart 2.0 or later, the font system will automatically 
create a double-size font from another available font. 

In both of these cases, the result may not be as good as you would obtain if you 
had the needed fonts installed, so you should always try to install larger fonts if 
you can. The "ProFonts I" package from New Horizons has a good selection of 
professional fonts in a broad range of sizes that are useful for high quality printing 
with ProWrite. Contact New Horizons for more information about this font 
package. 

Choose Print» Print from the Project menu. A requester will appear. 

Select the "High" quality print mode and click on the "OK" button. 

Finally, you will generally get the best results with High quality printing (and 
Normal quality printing as well) if you tum off the "Aspect Adjusted" setting in 
ProWrite's "Page Setup" requester. Note, however, that on some printers turning 
off this setting will result in pictures that are slightly compressed in one direction. 



To specify the number 
of print colors: 

To set print options: 

Using ProW rite 

Color Printing 

When printing in a graphics mode (High or Normal quality), or when "Print 
Pictures" is turned on in NLQ or Draft quality, you can print using either eight, 64, 
or 4,096 colors. Printing with eight colors requires the least amount of memory, 
and gives the fastest print times, at the expense of having only solid colors in 
pictures. Printing with 64 colors gives reasonable picture results (except with flesh 
tones) with somewhat slower printing times and greater memory requirements. 
Finally, using 4,096 colors will print all pictures with their full original colors, at 
the expense of slow printing and very large memory requirements. 

Choose Print» Print from the Project menu. A requester will appear. 

Choose a print quality and mode that will cause pictures to be printed (High or 
Normal quality, or NLQ or Draft quality with "Print Pictures" turned on). 

Click on the "Options" button. A requester will appear. 

Print Options '=========~~~~I 

Colora: 

Pr Inter font 1UIber: 1 

Options: iRooth 
erint P ict\rea 
I;Pth ... Spacing 

Choose the number of colors to use (8, 64, or 4,096). 

Click on the "OK" button to use this setting. 

Click "Print" to begin the printing. 

Print Options 

When printing on a non-PostScript printer, several print options are available to 
give you complete control over your printing. See Appendix B: Printing Consid
erations for a full discussion of these options. 

Choose Print» Print from the Project menu. A requester will appear. 

Select a non-PostScript print quality (e.g. High, Normal, NLQ, or Draft) and 
click on the "Options" button. A second requester will appear. 

Select the print options you wish to use and click on the "OK" button. 
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Miscellaneous 

When printing in NLQ or Draft mode, ProWrite will only use line advances in 
multiples of 1/6 or 1/8 of an inch unless you have the "Print Pictures" option in the 
"Print Options" requester turned on. Turning this option on will enable ProWrite to 
use arbitrary line advances in NLQ and Draft modes. This is particularly useful 
when you have side-by-side paragraphs that have different line spacings. However, 
only graphics-capable printers can use this feature. 

Printing a Single Copy 

ProWrite offers you the option of quickly printing a single copy of your document 
without having to go through any requesters. 

Choose Print» Print One from the Project menu. When you choose this 
command, ProWrite prints one copy of your document using the printer 
settings you most recently used for that document. As with regular printing, a 
requester is displayed to let you cancel at any time. 

Printing Merged Documents 

With ProWrite you have the capability to create a template document (such as a 
form letter) and automatically merge it with several entries from a text file (either 
one created in a data base system or with ProWrite) and print the results. A 
common example of this is producing customized letters from a form letter and a 
data base of names and addresses. 

To use the print merge feature, you must first create a merge data file. This file 
contains the individual entries that must be merged with the document. In the 
description below, the term "record" refers to each entry for which a separate 
document is to be generated, and the term "field" refers to the specific portions of 
the record. For example, if the file consists of names and addresses, a record would 
be an entire name/address entry, and the fields of a record would be the name, the 
address, the city, the state, and so on. 

The file must have the following format: 

I. Single paragraph entries for each record. 

2. The fields of each record are separated either by a single comma or a single 
TAB character. 

3. If any field must include a comma, then the whole field must be enclosed in 
quotes. 
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4. The first record is simply the names of the specific fields. No merged docu
ment will be printed for this record. 

An example merge data file might look like the this: 

Name, Address, City, State, Zip 
Jane Doe, "123 Any St., #B2", Any town, TX, 78745 
John Pancreas, 555 Livermore Ln., Lungstown, CA, 90001 

and so on, where each new line is a separate paragraph (i.e., press RETURN after 
each record), and each field is separated from the previous one by a single TAB or 
comma character (i.e., press either the TAB key or the comma key, but not both, 
between field entries). Notice the field that has been enclosed in quotes to keep its 
comma from being interpreted as a field separator. 

You can also have quotes in the data fields for the Print Merge command. To 
include a quote in the data field, simple precede it with a caret symbol (1\). For 
example to have a data field of "John "crazy" Doe" you would type it as: 

"John I\"crazyl\" Doe" 

To have a single caret symbol appear in a data field, precede it with a caret as well. 

This merge format is compatible with output from a number of database systems, 
but you can also use ProWrite to create or edit a merge file. If you do, you may 
find that field entries don't necessarily line up on the screen, and that records 
might even word-wrap. This is all right, just make sure you put only one TAB or 
comma (not both) between fields, and press RETURN only at the end of each entire 
record. It may be helpful to tum on Show Invisibles in the View menu. 

The file must be saved in "Text Only" format (also called "ASCII" format by other 
programs). If you are creating the file with ProWrite, be sure to click on "Text 
Only" in the Save As requester when saving the file. 

Once you have created and saved the merge data file, you need to create the merge 
document (or form letter). You do this by creating a document just as you nor
mally would, but wherever you want the fields from the merge data file to go, you 
instead put the field names surrounded by double angle bracket characters (which 
are obtained by pressing ALT-9 and ALT-O on the Amiga keyboard). For example, 
you might start out a letter like this: 

«Name» 
«Address» 
«City», «State» «Zip» 

Dear «Name», 
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and so on. Remember that the double angle bracket characters are not the same as 
pressing the single angle bracket characters twice! You must use the ALT-9 and 
ALT-O characters to create the double angle brackets. 

Once you have created your merge document, you now start the print merge 
operation. 

Create a merge data file and merge document (form letter) as described above. 
The merge data file must be saved in "Text Only" form. 

With the merge document active, choose Print» Print Merge from the 
Project menu. The "Open" requester will appear. 

ProWrite will list in this requester only those files that identify themselves as being 
Text files. If you use a different program to create this file and that program does 
not properly set the file type as Text, the file will not show up in this requester. 
However, if you hold down the ALT key when you choose Print Merge, the Open 
requester will show a list of all files. If you do this, make sure the file you select is 
the correct text file that contains your merge data. 

Choose the merge data file that contains the information you want merged into 
this document and click on the "OK" button or press the RETURN or ENTER key. 
For more information on using the "Open" requester, see Loading and 
Saving a Document earlier in this chapter. 

After you have chosen your merge data file, a second requester will appear to 
let you decide which merge data file records you want to print. "All" is pre
selected, but you can set a range instead. This enables you to conveniently 
print just one or a few records of a much larger file. Empty entries in the 
merge data file are skipped in the merge process, so they are not counted 
when ProWrite is finding the range of records you have set. 

... of records to REI""ge: 

811 

Once you have set the range of records to be merged, the "Print" requester 
will appear. Choose the print options you want and click on the "OK" button 
or press the RETURN or ENTER key. 

ProWrite will print one complete document for each entry in the merge data file. 
When the first merge document begins printing, a requester will appear allowing 
you to cancel the print merge at any time. 
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Project Information and Passwords 

To see the creation and 
save dates: 

To add a document 
comment: 

To password protect a 
document: 

ProWrite notes the exact date and time that you created a document (that is, the 
date and time when you first chose the New command from the Project menu) , as 
well as the date and time that the document was last saved. This information can 
be useful to you in determining exactly which document revision your are working 
with. 

r 
I 
I 

I 
I 
I 

I 
I 
I 

Choose Information from the Project menu. A requester will appear showing 
the creation and save dates. 

Project Infonaat Ian 
"""_ ........ .-, .. ;Of ......... ......, :;;;;:::lI 

Date created: 
Septelliber 29, 1992 1f:&l3PW 

Date I_t saved: 
SepteRber 29, 1992 ":57 fIN 

Cal'lN!flt : 

Panord: II 

ProWrite also allows you to add a comment to your document, and this comment 
will be displayed while the document loads. You can use this as a brief statement 
of the document's purpose, or as a reminder of things you need to work on with 
the document. 

Choose Information from the Project menu. A requester will appear. 

Type your comment into the "Comment" text box. 

Click the "OK" button to add the comment. 

If a document contains sensitive information, or information that you wish to keep 
from others, you can add a password to your document. When you do this, the text 
of the document will be saved in an encrypted form, and no one will be able to 
open the document without first entering the password. 

Choose Information from the Project menu. A requester will appear. 

Type the password you wish to use in the "Password" text box. Remember 
this password exactly, including which letters are upper case and lower case. 
Do not forget the password, otherwise you will not be able to open the 
document again! 
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To remove password protection, delete the contents of the "Password" text 
box, 

Click the "OK" button to set the password. 

Warning: If you forget the password you assign to a document, you will not 
be able to recover the document, as its contents are encrypted 
when it is saved! 
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Setting ProWrite Options 

To set open & save 
options: 

There are a number of options which you may set to customize ProWrite 's 
behavior. These include screen colors, "Open" requester file filtering, saving icons 
with files, insertion point blinking, and typing mode. 

ProWrite's settings are divided up into two main requesters; one for open & save 
options, and one for general program settings. These settings will only be used 
during your current work session unless you save them by choosing Settings )) 
Save from the Project menu (see the next section). 

Open & Save Preferences 

ProWrite 's open & save settings control some of the options ProWrite has opening 
and saving documents. 

Choose Preferences )) Open & Save from the Edit menu. A requester will 
appear. 

Sav Ing docUIIenta: 
~ leans 

e Backups 
Ru.tD-seYe everu: 

Open requester: 
"Inutn 

Show ITaNrlte Fi In OnIU 
Shot! RII Files 

If you prefer not to see any files in the Open requester that Pro Write isn't sure 
it can open, then leave "Show ProWrite Files Only" selected. If you would 
like to see all files (except ".info" files) displayed, select "Show All Files." 

If you would prefer not to have ProWrite save icons (" .info" files) with its 
files, tum off the "Save Icons" options. This option is normally on. 

Set whether you would like to enable automatic saves, and automatic backups. 
See the section on Loading and Saving a Document earlier in this chapter 
for more information about these options. 

If you wish to remove all previous changes and return to the built-in default 
settings, click on the "Reset" button. 

When you are satisfied with the changes, click the "OK" button. 
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General Preferences 

ProWrite's "General" settings control a number of program features, such as the 
unit of measurement used in requester's, how you would like to be notified of 
errors, and even for selecting insert or typeover mode when typing text. 

Choose Preferences» General from the Edit menu. A requester will appear. 

lkt I t of N!eIIUI"f!MIlt: 
... lrtchn 
:-" Cent I .. tera 

Error notification: 
.,. E 1.... Sa een 

tcutd Beep 
... 1D1h 

General: 
Full Cllpbord Suppart 

lup I ng 1III.'Jde: 
... Inwert 
~luPea ...... 

Cacbe Plcbrft 

Select the unit of measurement you prefer to use, either "Inches" or "Centime
ters". This setting is for dimensions such as paper sizes and margins that are 
displayed in ProWrite's requesters. 

Select the "Insertion point blinking" rate that you prefer. 

If you prefer typing over existing text without having the text to its right move 
to make room, select the "Typeover" typing mode. This may be useful in 
special circumstances, as when filling out a form file that has more than one 
entry per line. 

When in the typeover mode, you may find it helpful to use the Amiga-/ 
shortcut to insert spaces to the right of the insertion point; this is equivalent to 
choosing Space from the Insert Item submenu of the Edit menu. 

To choose the sort of signal you would like ProWrite to make when there has 
been some sort of error, select from the "Error notification" options: "Flash 
Screen," "Sound Beep," or "Both." 

Set whether you would like to have full clipboard support or not. See the 
section on Editing Text earlier in this chapter for more information about this 
option. 

Set whether you would like to cache pictures or not. See the section on 
Pictures in a Document earlier in this chapter for more information about 
this option. 



To change the window 
paper color: 

To change the screen 
colors: 

Using ProW rite 

If you wish to remove all previous changes and return to the built-in default 
settings, click on the "Reset" button. 

When you are satisfied with the changes, click the "OK" button. 

Paper Display Color 

You can set the color used for the background paper in ProWrite's display. This is 
useful if you prefer a different color to change the screen contrast or improve 
readability. It has no effect on the final printout. 

Choose Preferences » Paper Color from the Edit menu. A requester will 
appear. 

Paper' Co I or 

Click on the color you wish to use for the window display and click on the 
"OK" button, or simply double-click on the color. 

Screen Colors 

Pro Write's default color palette provides all of the primary colors. You can change 
the screen colors to any combination you wish, and ProWrite will automatically 
adapt to the changes. This is useful if, for example, you have a picture in your 
document that uses several shades of red, but no greens-you can change the 
palette to have several reds with no greens and you will get a more accurate picture 
display. 

Choose Preferences» Screen Colors from the Edit menu. A requester will 
appear. 
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Screen Co lora 

Click on the color you wish to change and then on the "Change" button, or 
simply double-click on the color. A requester will appear where you can 
change the color. 

Se I ect a screen co lor 

Hue 

Red: 3 

9 

BI~: 
Satlratian 

Specify the new color either by adjusting the Hue, Brightness, and Saturation 
sliders, or by adjusting the Red, Green, and Blue values. Click the "OK" 
button to keep the change. 

After you have adjusted the colors, click on the "OK" button. 

Be careful when using text colors that are no longer available in the screen palette, 
as you might get unexpected results. In particular, if you change all of the screen 
colors to be dark, then some text colors (such as yellow) may have white as their 
closest corresponding screen color, thus rendering the text invisible on the screen. 

Also, if you change the screen colors so that ProW rite no longer has sufficient 
color contrast to maintain its "3-D" appearance, it will fall back to using a "2-D" 
appearance. 
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Saving ProWrite Preferences 

To save program 
settings: 

To load program 
settings: 

To create a default 
settings file: 

With ProWrite you can save all of the program's default settings-including 
character styles, paragraph format, screen colors, window location and size, and 
preferences settings-and load them later. You can have several different settings 
files, and switch from one to the other at any time. You can even have one settings 
file always be loaded when the program starts, so you can have your own custom 
preferred default settings. 

Set all of the program's settings and preferences the way you want them. 

Choose Settings» Save As from the Project menu. A requester will appear. 

Specify a name and location for the settings file and click on "Save". 

Loading program settings can be done at any time. 

Choose Settings )) Load from the Project menu. A requester will appear. 

Select the settings file you wish to load and click on "Open". 

When ProWrite first starts up, it looks for a settings file name "ProWrite Defaults" 
in the same location as the Pro Write program. If this file is found, it automatically 
loads this settings file. You can easily create this file to create your default 
settings. 

Choose Settings )) Save from the Project menu. You will be asked if you are 
sure you want to create a new default settings file. 

Click "Yes" to create the default settings file. 

Note: ProWrite's new settings files are not compatible with the "ProWrite Prefs" 
files created with versions of ProWrite prior to version 3.2. ProWrite 3.3 will not 
load these older "Prefs" files, so if you are upgrading to ProWrite 3.3 from an 
older version, you will need to re-create your settings files. 
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ProWrite includes a facility which allows you to create "macro" programs for it, 
using the AREXX programming language. You must have AREXX installed on 
your system in order to use ProWrite's macros (AREXX is included as part of the 
Amiga operating system software version 2.0 and later). 

Creating and Using Macros 

A macro program consists of a series of normal ProWrite commands. The macro 
can be executed easily as though they were a single command, either by choosing 
an item from the Macro menu or by holding SHIff and pressing a function key. 

Macros are normally considered to be a feature for "advanced" users. To use them, 
you must have the AREXX language installed on your Amiga, and you should 
have some familiarity with the language. For additional information about 
AREXX, refer to the AREXX manual that came with your AREXX program. 

AREXX does not recognize space characters in file names. If you intend to use 
AREXX with ProWrite, you must make sure that there are no spaces in the names 
of any AREXX programs you write. 

For a complete list of the AREXX commands that ProWrite provides, see the 
ProW rite Reference chapter. 

Use either ProWrite or some text editor (such as the eLI's "Ed") to write the 
macro program. For a complete listing of ProWrite's macro language com
mands, see Macro Language Commands in the ProWrite Reference 
chapter. Here is an example of a short macro program which transposes the 
last two characters typed: 

/* Transpose characters */ 
ShiftDown 
CursorLeft 
ShiftUp 
Cut 
CursorLeft 
Paste 
CursorRight 



To use a macro: 

Using ProWrite 

Note that the first line of an AREXX program must be a "C style" comment (it 
must start with "/*" and end with "*f'). ProWrite's AREXX port name is normally 
"ProWrite"-unless you have several copies of ProWrite running, in which case 
the second port is named "ProWrite.l ", the third "ProWrite.2", and so forth. 
Normally you do not need to directly address this port, since ProWrite automati
cally sets the address to its own port before starting any macro. If you do need to 
directly address ProWrite's port, the capitalization of the port name is important; 
and since AREXX will convert any non-quoted text to all capitals, you must 
enclosed the name in either single or double quotes. 

Save the macro program as a "Text Only" (or "ASCII") file in the same 
directory (disk and drawer) that contains ProWrite. If you are using ProWrite 
to create the macro, be sure to use the Save As command to save the file as 
"Text Only". 

You can name your macro so that it will be instantly accessible from either the 
keyboard or menu. Up to ten such macro files may be created; they should be 
named "Macro_I" for the first macro, "Macro_2" for the second, "Macro_3" 
for the third, and so on up to "Macro_IO" for the tenth. The underscore L) 
character is obtained by holding SHIff and pressing the hyphen key. Alterna
tively, you can save the macros with any name you like, and change the menu 
entries to match the names. See Macro Menu Customization later in this 
chapter for more information. 

If you do not need instant access for your macro, or if you have already used 
up all ten macro names, then you may give the macro any name you like (as 
long as the name does not contain any spaces). 

You can invoke ProWrite macros either with the keyboard or the menu. And 
because ProWrite's macros run through AREXX, you can also start up a ProWrite 
macro from a program other than ProWrite. 

Before using macros, you must start up the AREXX resident process with the 
language's "RexxMast" CLI command. This command may be included in 
your system's startup sequence. See your AREXX documentation for details. 

For any of the ten instant-access macros, simply choose the corresponding 
command from ProWrite's Macro menu, or hold SHIff and press the corre
sponding function key. The commands in the corresponding macro file will be 
executed. 

For any other macro program stored in ProWrite's directory, choose Other 
from ProWrite's Macro menu. A requester will appear. 
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I 
You can either type the macro's name, or click on the "?" button and use the 
file requester to locate the macro you wish to execute. 

AREXX programs which are run externally, either using AREXX's "rx" CLI 
command or another AREXX-compatible program, may also be used to send 
commands to ProWrite. 

Macro Parameters 

You can pass parameters to your macros when you invoke them from ProWrite. 
You can use parameters as additional information that your macro program uses 
when executing commands. 

Choose Other from the Macro menu. A requester will appear. 

Type the name of the macro to execute, press RETURN, and type the parameter 
you wish to have sent to the macro. 

Click the "Execute" button or press RETURN to execute the macro. 

Your macro programs can retrieve the parameter passed to them with the ARGO 
AREXX command. For example: 

numParams = ARG() 

will return in numParams the number of parameters passed to the macro (zero or 
one if invoked from ProWrite), and 

parameter = ARG( l ) 

will return the parameter sent with the macro. 



To customize the Macro 
menu: 

Using ProW rite 

Macro Menu Customization 

You can customize the macro names in the Macro menu. This means that you do 
not need to name your macros "Macro_I", "Macro_2", etc. in order to have them 
available in the menu and as a SHIFT-function key-you can have the actual macro 
name show up in the macro menu, and still be able to access it with the function 
keys . 

Choose Customize from the Macro menu. A requester will appear. 

Wacro IlC:WIeS: 

F1 ~ro 1 
F2 ~ro:2 

FJ ~ro_J 

Ftf liKio_tf_ 
F5 ~~_~_ .~..... _ 

F6 ftiro:& __ .. , :. _u_ 
n dwacro-1 
F8 IlHacro .8 

F9 

Change the macro names for each of the ten entries to the names of the 
macros you wish to use. 

Click the "Use" button to use the new macro names, but not make them the 
default settings. Click on the "Save" button to use the new settings and also 
save them as your default macro menu setup. 

When you save your macro name settings, ProWrite creates a file named 
"ProWrite FKeys" in the same drawer as the ProWrite program. ProWrite will 
look for this file when it starts up, and set the macro menu to the settings it 
contains. 

Remember that you must hold down the SHIff key when you press a function key 
in order to invoke a macro from the Macro menu. Pressing a function key without 
the SHIFT key will execute a menu command instead. 
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Other Macro Features 

ProWrite automatically executes the AREXX macro named "ProWrite Startup", if 
one is present in the same drawer as the ProWrite program. "ProWrite Startup" 
macro can contain any operations that you want to have automatically executed 
when first starting ProWrite. For example, you might want to place the command: 

SetPath 'Work:Documents' 

in the "ProWrite Startup" macro if you wish to have the default path for saving 
documents set to the directory "Work:Documents". 

ProWrite will report errors and failures of macro commands. If a command has 
improper parameters, ProWrite will set the AREXX variable RC to 5. If a macro 
command fails (for example, the user clicked on "Cancel" in a requester, or a find 
operation was unsuccessful), ProWrite will set RC to 10. Finally, if a command is 
sent to ProW rite that it doesn't understand, ProWrite will set RC to 20. 

If you are running several instances of ProWrite at the same time, you can now use 
macros in each one. The first instance of ProW rite that is run will have an AREXX 
port name of "ProWrite", the second one will have a port name of "ProWrite.1 ", 
the third, a name of "ProWrite.2", and so on. Since ProWrite automatically sets up 
the AREXX command address to its own port, you should not need to reference 
these port names unless you are writing macros that manage multiple instances of 
ProWrite. You can determine the current AREXX port name that an instance of 
ProWrite is using by choosing About ProW rite from the View menu, or by 
pressing the HELP key. 

Sample Macros 

On the ProWrite Program disk are several sample macros. If you are new to 
AREXX, you might wish to study these examples to see how you can use 
ProWrite's macro commands and AREXX to accomplish difficult tasks. A brief 
description of the included macros is as follows: 

Transpose 
Will transpose the last two characters typed. For example, if you typed "teh" and 
invoke this macro it will change it to "the". 

Math 
Will evaluate a math expression that is selected and display the result. For ex
ample, if you type "5*6", select it, and invoke this macro it would type "=30" at 
the end of the expression. This macro supports all AREXX math operations and 
functions, and since it is a macro, you can modify it if you want the results entered 
or used in some other fashion. 
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Indent 
Will indent the left indent and left margin markers by 1/2 inch. You can use this 
macro and the Unlndent macro to implement a simple outline generator with 
ProWrite. 

UnIndent 
Un-indents the left indent and left margin markers by 1/2 inch. 

HangingIndent 
Indents the left margin, but not the left indent marker, by 1/2 inch. This creates a 
"Hanging" indent. 

EndNote 
Implements a simple end-note system. It asks you for the marker to use for the 
endnote, and the endnote text, then places a superscript marker at the current 
location, goes to the end of the document and types the end-note text, and finally 
returns to the original location in the document. 
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There are several additional features in ProWrite that do not fit in the categories 
already discussed. These features are primarily conveniences to make working 
with ProWrite quicker and easier. 

Dynamic Scrolling 

When the ALT key is held down while dragging the document's horizontal or 
vertical scroll box, the document will dynamically scroll as the box is dragged. 
This may result in a somewhat jerky scrolling response unless you are running 
ProWrite in a two color screen, or are using a faster processor such as a 68030. 

Kickstart 2.0 Enhancements 

In addition to support for new screen options, ProWrite takes advantage of several 
other new features in Kickstart 2.0 when you are running this version of the Amiga 
operating system. Chief among these are the "Application Icon" or "AppIcon", and 
the "Application Menu Item" or "AppMenuItem" features. 

When ProWrite is started, it will put up an AppIcon named "ProWrite Deposit" on 
the Workbench screen. If you double-click on the icon, ProWrite's screen will be 
brought to the front. If you drag one or more icons on top of this AppIcon, 
ProWrite will automatically load these files. This lets you use the Workbench 
itself, instead of ProWrite's "Open" requester, to specify the files you wish to load. 

ProWrite also adds an AppMenuItem named "ProWrite" to the Workbench's 
"Tools" menu. Choosing this menu item will bring ProWrite's screen to the front. 
With Workbench 2.04 and later, if you select one or more document icons and 
then choose this menu item, ProWrite will load the selected documents. 

ProWrite utilizes several other new internal features in Kickstart 2.0 for improved 
appearance and performance. 

Kickstart 3.0 Enhancements 

When you are running ProWrite under Kickstart 3.0, ProWrite will use the 
Preferences "Busy" pointer rather than its own, allowing you to customize the 
pointer appearance. 

Under Kickstart 3.0 ProWrite will also open its screen as an "Interleaved Bit
map", which improves window scrolling performance and eliminates scrolling 
artifacts when using certain color combinations. 
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File Convert Program 

ProWrite comes with a new file conversion program, called "ProWrite File 
Convert," located on the "Extras" disk. This powerful program can convert a wide 
variety of documents from other word processors into ProWrite format, while 
retaining as much of the original file's text and formatting as possible. ProWrite 
File Convert supports Textcraft, Textcraft Plus, KindWords, Pen Pal, excellence! 
2.0, Final Copy, and other Amiga file formats, as well as WordPerfect, and RTF 
(Rich Text Format), a popular IBM-PC and Macintosh format. 

To use ProWrite File Convert, double-click on the icon to start the program, select 
the file type you want to convert, and click on the "Convert" button. You will be 
asked for the name of the file to convert, and for a new name for the converted file. 

Additional Fonts 

ProWrite comes with a "Fonts & Devices" disk which contains several additional 
fonts. Included with this disk are the Times, Helvetica, Courier, and Symbol font 
families for use in PostScript printing, as well as two font families, Granite and 
Marble, for use on dot-matrix printers. The Granite and Marble fonts come in a 
wide range of sizes, from very small to very large, and are particularly useful when 
using ProWrite's "High Quality" printing option under Kickstart 1.3 (where there 
is no outline font system). 

To install these fonts, either use the "System Mover" program included on the 
disk, or use the installation program included on the "Extras" disk. 
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ProWrite Reference 

Congratulations ! You have explored and mastered the exciting 
possibilities of word processing with ProWrite. 

This reference chapter summarizes the commands and operations 
available in ProWrite. This chapter is designed for the experienced 
ProWrite user---descriptions are arranged in the order they appear in 
the menus, and each command is only briefly described. For a more 
complete discussion on the use of particular commands, refer to the 
previous chapter, Using ProWrite. 

The sections in this chapter are: 

• The Menus 

• The Ruler 

• Shortcuts 

• Macros and AREXX 

• Macro Language Commands 
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ProWrite has seven menus: Project, Edit, Search, Fonnat, Document, View, and 
Macro. 

The Project menu contains commands which control file and print operations: 
opening and closing documents, saving and printing documents, and quitting the 
program. 

The Edit menu commands are for moving, copying, and erasing text and pictures 
in documents. This menu also lets you transfer styles and fonnats from one block 
of text to another, insert special text items such as forced page breaks and page 
numbers, and set certain options that control ProWrite's behavior. 

The Search menu is used to find and change specific text and to go to a particular 
locations in a document. 

The Format menu is used to change the fonnat of characters, paragraphs, or 
pictures. Character fonnat settings include the type, style, size, position, and color 
of characters. Paragraph fonnat settings include alignment, spacing, and tab type. 
Picture fonnat settings include the picture's size, type of text wrap, and name. 

The Document menu allows you to control the overall appearance of your 
document. You use these commands to set up headers and footers, find words, 
check spellings, and use the thesaurus. 

The View menu lets you choose whether to see things such as page guides, 
"invisible" characters, pictures, or one of several kinds of rulers. Also, each 
document that has been opened is listed here for selection. 

The Macro menu is a special purpose menu which allows you to execute macro 
language programs from within ProWrite. 



New 
Open ... 
Close 

Insert » 

Save II!'DS 
Save As ... 
Revert 

Page Setup ... 
Pr int » 
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Settings » 

Quit 

ProWrite Reference 

The Project Menu 

The Project menu contains commands which control file and print operations: 
opening and closing documents, saving and printing documents, and quitting the 
program. 

New Keyboard equivalent: F1 or Amiga-N 

Creates an new, empty, untitled document. Existing windows will not be closed. 
You can have up to ten document windows open at the same time (depending upon 
available memory). 

Open Keyboard equivalent: F2 or Amiga-O 

Opens a previously saved document. 

After choosing Open, a requester will appear in the window. This requester 
contains a list box showing the contents of the disk. Documents will be shown in 
normal type, while drawers will be shown in italics and will have a dash in front of 
their name. To open a document, click on the name of the document and then click 
on the "Open" button, or simply double-click on the name of the document. 

To view the contents of a drawer, click on the name of the drawer and then click 
the "Enter" button, or simply double-click the name of the drawer. To back up to 
the previous directory level, click on the "Back" button. To see a list of disks and 
assignments, click the "Disks" button. 

The requester also has a text box where you can type the name of a file or location. 
If you type a location name (a disk or drawer name, or a complete path specifica
tion) and press RETURN, a list of files in that drawer will be displayed. If you type a 
file name (with or without a path specification), that file will be opened. 

Normally, ProWrite will only list files in this requester that it knows how to load. 
If tum on the "Show All Files" check box, ProWrite will display all files at that 
location (except for ".info" icon files). You can have ProWrite automatically tum 
on this option either by holding down the ALT key when you choose Open, or by 
selecting the "Show All Files" option in the "Open & Save Preferences" requester. 

Close Keyboard equivalent: F3 or Amiga-W 

Closes the active window. You can also close the active window by clicking in the 
close box of the window. 

If you try to close a window without saving changes you have made, ProWrite will 
ask if you want to save the document before closing it. 
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If ProWrite is running on its own screen and only one window is open, then after 
closing it you will see an empty screen; you can still use the Project menu to quit, 
or to open or create a new document. If Pro Write is running on the Workbench 
screen or some other public screen, it will Quit automatically when its last 
window is closed. 

If you hold down the ALT key when choosing Close or clicking a close box, then 
all opened documents will be closed at once. You will be asked for each one if you 
want to save any documents that have been changed. 

Insert 

Displays a submenu of two commands which let you insert either text or pictures 
files into your document: 

Text 
Displays the "Open" requester where you can select a text file to insert. The 
contents of the specified file will be inserted at the current insertion point just 
as if you had typed the contents. See Open for more information on using the 
"Open" requester. 

Picture 
Displays the "Open" requester where you can select a picture file to insert. 
The picture will be placed at the top left comer of the window; you can drag it 
from there to the location you wish. 

Save Keyboard equivalent: Amiga-S 

Saves a copy of the document to the disk. The document will be saved in "Nor
mal" format. 

If you choose this command to save an untitled document (one that has never been 
saved), you will see a Save As requester. 

If you choose this command from the menu to save a document that has been 
saved before, you will not see a requester. Instead, ProWrite will save the docu
ment using the name it was last saved under, replacing the previous version. If you 
wish to keep the previous version, you must use the Save As command. 

Save As Keyboard equivalent: sHIFT-Amiga-S 

Saves a document under a new file name. 

This command brings up a requester with a text box for you to type in a name for 
the document. Select the "Text Only" option if you want the document saved 
without any formatting; the "Normal" option is preselected. 
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This command's requester is similar to the Open requester in that it has a list box 
showing the drawers contained in the disk. As when opening a document, you may 
select a drawer to save your document into by clicking the drawer's name in the 
list box and then clicking the "Enter" button, or simply by double-clicking the 
drawer's name. Click on the "Back" button to back up to the previous directory 
level, and on the "Disks" button to see a list of disks and assignments. When you 
have entered a name for your document and specified the disk and directory you 
want it saved to, click the "Save" button, or press RETURN or ENTER, to save the 
document. 

Revert 

Loads a document in the version in which it was last saved. 

This command discards any editing you may have done since you last saved the 
document. You will be asked to verify that this is really what you want to do. 

Page Setup Keyboard equivalent: F4 

Allows you to set up the page format of your document. 

When you choose this command, a requester will appear so you can specify the 
document's paper size, orientation, and other printout options. Many of these 
settings override equivalent settings in the Amiga's Preferences program. 

Four pre-defined paper size settings are provided: "US Letter," "US Legal," "A4 
Letter" (an international letter size), and "Wide Carriage" (for wide-platen 
printers). A pair of text boxes is also provided so that you may type custom width 
and height settings, as desired. If you type a custom width or height, the "Custom" 
setting will be selected to show you have made a custom setting. 

To set the orientation of your document on the page, select one of the "Orienta
tion" icons in the requester's lower left comer; the choices are portrait (upright) 
and landscape (sideways) printing. 

You may type in a value to reduce or enlarge your document's printout to any size 
from 25% to 400% of normal. This setting is reflected inversely by the size of the 
editable page in the window display. For instance, a 200% printout enlargement 
will make your margins appear to be half as wide on the screen. 

The "Print density" setting shows the resolution (width x height) of your printer in 
dots per inch (dpi). If your printer supports more than one print density, you may 
alter this setting by clicking the appropriate up or down arrow. The number of the 
equivalent Amiga Preferences print density setting is also shown. 
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The "Aspect Adjusted" setting causes ProWrite to force an effective print density 
of 80 by 72 dpi in portrait orientation or 72 by 60 dpi in landscape orientation, 
ensuring a correct aspect ratio for graphics, with the possible side effect of 
distorting text in some fonts. For more information see Appendix B: Printing 
Considerations. 

You will not be able to print in the NLQ or Draft modes (see Print) unless you 
have selected portrait orientation and the "Aspect Adjusted" option. 

This requester's "No Gaps Between Pages" option sets the maximum printable 
area to allow printing over the full length of the page. This may be useful if you 
are using continuous-form paper and do not want printing to skip over perfora
tions. The maximum printable area is shown as a dotted border on the page if 
Show Invisibles has been selected from the View menu. 

Print 

Displays a submenu of commands for printing documents from ProWrite. 

Preview 

Displays a requester showing a reduced size preview of how your document 
will look when printed, one page at a time. You can advance or go back 
through the pages by clicking on the "Next" or "Previous" buttons, or display 
a particular page by typing the page number in the text box and clicking on 
the "Go" button. 

Print One Keyboard equivalent: AL T -F5 

Instructs ProWrite to print a single copy of the current document. The options 
used are the same as the last time the document was printed. See Print. 

Print Keyboard equivalent: F5 

Instructs ProWrite to print a document. 

When you choose this command, a requester will appear to let you choose 
from several print options. You can have Pro Write print all pages of the 
document, or just a specific range of pages, and you can request multiple 
copies of each page printed. If you select the "Automatic" paper feed radio 
button, ProWrite will assume that the printer can print continuous forms; 
otherwise select "Hand feed" to make ProWrite wait after each page for you 
to insert the next sheet of paper. 



ProW rite Reference 

Other paper handling options are: "Collate," which causes each copy of a 
multi-page document to be printed separately; "Print Back to Front," which 
causes the document's last page to be printed first; and "Print Odd Then Even 
Pages," which can be useful in printing two-sided documents. These options 
may be used in various combinations to avoid having to manually re-order 
pages after printing. 

You can also specify the type of printing you want-"PostScript" for printing 
on PostScript printers, "High" for a graphics printout at full printer resolution, 
"Normal" for a graphics printout at screen resolution, "NLQ" for a printout 
using your printer's "Near Letter Quality" fonts, or "Draft" for a printout 
using your printer's Draft fonts. "PostScript", "High", and "Normal" modes 
print all of the graphics and fonts that you see on your screen. The "NLQ" and 
"Draft" modes substitute your printer's built-in font for the fonts in your 
document, see Appendix B: Printing Considerations. 

There are several options you can set to precisely control the printing results. 
Click on the "Options" button to display a requester where you can set these 
options. There is a different "Options" requester for "PostScript" mode vs. the 
other printing modes. See the section on printing in the Using ProWrite 
chapter, and Appendix B: Printing Considerations for more information 
about setting these options. 

Print Merge 

Instructs ProW rite to print multiple copies of the document merged with a 
data file. 

When you choose this command, the "Open" requester will appear so you 
may choose a file containing merge data for this document. The merge file's 
contents must be arranged in a certain format, described under Printing 
Merged Documents in the Using ProW rite chapter. The data file must be 
saved as "Text Only"; see Open. 

After you have chosen a document to open, a second requester will appear so 
you may set a range ofrecords to be merged. This enables you to print only a 
portion of a large number of records. The default selection is to merge all 
records. Empty records are ignored when determining record numbers. 

Once you have set the range of records to be merged, you will see the "Print" 
requester where you can specify various printing options; see Print. 

The document to be printed must have markers showing the fields to be 
substituted from the data file. These markers consist of the field name 
enclosed in double angle brackets « » (obtained on the Amiga keyboard by 
pressing ALT-9 and ALT-O). Again, see Printing Merged Documents in the 
Using ProW rite chapter. 
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Information 

Displays a requester showing the document's creation date and date it was last 
saved. This requester also contains a text box where you can add a comment for 
the document. If you give the document a comment, the comment will be dis
played whenever the. document is first loaded. 

This requester also contains a text box where you can set a password for the 
document. If you give the document a password, you will not be able to load the 
document later without first entering the password. Furthermore, password 
protected documents have their contents encrypted, so you will not be able to use 
any other program to view the document's contents. If you use this feature, do not 
forget your password--{)therwise you will not be able to recover your document! 

Settings 

Displays a submenu of commands for saving or loading ProWrite settings. These 
settings include all of the settings in the Edit, Format and View menus, as well as 
settings in the "Layout", "Page Setup", and "Print" requesters (except for the 
"Pages" and "Copies" settings). 

Save 

Saves ProWrite's current settings as the default values. These values will then 
become the new defaults every time you start ProWrite. 

Save As 

Prompts you for a name and location to save ProWrite's settings. You can 
then load these settings at any later time. 

Load 

Prompts you for a settings file to load. The settings contained in the specified 
file will become the current settings. 

Quit Keyboard equivalent: Amiga-Q 

Closes all open documents, exits the ProWrite program, and returns to the Work
bench. 

If you have not already saved changes to any documents, ProWrite will ask if you 
want to save changes to those documents before quitting. 
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The Edit Menu 

Commands in the Edit menu allow you to cut and paste text and pictures in your 
documents, insert special items such as page number, date, and time markers, and 
perform other editing operations. 

Undo Keyboard equivalent: Amiga-Z 

Restores the active document to whatever state it was in before the previous 
operation or command. 

The Undo menu item changes to reflect the last command used; for instance, Undo 
Typing indicates that the last operation was typing. If the last command was 
Undo, then this menu command will change to Redo (i.e., undo the undo). The 
Undo command must be chosen immediately after the operation. Even simply 
clicking the mouse button or moving the insertion point with the cursor keys will 
disable the undo. 

Cut Keyboard equivalent: Amiga-X 

Cuts selected text or picture and keeps it in an internal clipboard, replacing any 
previously cut or copied selection. 

The selected item is removed from the document. 

Copy Keyboard equivalent: Amiga-C 

Copies selected text or picture and keeps it in an internal clipboard, replacing any 
previously cut or copied selection. 

The selected item is not removed from the document. 

Paste Keyboard equivalent: Amiga-V 

Inserts any previously cut or copied text into the document at the insertion point. 

Pictures are inserted in the upper left comer of the document's window. 

Erase 

Permanently removes the selected text or picture from the document. 
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HotLinks 

Displays a submenu of commands which allow you to link text and graphics in 
ProWrite with other programs. You must have the HotLinks system, developed by 
Soft-Logik Publishing Corp., installed in order to use the HotLinks feature. Refer 
to the HotLinks User's Manual for more information on using HotLinks with 
ProWrite. 

Publish 

Publishes the text of your document as a HotLinks edition. A requester will be 
displayed where you can specify a name for this edition. 

Subscribe 

. Subscribe to a HotLinks edition, either text or pictures. A requester will be 
displayed where you can select the edition you wish to subscribe to. 

Update 

Performs an immediate update of any HotLinks editions you have published 
or subscribed to. 

Information 

Displays inforn1ation about the selected HotLinks edition. 

Break Link 

Breaks the link with the selected HotLink edition. 

Retain 

Displays a submenu of two commands which let you copy text attributes into an 
internal buffer for later application (see Apply). The available commands are: 

Style 

Retains the font, style attributes, and color of either the selected character or 
the character to the left of the insertion point. 

Format Keyboard equivalent: Amiga-K 

Retains the margins, tab stop settings, alignment, and spacing of the paragraph 
that contains the insertion point. 
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Apply 

Displays a submenu of two commands which let you apply retained text attributes 
(see Retain). The available commands are: 

Style 

Applies the last style retained to the selected characters. 

Format Keyboard equivalent: Amiga-Y 

Applies the last format retained to the selected paragraphs. 

Change Case 

Displays a submenu of commands which let you quickly change the capitalization 
of selected text. The available commands are: 

UPPER CASE 

Changes selected text so that all characters are capitalized. 

lower case 

Changes selected text so that all characters are in lower case. 

Mixed Case 

Changes selected text so that the first letter of every whole word is capitalized. 

Insert Item 

Displays a submenu of special items which may be inserted into the text at the 
insertion point. The available choices are: 

Page Break 

Inserts an item to force a page break, so subsequent text begins on the next 
page. If you select Show Invisibles in the View menu, this item will appear in 
the document as a bold downward-pointing double arrow. 

Column Break 

Inserts a forced column break item. If you select Show Invisibles in the View 
menu, this item will appear in the document as a bold downward-pointing 
arrow. 
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In snaking columns (see Layout in the Document menu), a column break 
advances editing to the next column, or to the first column of the next page if 
the insertion point is in the last column. In side-by-side columns it returns to 
the first column, one position down. 

Page Number 

Inserts a page number item which always reflects the number of the page it is 
on; its appearance may be changed using the Item Formats command and the 
character commands in the Format menu. Page number items are useful in 
headers and footers; see the Edit Footer and Edit Header commands in the 
Document menu. 

Page Count 

Inserts a page count item which always reflects the total number of pages in 
the document; its appearance may be changed using the Item Formats 
command and the character commands in the Format menu. 

Date 

If this command is chosen by itself, it inserts a date item which always reflects 
the current system date. The date format may be changed using the Item 
Formats command and the character commands in the Format menu. 

If you hold the ALT key while choosing Date, the current date will be entered 
in the current date format as if you had typed it yourself. This text will not be 
updated after it is entered. 

Time 

If this command is chosen by itself, it inserts a time item which always 
reflects the current system time. The time format may be changed using the 
Item Formats command and the character commands in the Format menu. 

If you hold the ALT key while choosing Time, the current time will be entered 
in the current time format as if you had typed it yourself. This text will not be 
updated after it is entered. 

Literal 

Allows you to select from a table of all printable characters, displayed in the 
current font; click the desired character to insert it into the text. This is useful 
for inserting special characters, such as "®," or characters from a symbol font 
for which you may not know the proper key combination. 
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Space Keyboard equivalent: Amiga-/ 

Inserts a space character without moving the insertion point. This is useful for 
making space to insert text while in typeover mode; see Preferences. 

Item Formats 

Allows you to alter the appearance and behavior of certain items found in the 
Insert submenu. A number of appearance conventions are provided for page 
number, time, and date. The page number convention is also used for page count 
items. 

In addition, a text box is provided so you may choose a starting page number for 
your document. Note that zero is a valid starting page number. This is useful if you 
have set up a title or cover page and want page numbering to start with the second 
printed page. See Layout in the Document menu. 

Sort 

Displays a submenu of commands which allow you to sort paragraphs in either 
ascending or descending alphabetical order. You must have at least two paragraphs 
selected for this command to be available in the menu. 

AtoZ 

Sorts the selected paragraphs in ascending order. 

ZtoA 

Sorts the selected paragraphs in descending order. 

Select All Keyboard equivalent: Amiga-A 

Selects the entire text of the document. This is useful for making global changes to 
the character font or style, or the paragraph format of the document. 
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Preferences 

Displays a submenu of commands that allow you to change certain aspects of 
ProWrite's behavior. 

Open & Save 

Displays a requester where you can set options controlling ProWrite's "Open" 
and "Save" operations. For saving documents, you can have ProWrite create 
icons when it saves files, have backup copies of files automatically made, and 
have ProWrite automatically save your files at regular intervals. For opening, 
you can have ProWrite always show all files in its "Open" requester. 

General Keyboard equivalent: SHIFT-HELP 

Displays a requester where you can set options controlling ProWrite's general 
operations. You can control the unit of measurement used in ProWrite's 
requesters, the insertion point blink rate, type of error signalling, and typing 
mode. You can also control ProWrite's use of the system clipboard, and 
specify whether Pro Write should cache a screen version of pictures when it 
loads them. 

Paper Color 

Displays a requester where you can select the color ProWrite should use for 
the paper color in the window display. 

Screen Colors 

Displays a requester where you can change the screen colors currently used by 
ProWrite. To change a screen color, click on the color then click on "Change", 
or simply double-click on a color. ProWrite will then display a requester 
where you can specify a color, either by giving red, green, and blue intensi
ties, or specifying the color's hue, saturation, and brightness. 
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The Search Menu 

The Search menu provides commands that let you quickly find or change text in 
your document, or go to particular locations. 

Find Keyboard equivalent: Amiga-F 

Searches for specific text in a document. 

This command displays a requester with a text box for you to type the text you 
want to find. Two check boxes are provided: select "Whole Word" if you don't 
want larger words that happen to contain your search text, the way "ambush" 
contains "bush"; select "Match Upper!Lower Case" if you don't want to find 
words that are capitalized differently, the way "Bush" differs from "bush." The 
search starts at the insertion point; if it reaches the end of the document, you will 
be asked if you want to start over at the beginning (unless that's where you 
started). 

Find cannot recognize words which have soft hyphens (ALT-n) imbedded in them, 
unless the search text also includes the soft hyphen. 

Find Next Keyboard equivalent: Amiga-O 

Searches for the next occurrence of the search text that you specified in your most 
recent Find command. 

Change Keyboard Equivalent: Amiga-E 

Instructs ProWrite not only to find specific text but also to change it. 

A requester is displayed which contains two text boxes for you to type in both the 
text you wish to find and what you want to change it to. As in the Find command, 
you may also indicate that ProWrite is to find only whole words and/or match 
capital and lower case letters exactly as they appear in the first text box. The 
search begins at the insertion point; when it reaches the end of the document you 
will be asked if you want to start over at the beginning (unless that's where you 
started). 

Once a match has been found, you may do one of several things: click "Find" to do 
nothing but go on to the next occurrence; click "Change, Then Find" to change the 
text and go on; click "Change" to change this occurrence and wait; or click 
"Change All" to change every occurrence remaining in the document. 
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Go To Page Keyboard equivalent: Amiga-G 

Moves the insertion point to the top of a specific page. 

A requester will appear with a text box so you may type the desired page number. 

Go To Selection 

Scrolls the document so that the insertion point or selection is visible in the 
window. 

Set Bookmark 

Sets a "Bookmark" at the location of the insertion point, allowing you to easily 
return to this location after you have been making changes elsewhere in the 
document. 

If the text containing the bookmark is deleted, the bookmark will be removed. 

Go To Bookmark 

Moves the insertion point to the location of the bookmark you last set. 
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The Format Menu 

The Format menu provides commands which let you control the format and 
appearance of the text and pictures in your document. 

Font Keyboard equivalent: Amiga-T 

Allows you to change typefaces and type sizes. 

This menu command displays a submenu which shows a list of most frequently 
used fonts, and the command Other for selecting fonts that are not listed in the 
menu. When you choose Other, a requester is displayed showing a list of all 
installed font names, and installed sizes for the selected font name. To change the 
font you are using, click on the name, then either click on the size (if it is listed) or 
type the size you want to use. If you turn on the "Show Font Sample" check box, a 
sample of the font will be shown in the requester. If you tum on the "List Font in 
Menu" check box, the font will be included in the Font submenu. You can have up 
to 18 fonts listed in the submenu. 

Style 

Displays a submenu of style settings. 

Plain Keyboard equivalent: Amiga-P 

Removes all character styles. The font and color of the text is not affected. 

Bold Keyboard equivalent: Amiga-8 

Sets the type style to boldface. If the selected text is already in boldface (or 
the boldface style is already set) then boldfacing is removed. 

Italic Keyboard equivalent: Amiga-I 

Sets the type style to italics. If the selected text is already in italics (or the 
italic style is already set) then italicizing is removed. The insertion point will 
be slanted when it is in italic text. 

Underline Keyboard equivalent: Amiga-U 

Sets the type style to underlined. If the selected text is already underlined (or 
the underline style is already set) then underlining is removed. 
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Shadow 

Sets the type style to shadowed. If the selected text is already shadowed (or 
the shadowed style is already set) then shadowing is removed. This style is 
best if used with a character color other than black. 

Superscript Keyboard equivalent: Amiga-H 

Makes the text superscripted by raising the characters above the baseline of 
the text. If the selected text is already superscripted (or the superscript style is 
already set) then the text is returned to its normal position. 

Subscript Keyboard equivalent: Amiga-L 

Makes the text subscripted by lowering the characters below the baseline of 
the text. If the selected text is already subscripted (or the subscript style is 
already set) then the text is returned to its normal position. 

Color 

Displays a submenu from which you can choose a color for text. 

Alignment 

Displays a submenu from which you can choose a paragraph alignment based 
upon the ruler's margin settings. You can also choose these options by clicking 
icons in the ruler; see the Ruler section later in this chapter. The choices are: 

Left Keyboard equivalent: Amiga-[ 

Aligns text flush on the left margin and ragged on the right margin. 

Center Keyboard equivalent: Amiga-= 

Aligns text in the center between the left and right margins. 

Right Keyboard equivalent: Amiga-] 

Aligns text flush on the right margin and ragged on the left margin. 

Justified Keyboard equivalent: Amiga-J 

Aligns text flush on both the left and right margins. 
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Spacing 

Displays a submenu from which you can choose line spacing options. You can 
also choose these options by clicking icons in the ruler; see the Ruler section later 
in this chapter. The options are: 

Single Keyboard equivalent: Amiga-1 

Sets the paragraph's line spacing to single spacing. 

1-1/2 

Sets the paragraph's line spacing to one-and-a-half spacing. 

Double Keyboard equivalent: Amiga-2 

Sets the paragraph's line spacing to double spacing. 

Space Before 

Causes the paragraph to automatically have a blank line placed before it. 

Space After 

Causes the paragraph to automatically have a blank line placed after it. 

Line Height 

Displays a submenu where you can choose either to let ProW rite set the 
paragraph's line height automatically or to specify a fixed line height. The line 
height options are: 

Auto 

Sets the height of each line to the minimum which will accommodate the 
different fonts, superscripts, and subscripts that occur on that line. 

Fixed 

Displays a requester to let you specify a line height, in output dots, to use for 
all of a paragraph's lines. The height of an output dot is normally l/72nd of an 
inch, but for some printer drivers it will vary if you de-select "Aspect Ad
justed" in the Page Setup requester. 
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You may select pre-set line height values of 6 lpi (lines per inch) or 8 lpi text. 
These pre-sets are useful when you will be printing in "NLQ" or "Draft" 
mode (see Print), and want to keep superscripts and subscripts from changing 
the line height. 

Tab Type 

Displays a submenu for choosing the tab type to be used the next time you place a 
tab stop in the ruler. You can also choose these options by clicking ruler icons; see 
the Ruler section later in this chapter. The tab type options are: 

Left 

New tab stops will mark a left-hand alignment point for tabulated text. 

Center 

New tab stops will mark a centered alignment point for tabulated text. 

Right 

New tab stops will mark a right-hand alignment point for tabulated text. 

Decimal 

New tab stops will mark a point to which the decimal points of tabulated 
numbers will be aligned. 

Decimal Char 

When you choose this command, a requester will appear in which you can 
choose the character that will be considered a "decimal point" for decimal tab 
stops. This is useful in countries where the decimal character is not a period. 

Picture 

Displays a submenu of commands which control picture placement and appear
ance. 

Settings 

Displays a requester where you can change the picture's name, specify the 
amount to resize it relative to its original size, and have text automatically 
wrap around the picture. When you choose one of the text wrap options, you 
can also specify the amount of stand-off between the picture and text. 
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Move To Front 

Moves the selected picture in front of all other pictures. This is most useful 
when you have two or more pictures that overlap, and you wish to arrange 
their relative depth. 

Move To Back 

Moves the selected picture behind all other pictures. This is most useful when 
you have two or more pictures that overlap, and you wish to arrange their 
relative depth. 
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The Document Menu 

The Document menu provides commands for controlling the overall format of 
your documents, as well as commands for features such as spell checking and the 
thesaurus. 

Edit Document Keyboard equivalent: F6 

Causes the document to be displayed for editing. 

The document display's white area reflect the physical boundaries of the printed 
page, as set in the Page Setup requester (Project menu). Areas which would fall 
outside of this page are shown in blue. 

Most printers are not capable of printing on the entire physical page, but are 
limited to printing within a smaller printable area within the page boundaries. The 
outline of this area (also affected by Page Setup) is shown as a faint dotted line 
when Show Invisibles is selected in the View menu, and is also delimited by a 
grey area at either ends of the horizontal and vertical rulers. The actual editable 
region is determined by the overall margins set in the Layout requester and by 
each paragraph's individual ruler margin settings. 

Edit Header Keyboard equivalent: F7 

Causes the header to be displayed for editing. 

This command automatically activates the Show Header option. The header 
display may also be chosen by double-clicking the header region in the document 
display. Clicking the header display's close box returns you to the document 
display. 

If "Odd/Even Pages" is selected in the Layout requester, then Edit Header 
displays a submenu for editing either the odd or even page header, as desired. This 
option also enables a new keyboard equivalent: use ALT-F7 to edit the even header; 
F7 alone to edit the odd header. 

The white area of the header editing display reflects the height of the tallest 
header's text. Headers cannot be taller than one third of the page height. 

Edit Footer Keyboard equivalent: F8 

Causes the footer to be displayed for editing. 

This command automatically activates the Show Footer option. The footer display 
may also be chosen by double-clicking the footer region in the document display. 
Clicking the footer display's close box returns you to the document display. 
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If "Odd/Even Pages" is selected in the Layout requester, then Edit Footer 
displays a submenu for editing either the odd or even page footer, as desired. This 
option also enables a new keyboard equivalent: use ALT-F8 to edit the even footer; 
F8 alone to edit the odd footer. 

The white area of the footer editing display reflects the height of the tallest footer's 
text. Footers cannot be taller than one third of the page height. 

Show Header Keyboard equivalent: F9 

Causes the header to be shown in the document. If this option was already turned 
on then choosing it again will tum it off. 

Show Footer Keyboard equivalent: F10 

Causes the footer to be shown in the document. If this option was already turned 
on then choosing it again will tum it off. 

Layout 

Brings up a requester which lets you control the appearance of your document. 

The text boxes under the heading "Margins" in this requester let you impose limits 
on the editable area of your document. These settings are expressed in inches or 
centimeters. The default margins are set to the maximum area that is considered 
printable if Page Setup's "No Gaps Between Pages" option is de-selected. You 
can alter the margin settings as necessary to adjust the amount of white space 
around your text. Any ruler margin settings you have made will be adjusted 
accordingly; see The Ruler, later in this chapter. 

Both the margins and the maximum printable area can be made visible as dotted 
lines in the document display. See Show Page Guides and Show Invisibles in the 
View menu. The unprintable areas to the left and right are also shown by grey 
regions in the ruler. 

If the "Odd/Even Pages" option is selected, the "Binding" margin will be added to 
either the left or right margin of each page, depending on the page's number. 
Otherwise the binding margin will always be added to the left margin. Selecting 
"Odd/Even Pages" also enables editing odd and even headers and footers sepa
rately. See Edit Header and Edit Footer. 

The document may be laid out in as many as ten columns by increasing or decreas
ing the "Number" setting for "Columns." The "Gap Between" setting determines 
the distance between columns. Individual paragraph indentation and margin 
settings are added to this gap. 
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There are two kinds of columns, "Snaking" columns run down the page to the 
bottom of a column, then jump up to the top of the next (like columns in a newspa
per). "Side by Side" columns jump from one column to the next at the end of each 
paragraph, backing up only far enough to keep the paragraph's first lines even; 
from the last column the text jumps back to the left side of the page to start a new 
row of paragraphs. There is a pair of icons in the requester that illustrate these two 
column types; click the one desired to select it. 

Select the "Title Page" option if you want the document's first page to be laid out 
as a separate title page or cover sheet. This disables multiple columns, headers, 
and footers on the first page, and forces its binding margin to the left no matter 
what its page number is. 

Spelling 

Displays a submenu of spelling commands. 

Check 

Checks the spelling of the words in your document. Choose this command to 
see a requester that controls spell checking. To begin the check, click "Start". 

When a misspelled word is found, it is selected (highlighted) in the document 
and displayed in the requester. If you want to simply ignore this word, click 
the "Skip" button. If you want to save the word to your user dictionary, click 
"Learn." If you want to change the word's spelling directly, type a new word 
in the text box and click "Change" (the word you type will be checked as 
well). If you want to see a list of similar words displayed in the list box, click 
"Guess"; if you see the correctly spelled word in the list, you can either click 
on the new word and click "Change," or just double-click the new word. 

If a range of text is selected, only that range will be checked. Otherwise, the 
process begins at the insertion point and goes to the end of the document, 
where you will be asked if you wish to start over from the beginning (unless 
that's where you started). When you are through with the spell checker click 
"Done": this button will change to "Stop" while a check is going on, in case 
you want to interrupt the process. 

When you first use spell checking, ProWrite looks to see if there is a dictio
nary in the RAM disk: if not. the one in ProWrite's own drawer is used. Since 
the dictionary consists of about 100,000 words, copying it into the RAM disk 
can speed up spell checking by about six times. This is a good idea if you 
have enough memory in your system. To start up the RAM disk, double-click 
on the "RAMS tart" icon. If you have already been using a dictionary and want 
to change to another, use the Change Diet command. 
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Look Up 

Brings up a requester that lets you type in an individual word to look up in the 
dictionary. When you click the "Look Up" button, a list of similarly spelled 
words will be shown. You can insert one of these words into the document by 
either clicking the word and clicking "Insert," or by simply double-clicking 
the word. Otherwise, click "Done" to leave the requester. 

While Typing 

Turns on spell checking while typing. Each word of your text will be checked 
as you finish typing it, and the screen will flash if the word is not recognized. 
If you choose the Look Up command immediately afterwards, you will find 
the misspelled word already entered into the requester's text box so you can 
look up a new word and click "Insert" to replace the misspelled one. 

Spell checking while typing may make typing too slow on floppy-based 
systems. See the Check command for suggestions on using the RAM disk 
instead. 

Change Diet 

Brings up an Open requester with which you can choose the "Main" (non
user) dictionary you wish to use. User dictionaries cannot be changed this 
way; only one is supported, and it is loaded when ProWrite starts up. 

Thesaurus 

Displays a requester with a "Look Up" text box in which you can type a word or 
short phrase to find synonyms for. If the insertion point is in a word, or if a word is 
selected, that word is automatically placed in the text box. 

When you click the "Look Up" button, words with similar meanings will be shown 
in the list box, grouped into sub-lists with the same parts of speech and similar 
meaning. If you would like to see more synonyms for one of these words, click the 
new word and click "Look Up" again. You can do this as many times as you like; 
the thesaurus has over 300,000 cross-references, with entries for nouns, verbs, 
adjectives, adverbs, prepositions, and conjunctions. As you browse through the 
thesaurus, you can always return to previous levels by clicking "Prior." 

If you see a synonym you want to insert in the document (replacing selected text), 
click the new word and then click "Insert," or just double-click the new word. If 
you want to close the thesaurus without inserting a word, click "Done." 
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Speaking 

Displays a submenu of commands for controlling ProWrite's speaking capability. 

Speak Now 

Begins speaking the text of the document using the current speak settings in 
the Speaking Options requester. If you have selected a range of text, only the 
selected text will be spoken; otherwise the entire document will be spoken. 

Options 

Displays a requester where you can set a number of options controlling 
ProWrite's speaking. You can adjust the type of voice (either "Male", 
"Female", or "Robotic"), pitch, and speed of the speaking. You can also 
indicate that the text you've selected for speaking consists of phonetic codes, 
rather than readable text. Typing speak text in phonetic codes gives you much 
greater control over the results of the speaking. 

While Typing 

Turns on speaking while typing. When this option is turned on, every charac
ter you type will be spoken back to you. 

Summary 

Displays a summary of several types of information about the document. 

When you choose this command, a requester is displayed which shows the current 
count of characters, words, lines, pages, sentences, paragraphs, and pictures in the 
document, as well as it's average word length, average sentence length, and an 
estimate of it's readability, expressed as an approximate minimum grade level. 
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The View Menu 

The View menu provides commands for controlling the display of several items in 
the document window, and for easily selecting a particular document for editing 
when you have several windows open. 

About ProWrite 

Displays copyright information about ProWrite, as well as information about 
available memory and the name of ProWrite's AREXX port. 

Show Invisibles 

Selects display of certain "invisible" elements of your documents: spaces, tabs, 
forced line breaks, paragraph ends, column breaks, and page breaks. 

An outline is also displayed to show each page's maximum printable area-the 
page boundary area where most printers cannot print. This area is affected by the 
"No Gaps Between Pages" option of the Page Setup requester. 

Show Page Guides 

Selects display of an outline showing the editable region defined by the margin 
and column settings; see Layout in the Document menu. The page guides initially 
coincide with the page's maximum printable area. 

Show Pictures 

Selects display of pictures on the screen. Otherwise, pictures in a document are 
represented by outlines showing their size and positions on the page. 

Show Ruler 

Displays a submenu of commands for displaying both the horizontal and vertical 
rulers. 

Horizontal Keyboard Equivalent: Amiga-R 

Displays the horizontal ruler. The horizontal ruler also has an optional strip of 
icons which can be used in control of a number of paragraph formatting 
commands. If the strip is not visible, double-click on the ruler's upper, 
division-marked area to tum the icon strip on; double-click again to remove it. 
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Vertical 

Displays the vertical ruler. 

Ruler Type 

Displays a submenu where you may choose the units you want the ruler divided 
by. The available units are: Inch, CM (centimeters), P 10 (10 pitch), P 12 (12 
pitch), Pica (six picas per inch), or Points (72 points per inch). 

The 10 pitch and 12 pitch rulers are useful for working with Pica and Elite non
proportional text. To enhance this use, the zero point for these rulers is aligned 
with the edge of the maximum printable area (1/4" from the edge of the page). The 
other ruler types are aligned to the edge of the page. 

(Window List) 

At the bottom of the View menu is a list showing the name of every window that is 
open. Choosing a name from the menu activates the window and brings it to the 
front. 
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The Macro Menu 

The Macro menu provides commands for executing macros. 

Before using any AREXX macros, you must first start the AREXX "resident 
process" with the "RexxMast" command. Consult your AREXX documentation 
for information about the AREXX language. 

Macro _1, Macro _2, ... Macro _10 

Each of these ten commands executes the corresponding ARE XX macro program, 
which must be stored as a "Text Only" file in the same directory (disk and drawer) 
as ProWrite. You can either name your macros "Macro_I", "Macro_2", and so 
forth, or use the Customize command to change the names of these menu entries 
to the names of your macros. 

Each of these commands may also be executed by holding down SHIFT and pressing 
the corresponding function key at the top of the Amiga's keyboard. 

Other Keyboard Equivalent: Amiga-M 

This command presents a requester with a string gadget in which you may type the 
name of any AREXX macro. If you just the name of a macro (i.e., no path specifi
cation), ProWrite will look in the same location (disk and drawer) as ProWrite for 
the specified macro. You can also click on the "7" button to display ProWrite's 
"Open" requester, where you can locate and select a macro to execute. 

Customize 

Displays a requester where you can specify the names for the macros you want to 
have listed in the Macro menu. Once you have made changes to the menu, you can 
either save those changes as your default, or just use them for this session. 
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You can have ProWrite display a horizontal and/or vertical ruler by selecting the 
appropriate Show Ruler command in the View menu. You may also choose a 
Ruler Type from the View menu. The horizontal ruler is used to adjust left and 
right margins, first line indentation, and tabs; these formatting items may be set 
separately for every paragraph. Both the horizontal and vertical rulers are used for 
adjusting a picture's location and size. 

To change a paragraph's formatting, first place the insertion point anywhere in the 
paragraph you wish to modify. The ruler will show the paragraph's current 
settings. You can fonnat several paragraphs at the same time by dragging across 
the ones you wish to change, in this case the ruler will show the settings for the 
first paragraph in the selected range. 

Margins 

The paragraph margin settings are bound by the overall page or column margins 
set in the Layout requester. When you change those margins, the paragraph 
settings adjust themselves to maintain the same relative arrangement. 

Paragraph margins are shown in the ruler by triangular markers. The right margin 
marker is a solid triangle pointing to the left; the left marker is a split triangle 
pointing to the right. To change the right margin, simply click and drag the marker 
along the ruler. The left margin marker works the same way, except its top and 
bottom halves may be moved separately; the top half (the indentation marker) 
controls the first line of the paragraph, while the bottom half (the left margin 
marker) controls the left margin for the rest of the paragraph. Hold the ALT key if 
you want to drag both markers at once. 

You can set up a hanging indentation by placing the indentation marker to the left 
of the main left margin marker. When you set up a hanging indent, the left margin 
marker is treated like a left tab stop for the first line of the paragraph. 

Tab Stops 

Each paragraph can have up to ten tab stops. To set a tab stop, click on the ruler 
(just beneath it's division-marked area) at the place where you want the tab stop to 
be. This creates a tab stop marker of the current type (left, center, right, or deci
mal). The current tab type may be set by using the Format menu or by clicking the 
appropriate icon in the ruler (see Ruler Icons, below). Move a tab stop just as if it 
were a margin marker, dragging it to a new position on the ruler. To remove a tab 
stop, drag it down off of the ruler and release the mouse button. 

If there are no tab stops set for a paragraph, then tabs will stop automatically at 
half-inch intervals. 
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Ruler Icons 

ProWrite's ruler is equipped with an optional strip of icons which can be used in 
place of a number of paragraph formatting commands. If the strip is not visible, 
double-click on the ruler's division-marked area to tum it on, then again to remove 
it. 

The icons are arranged in four groups: tab stop types (left, center, right, decimal), 
margin alignment (left, center, right,justified), line spacing (single, 1-1/2, double), 
and paragraph spacing (none, space before, space after). Simply click an icon to 
choose the desired effect. 

Pictures 

When you select a picture in a document, markers are displayed on both the 
horizontal and vertical rulers showing the picture's location and size. When you 
move or resize a picture, these indicators move to show you the resulting location 
or size of the picture. 
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Pro Write lets you use the keyboard instead of the mouse for most of its commands 
and operations. You may find it easier or faster to choose commands, move the 
insertion point, and select text from the keyboard instead of using the mouse and 
pulling down menus. There are three types of keyboard shortcuts: menu key 
commands, function key commands, and cursor key commands. In addition there 
are some miscellaneous keyboard commands, as well as keyboard shOltcutS 
involving requesters and the mouse. 

Note that many of the Amiga-key shortcuts use the first letter of the associated 
menu commands to make them easier to remember. You may remember the menu 
key commands for superscript and subscript by noticing that H stands for high and 
L for low, and the menu key command for "Font" by noticing that T stands for 
typeface. Some other shortcut keys are arranged so that they use adjacent charac
ters on the keyboard for commands which are often used together, such as "Undo," 
"Cut," "Copy," and "Paste" (Z, X, C, and V under the four fingers of the left 
hand). Function keys are also arranged so that similar commands are together. 

Menu Key Commands 

Some commands may be chosen by holding down the right Amiga key and 
pressing a character key. 

Press: 

Amiga-A 
Amiga-B 
Amiga-C 
Amiga-D 
Amiga-E 
Amiga-F 
Amiga-G 
Amiga-H 
Amiga-I 
Amiga-J 
Amiga-K 
Amiga-L 
Amiga-M 
Amiga-N 
Amiga-O 
Amiga-P 
Amiga-Q 
Amiga-R 
Amiga-S 
sHIFT-Amiga-S 

To choose: 

Select All 
Bold 
Copy 
Find Next 
Change 
Find 
Go To Page 
Superscript 
Italic 
Justified 
Retain Format 
Subscript 
Other Macro 
New 
Open 
Plain 
Quit 
Show Ruler 
Save 
Save As 
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Amiga-T 
Amiga-U 
Amiga-V 
Amiga-W 
Amiga-X 
Amiga-Y 
Amiga-Z 
Amiga-l 
Amiga-2 
Amiga-/ 
Amiga-= 
Amiga-[ 
Amiga-J 

Font 
Underline 
Paste 
Close 
Cut 
Apply Fonnat 
Undo 
Single Space 
Double Space 
Insert Space 
Centered 
Left Aligned 
Right Aligned 

Function Key Commands 

The function keys provide an alternative to menu key commands, including 
several commands without menu keys. Simply press the appropriate function key 
to choose the command. 

Function key Command 

Fl New 
F2 Open 
F3 Close 
F4 Page Setup 
F5 Print 
ALT-F5 Print One 
F6 Edit Document 
F7 Edit (Odd) Header 
ALT-F7 (Edit Even Header) (Odd/Even Pages only) 
F8 Edit (Odd) Footer 
ALT-F8 (Edit Even Footer) (Odd/Even Pages only) 
F9 Show Header 
FlO Show Footer 

Modified Menu Commands 

Some menu commands can be affected by modifier keys, creating new commands. 
There is also one command which is only available from the keyboard. 

ALT + Open 
ALT + Close 
ALT + Print Merge 
ALT + Insert Date 
ALT + Insert Time 

See all files in ProWrite's Open requester 
Close all open windows 
See all files in the Print Merge Open requester 
Insert non-updating date text 
Insert non-updating time text 
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Cursor Key Commands 

You can use the cursor keys in combination with ALT and CTRL to move the 
insertion point in the window. The following table outlines these cursor key 
commands. 

Press: 

Left cursor 
Right cursor 
Up cursor 
Down cursor 

SHIFT + left cursor 
SHIH + right cursor 
SHIFT + up cursor 
SHIff + down cursor 

ALT + left cursor 
AL T + right cursor 
AL T + up cursor 
AL T + down cursor 

To move: 

left a character 
right a character 
up a line 
down a line 

left a word 
right a word 
up a window 
down a window 

to the beginning of a sentence 
to the end of a sentence 
to the beginning of the document 
to the end of the document 

Holding down the CTRL key while using the cursor keys (with or without the SHIH 

or ALT keys) will select any text the insertion point passes over (just like dragging 
with the mouse). 

Other Key Commands 

There are several keys used for deleting a character at a time, a word at a time, and 
a sentence at a time. 

Press: 

BACKSPACE 

DEL 

SHIFT + BACKSPACE 

SHIFT + DEL 

ALT + BACKSPACE 

ALT + DEL 

HELP 

SHiff + HELP 

To: 

delete previous character 
delete next character 
delete to beginning of previous word 
delete to beginning of next word 
delete to beginning of current or previous sentence 
delete to beginning of next sentence 
About ProWrite 
General Preferences 
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And finally, there are a few miscellaneous keyboard shortcuts. 

Press: 

ALT + SPACE 
ALT +n 
AL T + (hyphen) 

RETURN 
SHIFT + RETURN 

ENTER 
SHIFf + ENTER 

To: 

insert non-breaking space 
insert discretionary (soft) hyphen 
insert soft hyphen(not available in requesters) 

insert paragraph break 
insert forced line break 

insert page break (in document display) 
insert column break 

ENTER insert page number 
insert page count 

(in header/footer display) 
SHIFf + ENTER 

Requester Shortcuts 

In requesters, you can select nearly any of the buttons and check boxes by typing 
the key corresponding to the underlined character in the button or check box. Note 
that if a text box is active, you will first need to de-activate it by pressing the right 
Amiga and ALT keys simultaneously. 

If a text box is active in a requester, it will intercept most of the keys you type. If 
the box happens to be grouped with other text boxes, you can move from one to 
the next by pressing RETURN and back again by pressing SHIFT-RETURN. If you press 
RETURN or SHIFT-RETURN when you are at the end or beginning of a group of text 
boxes, the outlined button (usually "OK") will be selected. If you are using 
Workbench 2.0 or later, you can also use the TAB and SHIFf-TAB keys to move 
between any text boxes in a requester, not just grouped text boxes. 

Pressing ENTER at any time will select the outlined button. 

In requesters with a list box, you can use the up and down cursor keys to scroll 
through the list. If two list boxes are present, use the SHIFf-UP and SHIFT-down keys 
to scroll through the second box. In requesters with up and down arrows for 
selecting a value, you can use the up and down cursor keys to select the up or 
down options. 
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Mouse Shortcuts 

In addition to making the keyboard more powerful, some modifier keys and click 
combinations can enhance mouse selection. 

double-click 
triple-click 
AL T + double-click 
AL T + triple-click 

select a whole word 
select a whole sentence 
select a whole paragraph 
select the whole document 

Dragging the cursor after selecting a whole word, sentence, or paragraph will 
continue selection by either whole words, sentences, or paragraphs, respectively. 

The ALT key can also be used to enhance the operation of some window gadgets: 

AL T + close box 
ALT + scroll up 
AL T + scroll down 
ALT + page up 
AL T + page down 

closes all windows 
scroll up one window-full 
scroll down one window-full 
scroll to beginning of document 
scroll to end of document 

Note that scroll commands do not move the cursor. 

Finally, here are some miscellaneous shortcuts: 

Click the page number indicator in the document display's border to bring up 
the Go To Page requester. 

Double-click the header or footer in the document editing display to bring up 
the editing display for that item. 

When editing a header or footer, click its close box to return to editing the 
document. 
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Macros and AREXX 

ProWrite is equipped with a software port which allows you to create external 
"Macro" programs using the AREXX language, and to execute those macro 
programs from within ProWrite. This facility also allows external AREXX 
programs to address ProWrite to send it macro commands. 

This section assumes that you are already familiar with the AREXX programming 
language. If you are not, please consult the AREXX manual. 

Creating and Using Macros 

A Macro program must be a "Text Only" file containing an AREXX program. The 
program's first line must be a comment. The macro file must be stored in the same 
directory (disk and drawer) with the ProWrite program. 

Before using macros, you must first start the AREXX "resident process" with the 
"RexxMast" command. Macro programs are accessed through the Macro menu, or 
by holding shift and pressing the corresponding function key on the keyboard. 
AREXX programs which are run externally may send ProWrite commands 
directly by addressing the port named "ProWrite". 

If ProWrite was started from a CLI, it will print diagnostic messages to the CLI 
window if it detects any errors in a macro program. 
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ProWrite provides the following commands for use by macro programs. Most of 
these commands behave identically to an equivalent menu command. Note that 
there is no way for the AREXX port in ProWrite to respond to requesters; if any 
macro command causes ProWrite to display a requester, the user must acknowl
edge the requester before the macro can continue. 

In the following command descriptions, an item in parentheses 0 indicates an 
optional text string, an item in brackets [] indicates an optional keyword. If 
several keywords are in brackets separated by a vertical bar [ I ] then only one 
keyword in the list is allowed. 

Menu Commands 

New 

Open (file name) 

Close [NoPrompt] 

Open a new document. 

If file name supplied, open the specified file; otherwise 
display the "Open" requester. 

Close the active window, optionally bypassing the "Save 
Changes" prompt. 

InsertText (file name) If file name supplied, insert text from specified file; other
wise display the "Insert Text" requester. 

InsertPicture (file name) 
If file name supplied, insert picture from specified file; 
otherwise display the "Insert Picture" requester. 

SaveAs (file name) If file name supplied, save the document in normal format 
with the specified file name; otherwise display the "Save 
As" requester. 

SaveAsText (file name) 
If file name supplied, save the document in text-only format 
with the specified file name and the set text file type 
previously set with the TextFileType AREXX command; 
otherwise display the "Save As" requester. 

TextFileType [ParaLF I LineLF] 

PrintPreview 

Set the text file type for use with the "SaveAsText" AREXX 
command. 

Display the "Print Preview" requester. 
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Revert Display the "Revert" requester. 

PageSetup Display the "Page Setup" requester. 

SetPageSetup (page setup option) (page setup option) ... 
Set one or more page setup options. Valid page setup 
options are: 

USLetter 
A4Letter 
Portrait 
AspectAdjustOn 
NoGapsOn 

USLegal 
ComputerPaper 
Landscape 
AspectAdjustOff 
NoGapsOff 

PaperSize width height 
Change the paper size to the specified values (in decipoints). 

PrintScale (value) If a value is supplied, change the print scale to the specified 
scale percentage; otherwise return the current print scale 
value in the AREXX variable "result". 

PrintDensity (value) If a value is supplied, change the print density to the 
specified density number (in the range 1 ... 7); otherwise 
return the current print density number in the AREXX 
variable "result". The actual print density will depend upon 
the currently selected printer driver. 

PrintOne Print the active window with current settings. 

Print Display the "Print" requester. 

SetPrint (print option) (print option) ... 

PrintMerge 

Quit [NoPrompt] 

Set one or more print options. This command is most useful 
when used in conjunction with ProWrite's "Print One" 
AREXX command, as it lets you set the print options and 
begin a print job without having to go through the "Print" 
requester. Valid print options are: 

PostScript High 
NLQ Draft 
HandFeed Smooth 
PrintPicts NoPrintPicts 
NoOptSpace Collate 
BackToFront FrontToBack 
NoOddEven 

Display the "Print Merge" requester. 

Normal 
AutoFeed 
NoSmooth 
OptSpace 
NoCollate 
OddEven 

Quit ProWrite, optionally bypassing the "Save Changes" 
requester for all document windows. 
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Undo Undo the last command (if possible). 

Cut Cut the selected text or picture. 

Copy Copy the selected text or picture. 

Paste Paste the last item cut or copied. 

Erase Erase the selected text or picture. 

RetainStyle Retain the style of selected text. 

RetainFormat Retain the format of selected text. 

ApplyStyle Apply the last style retained. 

ApplyFormat Apply the last format retained. 

UpperCase Change case to UPPER CASE. 

LowerCase Change case to lower case. 

MixedCase Change case to Mixed Case. 

NewPage Insert a Page Break at the insertion point. 

NewColumn Insert a Column Break at the insertion point. 

InsertPageNumber Insert a Page Number item at the insertion point. 

InsertPageCount Insert a Page Count item at the insertion point. 

InsertDate Insert a Date item at the insertion point. 

InsertTime Insert a Time item at the insertion point. 

InsertLiteral Display the "Insert Literal" requester. 

InsertSpace Insert a Space before the insertion point. 

ItemFormats Display the "Item Formats" requester. 

PageNumberFormat [Arabic I RomanCap I RomanLower I AlphaCap I 
AlphaLowerl 
Set page number format to specified format. 

DateFormat [Short I Abbrev I Long I AbbrevDay I LongDay I Military 1 
Set date format to specified format. 



Search Menu 
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TimeFormat [12Hour I 24Hour] 
Set time format to specified format. 

StartPageNumber number 
Set the starting page number to specified number. 

SortAtoZ Sort selected paragraphs from A to Z. 

SortZtoA Sort selected paragraphs from Z to A. 

SelectAlI Select All text. 

SetPreferences (preferences option) (preferences option) ... 
Set one or more preferences options. Valid options are: 

Measurelnch MeasureCM 
Insert Typeover 
ErrorFlash ErrorBeep 
BlinkFast 81inkSlow 
ShowProWrite ShowAll 
SavelconsOn 
Make8ackupsOn 
AutoSaveOn 
FullClipboardOn 
CachePicturesOn 

SavelconsOff 
MakeBackupsOff 
AutoSaveOff 
FullClipboardOff 
CachePicturesOff 

ErrorBoth 
BlinkOff 

Find (search text) If search text supplied, search for the text using current find 
options; otherwise display the "Find" requester. 

SetFind (find option) (find option) ... 
Set one or more find/change options. Valid options are: 

WholeWord NoWholeWord 
MatchCase NoMatchCase 

SetFindText text Set the text to find, without starting the search. 

FindNext [NoPrompt] Find the next occurrence of the find text, optionally bypass
ing the "Continue from beginning" prompt. 

Change Display the "Change" requester. 

FindPicture (name) If a picture name is supplied, find the specified picture; 
otherwise display the "Find Picture" requester. 

GoToPage (number) If a number is supplied, go to the specified page; otherwise 
display the "Go To Page" requester. 

GoToSelection Go to the current selection. 

SetBookmark Set document bookmark at current location. 

155 



Format Menu 
Commands: 

156 

GoToBookmark 

Font 

FontName (name) 

FontSize (size) 

StylePlain 

StyleBold 

Sty leI talic 

StyleUnderJine 

StyleShadow 

StyleSuper 

StyleSub 

ColorBlack 

ColorRed 

ColorYellow 

ColorGreen 

ColorCyan 

ColorBlue 

ColorMagenta 

AlignLeft 

AlignCenter 

AlignRight 

Return insertion point to last bookmmark set. 

Display the "Font" requester. 

If a name is supplied, change selected text to specified font 
name (without changing the font size); otherwise return the 
font name of the currently selected text in the AREXX 
variable "result". 

If a size is supplied, change selected text to specified font 
size (without changing the font name); otherwise return the 
font size of the currently selected text in the AREXX 
variable '"result". 

Set the text's style to plain. 

Set the text's style to bold. 

Set the text's style to italic. 

Set the text's style to underline. 

Set the text's style to shadow. 

Set the text's style to superscript. 

Set the text's style to subscript. 

Set the text's color to black. 

Set the text's color to red. 

Set the text's color to yellow. 

Set the text's color to green. 

Set the text's color to cyan. 

Set the text's color to blue. 

Set the text's color to magenta. 

Set the paragraph's alignment to left. 

Set the paragraph's alignment to center. 

Set the paragraph's alignment to right. 
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AlignJustify Set the paragraph's alignment to justified. 

SpaceSingle Set the paragraph's spacing to single. 

SpaceOneAndHalf Set the paragraph's spacing to 1-1/2. 

SpaceDouble Set the paragraph's spacing to double. 

SpaceBefore Set the paragraph's spacing to space before. 

SpaceAfter Set the paragraph's spacing to space after. 

LineHeightAuto Set the paragraph's line height to auto. 

LineHeightFixed (line height) 
If a line height is supplied, change the selected paragraphs 
to the specified line height; otherwise display the "Line 
Height" requester. 

TabLeft Set the new tab type to left. 

TabCenter Set the new tab type to center. 

TabRight Set the new tab type to right. 

TabDecimal Set the new tab type to decimal. 

DecimalChar (char) If a character is supplied, change the decimal character to 
the specified character; otherwise display the "Decimal 
Character" requester. 

PictSettings Display the "Picture Settings" requester. 

PictMoveToFront Move the selected picture to the front. 

PictMoveToBack Move the selected picture to the back. 

PictTextWrap [LeftBlock I LeftContour I RightBlock I RightContourJ 
Set picture wrap type. 

PictTextGap (value) If a value is supplied, set the picture text gap to the specified 
value (in decipoints); otherwise return the selected picture's 
text gap value in the AREXX variable "result". 

PictName (name) If a name is supplied, change the selected picture's name to 
the specified name; otherwise return the selected picture's 
name in the AREXX variable "result". 
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PictScale width height 

EditDocument 

EditHeader 

EditOddHeader 

EditEvenHeader 

EditFooter 

Edi tOddFooter 

EditEvenFooter 

ShowHeader 

ShowFooter 

Layout 

Scale the selected picture to given width and height percent
ages of original size. 

Start to edit in the document display. 

Start to edit in the header display. 

Start to edit in the odd header display. 

Start to edit in the even header display. 

Start to edit in the footer display. 

Start to edit in the odd footer display. 

Start to edit in the even footer display. 

Show the page header in the document. 

Show the page footer in the document. 

Display the "Layout" requester. 

SetLayout (layout option) (layout option) ... 
Set one or more layout options. Valid print options are: 

TitiePageOn TitlePageOff 
OddEvenOn OddEvenOff 
ColumnSnaking Co!umnSideBySide 

SpellCheck Display the "Spelling Check" requester. 

SpellLookUp Display the "Spelling Look Up" requester. 

SpellWhileTyping Have spelling checked while typing. 

SpellChangeDict (file name) 

Thesaurus 

Speak 

SpeakNow 

SpeakTyping 

If file name supplied, change to the specified dictionary; 
otherwise display the "Change Dictionary" requester. 

Display the "Thesaurus" requester. 

Display the "Speak Options" requester. 

Begin speaking the document using the current settings. 

Speak each character while typing. 



Misc. Commands: 

Summary 

ScreenToFront 

ScreenToBack 

Window title 

WindowNoFront title 

ProgName 

ProgVersion 

DocName 

DrawOff 

DrawOn 

SetPath path 
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Display the document "Summary" requester. 

Bring the ProWrite screen to the front. 

Send the ProWrite screen to the back. 

Select window with given title. 

Activate specified window without bringing it to the front. 

Returns the name of the ProWrite program in the AREXX 
variable "result". 

Returns the ProWrite version number in the AREXX 
variable "result". 

Returns the name of the current document in the AREXX 
variable "result". 

Suspend all window display operations until a "DrawOn" 
command, or until macro execution is completed. 

Resume all window display operations. 

Sets the current directory path to specified path name. 

Text Entry Commands 

These are commands which ProWrite provides for entering text into ProWrite's 
active document. Also see the "Insert" macro menu commands listed earlier. 

Type (text block) 
Insert a quote-enclosed block of text. The text block must be enclosed in single or 
double quotes, or AREXX will convert it to upper case. 

The "Type" command allows you to enter text directly into the editing display 
from a macro program. The text will be inserted at the insertion point. Multiple 
type commands may be mixed with other commands in much the same way you 
would use style and formatting commands as you type. For example: 

/* Simple Typing Test */ 
AlignCenter 
Type 'This is a test of ' 
StyleBold 
Type 'Macros ' 
StylePlain 
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Type 'in ProWrite.' 
NewParagraph 

Notice that an extra space has been left at the end of the first two text strings to 
correctly space the word "Macros". Here is what this example types: 

This is a test of Macros in ProWrite. 

If the string to be typed contains either quote type (single or double), you may use 
the other quote type to denote the string. For instance the macro program: 

/* Quote Test */ 
Type 'Quoth the robot, "Nevermore!"' 
NewParagraph 

Will type the text: 

Quoth the robot, "Nevermore!" 

ASCII (ASCII code) 
Insert a single character with the given decimal ASCII code. 

The "ASCII" command allows you to enter any printable character at the insertion 
point's location by using its decimal ASCII code. You may also enter a tab 
character (ASCII 9) or forced line break (ASCII 10). For example, a double quote 
is ASCII 34, so the previous example could be re-written this way: 

/* ASCII Test */ 
Type 'Quoth the robot, 
ASCII 34 
Type 'Nevermore!' 
ASCII 34 
NewParagraph 

This example enters the same text as the last one. 

ProWrite recognizes ASCII codes 9, 10, the range from 32 to 126, and the range 
from 160 to 255. These codes will not all produce meaningful characters in every 
font, nor will every font's character for a given code always be the same, espe
cially in the range from 160 to 255. Also, characters printed in NLQ or Draft 
modes will not always match the characters displayed on the screen. 

The following tables list some useful ASCII codes available in the Pica font: 
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Characters 

Digits 0-9 
A-Z 
a-z 
tab 

NewParagraph 
NewColumn 
NewPage 

Codes 

48-57 
65-90 
97-122 
9 

Character Code 

forced line break 10 
space 32 
non-break space 160 
soft hyphen 173 

Inserts a paragraph break, column break, or page break. 

This command is the same as pressing return, shift-enter, or enter on the keyboard. 
It places a paragraph, column, or page break at the insertion point. Text entered by 
separate "Text" and "ASCII" commands will be added to the same paragraph 
unless one of these commands is used between them. 

Formatting Commands 

A number of commands are provided to both set and get values for all of 
ProWrite's format settings. 

Leftlndent (value) 
If value is given, set the left indent (relative to document margins) to value (in 
decipoints); otherwise return current left indent value in the AREXX variable 
"result" . 

LeftMargin (value) 
If value is given, set the left margin (relative to document margins) to value (in 
decipoints); otherwise return current left margin value in the AREXX variable 
"result". 

RightMargin (value) 
If value is given, set the right margin (relative to document margins) to value (in 
decipoints); otherwise return current right margin value in the AREXX variable 
"result". 

AddTab value 
Add a tab stop of the current tab type at the position indicated by value (in 
decipoints, relative to the document margins). 

Rem Tab value 
Remove the tab stop at the position indicated by value (in decipoints, relative to 
the document margins). 
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DocLeftMargin (value) 
If value is given, set the document left margin to value (in decipoints); otherwise 
return current document left margin value in the AREXX variable "result". 

DocRightMargin (value) 
If value is given, set the document right margin to value (in decipoints); otherwise 
return current document right margin value in the AREXX variable "result". 

DocTopMargin (value) 
If value is given, set the document top margin to value (in decipoints); otherwise 
return current document top margin value in the AREXX variable "result". 

DocBottomMargin (value) 
If value is given, set the document bottom margin to value (in decipoints); other
wise return current document bottom margin value in the AREXX variable 
"result". 

DocBindingMargin (value) 
If value is given. set the document binding margin to value (in decipoints); 
otherwise return current document binding margin value in the AREXX variable 
"result". 

DocColumnGap (value) 
If value is given, set the column gap to value (in decipoints); otherwise return 
current column gap value in the AREXX variable "result". 

Columns (number) 
If number is supplied, set the number of columns to specified number (in the range 
1...10); otherwise return current number of columns in the AREXX variable 
"result" . 

Move Commands 

These are commands which ProWrite provides for moving the insertion point in 
the current document. 

CursorUp 
Unless it is altered by a previous modifier command, this command moves the 
insertion point up one line. Otherwise, this command's modified action is the same 
as if you held a modifier key and pressed the up cursor key. 

CursorDown 
Unless it is altered by a previous modifier command, this command moves the 
insertion point down one line. Otherwise, this command's modified action is the 
same as if you held a modifier key and pressed the down cursor key. 
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CursorLeft 
Unless it is altered by a previous modifier command, this command moves the 
insertion point one character to the left. Otherwise, this command's modified 
action is the same as if you held a modifier key and pressed the left cursor key. 

CursorRight 
Unless it is altered by a previous modifier command, this command moves the 
insertion point one character to the right. Otherwise, this command's modified 
action is the same as if you held a modifier key and pressed the right cursor key. 

Backspace 
Unless it is altered by a previous modifier command, this erases the character to 
the left of the insertion point and moves the insertion point and following text one 
character space to the left. Otherwise, this command's modified action is the same 
as if you held a modifier key and pressed the backspace key. 

Delete 
Unless it is altered by a previous modifier command, this erases the character to 
the right of the insertion point and moves the following text one character space to 
the left. The cursor does not move. Otherwise, this command's modified action is 
the same as if you held a modifier key and pressed the del key. 

MoveNextPara 
Move inseltion point to beginning of next paragraph. 

MovePrevPara 
Move insertion point to beginning of previous paragraph. 

MoveBeginLine 
Move insertion point to beginning of current line. 

MoveBeginDoc 
Move insertion point to beginning of document. 

MoveEndDoc 
Move insertion point to end of document. 

FirstPicture 
Select the first (top-most) picture in the document. 

NextPicture 
Select the next picture down in the document. 

CurrentPage 
Return the page number the insertion point is on in the AREXX variable "result". 
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Modifier Commands 

These are keyboard modifier commands which ProWrite provides so that you can 
modify menu and insertion point moving commands from within macro programs. 
ProWrite automatically sets all modifier commands to the up position before 
beginning a new macro. 

ShiftDown 
Begin shift modification. Any subsequent menu, backspace, delete, or insertion 
point moving commands will be modified as if you were holding the shift key 
while performing the operation. This command does not affect either the "Type" 
or the "ASCII" command. The shift modification will remain in effect until a 
ShiftUp command is executed. 

The following example program moves the insertion point to the beginning of the 
next word. 

ShiftUp 

/* SHIFT Modifier Test */ 
ShiftDown 
CursorRight 
ShiftUp 

If shift modification is in effect, end it. If you fail to use this command after you 
are through with a shift modified sequence, subsequent portions of the macro may 
not behave as you expect. 

AltDown 
Begin alt modification. Any subsequent menu, backspace, delete, or insertion point 
moving commands will be modified as if you were holding the alt key while 
performing the operation. This command does not affect either the "Type" or the 
"ASCII" command. The alt modification will remain in effect until an AltUp 
command is executed. 

The following example program inserts a non-updating time item at the insertion 
point. Without alt modification, the time item created would update every time the 
document was re-drawn or printed. 

AItUp 

/* ALT Modifier Test */ 
AltDown 
InsertTime 
AltUp 

If alt modification is in effect, end it. If you fail to use this command after you are 
through with an alt modified sequence, subsequent p0l1ions of the macro may not 
behave as you expect. 
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CtrlDown 
Begin ctrl modification. Any subsequent menu, backspace, delete, or insertion 
point moving commands will be modified as if you were holding the ctrl key while 
performing the operation. This command does not affect either the "Type" or the 
"ASCII" command. The ctrl modification will remain in effect until a CtrlUp 
command is executed. 

The following example program moves the insertion point to the beginning of 
whatever sentence it is in, then selects the whole sentence. This is equivalent to 
triple-clicking in the sentence. 

/* CTRL Modifier Test */ 
AltDown 
CursorLeft 
CtrlDown 
CursorRight 
CtrlUp 
AltUp 

Note that in this case both alt and ctr! modifiers are used, and that the 
"CursorRight" command is modified by both. 

CtrlUp 
If ctrl modification is in effect, end it. If you fail to use this command after you are 
through with a ctrl modified sequence, subsequent portions of the macro may not 
behave as you expect. 

Extracting Text 

ProWrite has a command, Extract, for getting the selected text and making it 
available to the AREXX macro. 

Extract 
This is an extremely powerful command which allows you to extract a copy of 
selected text from the current ProWrite document. Once the text has been returned 
to AREXX, your macro program can modify or utilize that text in any way you see 
fit, using all of AREXX's text and numerical manipulation capabilities. The 
resulting text or data can then be stored, transferred to another program. or re
inserted into the ProWrite document. 

At some point in your macro program before you use the Extract command, 
you need to use the following AREXX command: 

Options Results 

This instructs AREXX to let subsequent commands return a result if they need 
to. 
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In your program, use the menu, modifier, and/or insertion point moving 
commands to select whatever text you wish to extract. If your program is to be 
used as a macro, you might simply decide to assume that the user has selected 
some text before invoking the macro. 

Note that AREXX cannot extract text beyond the first paragraph mark in the 
selection. This simply means that selected text before the first selected 
paragraph mark will be extracted, while selected text after any paragraph mark 
will be ignored. 

After the text has been selected, use this command in your macro program: 

Extract 

The extract command will copy the selected text (up to the first selected 
paragraph mark) to the AREXX variable "result". Your macro program can 
then use or modify the result text in any way you like. The Extract command 
will also set the AREXX variable RC to a non-zero value if the extraction 
failed (which can happen if nothing is selected in the document). 

Here is an example program which performs a "transpose" operation: 

/* Fast Transpose Example */ 
CtrlDown 
CursorLeft 
CursorLeft 
CtrlUp 
Options Results 
Extract 
If RC -= 0 Then Exit RC 
Type Reverse(result) 

This example selects the previous two characters, extracts them, then uses the 
AREXX function "Reverse" to type the characters in reversed order. 

Here is another example of using the Extract command, this time to calculate the 
result of a mathematical expression that has been selected and type the result: 

/* Math calculation */ 
Options Results 
Extract 
If RC -= 0 Then Exit RC 
result=Insert('a=',result) 
Interpret result 
Type '='a 
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To use this macro, simply select an equation in the document (such as "32*25"), 
and invoke the macro. Your equation can use any AREXX operation, including 
AREXX functions. 

User Requester Commands 

Several commands are available for giving information, or requesting information 
from the user. 

Request! info 
Display a requester with specified information text, and a single "OK" button. 
Sets AREXX variable RC to O. 

Request2 info 
Display a requester with specified information text, and two buttons labeled "OK" 
and "Cancel". Sets the AREXX variable RC to 0 if the "OK" button is pressed, 
and to 1 if the "Cancel" buttons is pressed. 

Request3 info 
Display a requester with specified information text, and three buttons labeled 
"Yes", "Cancel", and "No". Sets the AREXX variable RC to 0 if "Yes" is pressed, 
to I if "Cancel" is pressed, and to 2 if "No" is pressed. 

RequestText info 
Display a requester with specified information text, a text box for user text entry, 
and two buttons labeled "OK" and "Cancel". Sets the AREXX variable RC to 0 if 
"OK" is pressed, and to I if "Cancel" is pressed. If "OK" button is pressed, sets 
the AREXX variable "result" to the text box contents entered by the user. 
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Appendix 

This section covers material that is not directly related to the opera
tion of ProWrite. In this section you will find information that will 
help you utilize ProWrite more fully. 

The individual appendices in this section are: 

• Appendix A: Moving System Files 

• Appendix B: Printing Considerations 

• Appendix C: Printer Font List 

• Appendix D: Memory Considerations 

• Appendix E: Error Messages 

• Appendix F: Troubleshooting 
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If you are using a hard disk or other Workbench disk, you may not be using the 
latest printer drivers and other system files that it contains. On the other hand, 
ProWrite's "Fonts & Devices" disk does not include a complete set of Amiga 
fonts. In either case, you may want to move font or system files from one disk to 
another to create your own custom set-up. You may also wish to remove files you 
don't need, such as character fonts which your printer can't use. It is also quite 
sensible to remove any printer drivers other than the one your printer uses. 

ProWrite's "Extras" disk includes a tool named "System Mover", which simplifies 
the task of installing and removing fonts and other system files. 

About System Files 

If you use only the Workbench to run programs and delete files, and have never 
used the CLI, then you may not be aware that there are a large number of files on a 
Workbench disk that are hidden from Workbench's view. These "system" files are 
used for many operations, including providing common code routines for applica
tion programs, handling devices attached to your computer (such as a modem or 
printer), and dealing with the CLI environment. Fonts are contained in another 
type of system file that is also inaccessible to Workbench users. Unfortunately, for 
Workbench users this means that you have to use the CLI in order to do simple 
operations like updating your system to a new version, or simply installing fonts 
onto your Workbench disk. This is where the System Mover comes in. 

System Mover allows you to easily move system files of all types from one disk to 
another. When moving font files, it automatically updates all the appropriate font 
description (" .font") files, thus ensuring that these fonts will be accessible to all 
programs. Even for users familiar with the CLI, System Mover comes in handy 
since it will display information about the version of certain system files or, when 
version information is not available, information about the size of the file and 
when it was created (this information is useful in determining if you have the latest 
version of the system file). 

There are eight different kinds of system files that System Mover handles: 

Fonts 

Printers 

Keymaps 

Libraries 

Data for bit-map fonts. 

Printer drivers for various printers. See Amiga User's Manual 
for a list of current drivers and compatible printers. 

Information to translate the key presses on your keyboard into 
the actual characters that a program uses. 

Common routines that all programs can access. 



Devices 

Handlers 
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Routines that handle various devices (or pseudo-devices) that 
may be connected to your computer. 

Similar to devices, but interact with AmigaDOS rather than the 
Amiga's Exec system. 

CLI Commands Routines that execute the commands typed in a CLI window. 

CLI Scripts Files containing several CLI commands that are to be executed 
in succession. 

Using System Mover 

Using System Mover is very simple. You don't have to know anything about the 
contents of the files you are copying, you just select one or more files to copy, 
specify which disk to copy them from and to, and tell System Mover to copy them. 
To use System Mover, follow these steps: 

Double-click on the System Mover program icon. 

When the System Mover window appears, choose from the Move menu the 
type of file you want to copy. The choices are Fonts, Printers, Keymaps, 
Libraries, Devices, Handlers, CLI Commands, and CLI Scripts. 

Choose the disk you want to copy the files/rom by choosing the disk name 
from the From Disk sub-menu in the Disk menu. The disk must be currently 
inserted into a disk drive for it to be listed in the sub-menu, if the disk you 
want to move the files from is not listed, then insert the disk into a disk drive, 
wait a few seconds, and then choose the disk from the sub-menu. 

Once you have chosen a disk to copy files from, System Mover will get a list of 
the files of the appropriate type from that disk. You can now choose to either 
remove files, or copy them to another disk. 

If you want to copy files from one disk to another, choose the disk you want to 
copy the files to from the To Disk sub-menu in the Disk menu. Again, the 
disk must be currently inserted into a disk drive for it to be listed in the sub
menu. If you only want to remove files you can skip this step. 

Now select any file you want to copy or remove by clicking once on the file 
name in the list. If the file is not listed you can scroll the list up or down by 
clicking on the scroll arrows or by dragging the scroll box next to the list of 
files. You can select more than one file at a time by holding down the SHIFf 

key when you click on a file name. To undo a selection, simply hold down the 
SHIFT key and click on the file name again. 
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When you select a file, infonnation about that file is displayed in the bottom 
portion of the window. For fonts, an example of the font is displayed. For libraries 
and devices, infonnation about the version of the file is displayed (if available). 
For all other files, the file size and creation date are displayed. 

Once you have selected the file or files you want to copy, click on the Copy 
button in the window. The files will be copied from the "From" disk to the 
"To" disk. When fonts are copied, the font description (".font") file will be 
automatically updated. Also, if there is a metric file for that font, it will also 
be copied (metric files are used by ProWrite and other programs to obtain 
additional infonnation about the fonts present in your PostScript printer). 

If instead you wish to remove the selected files, click on the Remove button 
in the window. The files will be removed from the "From" disk. Be careful 
with this option, there is no way to get back what you remove! 

You can continue to copy files to and from different disks, of either the same 
or different file types, simply by choosing new selections for "From" and 
"To" disks from the appropriate sub-menus and new types offiles from the 
Move menu. 

When you are done, either click in the close box of the window or choose 
Quit from the Disk menu to quit from System Mover. 
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Appendix B: Printing Considerations 

ProWrite's ability to give high-quality printouts on your Amiga system depends on 
three very important factors: the printer and printer driver Preferences being used, 
the options set in ProWrite's "Page Setup" and "Print" requesters, and the font (or 
fonts) being used. This appendix details some special printing considerations that 
you should be aware of as you set up your system and use ProWrite. 

Printer Driver Preferences 

ProWrite's "Fonts & Devices" disk includes Commodore's printer drivers and 
printing system software, which are designed to work with a number of printers. 
Through the Amiga's Preferences facility, Commodore has provided a general way 
for you to control very powerful printing options even when using relatively 
simple programs to print text and pictures. 

But since ProWrite is strictly a "what you see is what you get" (WYSIWYG) word 
processor, it needs direct control over the appearance of the final printout; there
fore ProWrite directly controls most options available in the Preferences program. 
This makes it unnecessary for you to use the Amiga's Preferences program on a 
day-to-day basis. For instance, ProWrite's "Smooth" option duplicates (and 
overrides) Preferences' "smoothing" setting, which you might otherwise have to 
set through the Preferences program. 

Printer Preferences 

There are some settings in Amiga Preferences that ProWrite does not control: the 
printer name, printer port, carriage width, and graphic shading. These must be set 
so that Pro Write can operate the printer correctly. Fortunately, you normally set 
these settings just once when you first attach your printer. 

These settings tell the system (and ProWrite) what type of printer you have 
connected to your Amiga, and whether it is connected to the serial or parallel port. 
When you select a printer name, you are actually selecting a "printer driver" from 
the ones provided by Commodore (and included on the ProWrite "Fonts & 
Devices" disk). If your printer is not one of the ones listed, and is not compatible 
with a listed printer, you must obtain a driver written specifically for your printer. 

The steps involved in selecting a printer drive and printer port will vary depending 
upon whether you are using Workbench 1.3 (or earlier) or Workbench 2.0 (or 
later). Refer to the Amiga User's Manual that came with your computer for more 
information on setting the printer preferences. 
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Advanced Printing Techniques 

ProWrite's "Nonnal" printing mode (set in the "Print" requester) will print an 
exact copy of the document as you see it on the screen, and the "High" quality 
mode will use larger sized fonts and scale them down for a very high quality 
printout. The success of this graphic printing depends primarily on what your 
printer is capable of. For instance, color graphics and text will naturally only be 
printed in color if you are using a color printer; and some printers (such as daisy 
wheel types) are not capable of graphics printing at all-with these printers the 
"NLQ" or "Draft" mode must be used. The next few paragraphs outline consider
ations which should help you achieve the best results possible with your printer. 
Several levels of quality are considered, from fastest draft printout to the best (and 
slowest) graphical output. 

Finally, there is a "PostScript" printing mode that will produce very high quality 
results on printers that support the PostScript page description language. Use this 
mode for the best possible results. 

USing Printer-Resident Fonts 

First, a word must be said about the special fonts provided with ProWrite. These 
are mono-spaced fonts designed specifically for draft and NLQ printouts. Their 
names are: Pica (10 characters per inch, or "cpi"), Pica Wide (5 cpi), Elite (12 cpi), 
Elite Wide (6 cpi), Condensed (15 cpi), Condensed Wide (7.5 cpi), 
UltraCondensed (17 cpi), and UltraCondensed Wide (8.5 cpi). The advantage to 
using one of these fonts is that each character's screen size is matched as closely as 
possible to standard character pitches supported by most printers, so that you can 
have near-WYSIWYG printing without resorting to graphics printouts. 

Both "Condensed" and "UltraCondensed" fonts are provided because "condensed" 
pitch is finer on some printers than on others. However, the Amiga's printing 
software only supports one condensed printing mode, and there is no way for 
ProWrite to detennine what size your printer's "condensed" font will actually be, 
so you must use the screen font (either Condensed or UltraCondensed) that 
matches your printer's condensed pitch. You can either check your printer docu
mentation, or simply test both fonts to see which one yields the most accurate 
margin placement on your printer. A list of the correct condensed font to use with 
the printers we have tested is shown in Appendix C. 

Draft and NLQ Mode Printing 

For the fastest printing, use the "Draft" mode (set in ProWrite's "Print" requester), 
with "Print Pictures" and "Optimal Spacing" options turned off. Before you can 
use the draft mode, you must make sure the "Page Setup" requester is set for 
pOltrait (vertical) orientation and "Aspect Adjusted" is turned on. 
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With the exception of "Topaz 11" (which is equivalent in pitch to Pica) ProWrite 
will substitute the Elite font for any non-printer fonts during a draft printout. If 
necessary, extra spaces and line feeds will be used to achieve the best possible 
approximation of the page's appearance. 

Some printers support a special "Near Letter-Quality" character set. Choosing 
"NLQ" mode in the "Print" requester tells the printer driver to use such a character 
set if it is available. Note that your printer may not support all of the character 
pitches and styles in NLQ mode that it does in draft. Otherwise, NLQ is virtually 
identical to draft printing. 

Using the "Print Pictures" Option 

If you want to have your document's pictures printed in NLQ or draft mode, then 
select the "Print Pictures" option in the "Print Options" requester. 

In addition to printing pictures in NLQ and draft mode printouts, "Print Pictures" 
also controls the accuracy of vertical spacing in printouts using the printer's 
resident fonts. For speed, ProWrite generally uses only combinations of 1/6- or 1/ 
8-inch line feeds in character mode printing. When "Print Pictures" is selected, all 
lines will be spaced with the best vertical accuracy that the printer is capable of 
(generally to within 1/72 of an inch). This can, however, slow down the printing 
on some printers. 

Also, "Print Pictures" controls the way ProWrite generates a form feed. If this 
option is selected, then ProWrite will use line feeds to feed out the page to the 
exact length you have specified. In the faster character-only mode, ProWrite 
simply sends the printer a form-feed character. Whether this works depends upon 
whether your printer and driver support form feeds, and (if you are using some
thing other than the printer's built-in form length) whether they support a custom 
page length. 

Using the "Optimal Spacing" Option 

Pro Write's character fonts match printer fonts of various pitches as closely as 
possible. In reality, because of the fixed pixel size of the Amiga's screen, only one 
character font (Pica) can match exactly. This means that in the other type sizes 
ProWrite will still have to insert some spaces between words to achieve the same 
overall line length in a printout that you see on the screen. 

The spaces that are used will be of the same pitch that is currently being printed 
(Elite, Condensed, etc.). Unfortunately, this can occasionally lead to odd-looking 
results. However, if you select "Optimal Spacing" in the Print requester, ProW rite 
will use two different pitches for its space characters, allowing it to achieve more 
uniform word spacing. On some printers this will result in slower printing, but 
generally the results look much better. 
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Setting the Printer Font Number 

This is a little-known feature of the Amiga's printing software that is not acces
sible through the Preferences program. At the time this manual went to press, few 
printer drivers supported more than one alternate font-most drivers use this 
number to choose an international character set for your printer. This has little 
effect on the printed result, often simply changing characters like # into £. But a 
few drivers, such as the HP LaserJet driver, use the "Printer font number" to select 
different type faces, such as Serif vs. Sans Serif. Up to ten alternate font numbers 
may be set, in case future drivers support them. Font number zero selects the 
printer's default font. 

Graphics Printing 

Just as the effectiveness of character printing depends upon the print pitches which 
your printer supports, the effectiveness of "Normal" mode graphics printing 
depends on the print density of your printer. "Print Density" refers to the number 
of individual dots your printer can place within a square inch; it is expressed as 
dots per inch (dpi) of width by dpi of height. A very common print density is 80 by 
72-in fact this is the density with which ProWrite can give a one-to-one printout 
of your document, almost exactly as you see it on the screen. The reason that this 
print density is ideal for printing Amiga graphics is that it very nearly matches the 
Amiga monitor's pixel aspect ratio of 1.15: I. 

Setting the Print Density 

The "Print Density" setting of ProWrite's "Page Setup" requester allows you to 
select a print density for graphics printing (assuming your printer and printer 
driver supports more than one density). For the fastest graphic printing in the 
portrait (vertical) orientation, you should choose a density that is as close as 
possible to 80 by 72 dpi (dots per inch). For higher quality printing, such as when 
using the smoothed or High quality printing mode discussed later, you should use 
a higher print density. If possible, choose a print density that is an exact mUltiple 
of 80 by 72, such as 160 by 144, or 240 by 216. 

If you will be printing in landscape (sideways) orientation, the optimum printer 
print density is a multiple of 60 by 72 (which corresponds to 72 by 60 on the 
screen). 
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Using Aspect Adjustment 

Some printers do not support the ideal print density of 80 by 72 dpi. In that case 
you can have ProWrite compensate for this by "scaling" the printout to produce an 
effective output density of 80 by 72 dpi. You do this by turning on the "Aspect 
Adjusted" check box in the "Page Setup" requester. If you do this, the relative 
aspect (horizontal to vertical dimensions) of the screen will be preserved on the 
printout. While this scaling will guarantee that your pictures are printed correctly 
(circles will still be circles, not ovals), it often results in poor-quality results in the 
text of your document, particularly if you are using a font that has single-pixel 
wide strokes. 

If you tum the "Aspect Adjusted" option off, ProWrite will use a print density that 
is an exact multiple of the print density you have selected, while still being as 
close to 80 by 72 dpi as possible. For example, if your print density is set to 150 by 
150 dpi and "Aspect Adjusted" is turned off, the resulting output print density will 
be 75 by 75 dpi. This will greatly improve the print quality of the text, but can 
distort the pictures in your document, either by stretching or shrinking them in one 
direction but not the other. In the case of some printers the distortion can be quite 
severe. 

For portrait (vertical) orientations, the "Aspect Adjusted" option should generally 
be turned off, unless you will be printing in NLQ or draft mode, or need to have 
your pictures come out exactly as they appear on the screen. In landscape (side
ways) orientation, you should generally keep it turned on, since turning it off in 
this orientation can often result in severe distortions. 

Remember, the "Aspect Adjusted" option must be turned on for NLQ or draft 
mode printing. 

Using the "Smooth" Option 

If you have a high-density printer, you can achieve better print quality (at the cost 
of some printing speed) by selecting "Smooth" in the "Print Options" requester 
and setting an appropriate print density. This option tells the printer driver to use 
the extra resolution to "fill in" the stair-step pattern of the Amiga' s pixels. To be 
most effective, you must choose a print density that is at least 160 by 144 dpi 
(which is double 80 by 72 dpi). However, the higher the print density, the slower 
the printing speed, and the best trade-off between speed and quality is usually at a 
print density of 160 by 144 dpi. 
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Using High Quality Printing Mode 

For the best graphic printing, you should use the "High" quality printing mode. In 
this case ProWrite will use a larger font and scale it down when printing the 
document. For example, if you have set a print density of 160 by 144, ProWrite 
will use a double size font printed at the full resolution to achieve an effective size 
of 80 by 72, but with much higher quality. See the section on High Quality 
Printing in the Using ProW rite chapter for a more complete discussion of high 
quality printing. 

High quality printing will always produce the best possible results on your printer, 
but it may be slower than "Normal" mode printing. Also, unless you are using 
Workbench 2.0 or later, you will need to make sure you have the proper font sizes 
installed on your system. For example, if you use Times-12 in your document, you 
must have Times-24 installed as well in order to get a correct printout in high 
quality mode. If you are using Workbench 2.0 or later, ProWrite will automatically 
create the correct font size from the ones available, and if you have Commodore's 
outline font system installed you will always get perfect output. 
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Appendix C: Printer Font List 

Regular Fonts: 

Wide Fonts: 

Not all printers and printer drivers support all print pitches, and only one type of 
condensed print is supported on any given printer. Use this table to determine 
which printer fonts you can use in your ProWrite documents. If your printer is not 
on this list, then try printing using all of the different fonts and see which ones 
produce results that match the screen display. 

Note: If your printer does not support the "Elite" font then you must not use 
Pro Write's "Optimal Spacing" option, since this option uses the Elite font to even 
out word spacings. 

Printer driver Pica Elite Condensed UltraCond 

CBM_MPSlOOO x x 
Diablo_C 150 x 
ImageWriterII x x x 
EpsonX x x x 
EpsonXOld x x 
EpsonQ x x x 
HP _DeskJet x x 
HP _LaserJet x LJ+ only 
HP _PaintJet x x x 
NEC _Pinwri ter x x x 
Okidata_293I x x x 
Okimate_20 x x x 

Printer driver Pica Wide Elite Wide Condensed Wide UltraCond Wide 

CBM_MPS I 000 x x 
Diablo_C 150 
ImageWriterII x x x 
EpsonX x x x 
EpsonXOld x x 
EpsonQ x x x 

HP_DeskJet 
HP _LaserJet 
HP _PaintJet 
NEC _Pinwriter x x x 
Okidata_293I x x x 
Okimate_20 x x x 

179 



Appendix D: Memory Considerations 

To free memory: 

180 

The memory installed in your Amiga is used by programs, such as ProWrite, to 
hold both the program while it is running and any information the program is 
working with (for example, documents that you are editing or pictures that you are 
creating). Since the Amiga is a multi-tasking computer, this memory must be 
shared between all programs that are currently running. Obviously, in order to run 
many programs at the same time, you will need a large amount of memory (Note 
that the memory being discussed here is not the same as the amount of space 
available on your disks, but rather the actual plug-in memory that you have 
installed in your computer). 

When working with ProWrite, especially when using high resolution, multi
tasking, and the RAM Disk, you may encounter situations where ProWrite tells 
you that there is not enough memory to complete the operation you have re
quested. There are several steps you can take to try to increase the amount of 
available memory: 

Close all Workbench windows, including any CLI windows you may have 
open. 

Quit from any other programs you are using at the same time as ProWrite. 

Close any ProWrite windows you are not using. Note that when you use the 
New or Open command, any windows that are already open in ProWrite are 
not closed. 

If you use a lot of pictures in your documents, try to use brushes rather than 
full pictures. Brushes can use considerably less memory. 

Another reason available memory may be low is that when you cut or copy a large 
block of text or a picture, a copy remains in ProWrite's internal clipboard even 
though you may have pasted it back into the document (this is so you may easily 
paste multiple copies of the same text or picture). The contents of this clipboard 
may take up considerable amounts of memory, memory usage which is hidden 
from you. To clear the contents of the clipboard, simply select a single character in 
the text and choose Copy from the Edit menu twice (to clear out the undo buffer 
as well), the selected character will replace what was previously in the clipboard. 
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The memory in the Amiga system is actually composed of two parts-Graphics 
(or "Chip") memory, and Expansion (or "Fast") memory. Adding Expansion 
memory is straightforward; adding Graphics memory usually requires a little more 
work, and is limited to one megabyte total (two megabytes on the A3000). 
Unfortunately, the Amiga's special graphics hardware can only use Graphics 
memory, so the Amiga operating system uses up Graphics memory quite rapidly 
for screens, window contents, and other graphical data. This makes it possible to 
run out of Graphics memory when you are using several programs that rely on 
graphics at the same time (such as ProWrite and DeluxePaint)---even if you have 
several megabytes of Expansion memory available. To help reduce this problem 
ProWrite uses Expansion memory for everything it can, and only uses Graphics 
memory for things that must go there. To see the amount of both Graphics and 
Expansion memory that is currently available, press the HELP key while running 
ProWrite. 

Sometimes the graphics memory can get so low that the Amiga's menu system 
cannot display some menus when you try to pull them down. If this happens, you 
can still use keyboard equivalents to access most commands. See Shortcuts in the 
Using ProW rite chapter. 

ProWrite is designed to properly recover from all low memory conditions, it even 
has an automatic save feature when available memory gets low, to prevent you 
from losing your documents. Unfortunately not all programs are so forgiving; in 
fact the Amiga system itself often crashes if memory gets below certain levels. For 
this reason, ProWrite starts to warn you, with a message in the screen's menu bar, 
when memory gets so low that the system may start to have problems. When you 
see this message you should try to free some memory and save your document to 
prevent problems later. 

When ProWrite tries to display either the "Save Changes Before Closing'!" or 
"Save As" requester but is not able to do so due to lack of available memory, it 
will automatically try to save the document as a file with the name 
"ProWrite.Recover" on the disk in the internal drive. ProWrite will display a 
message on the menu bar while it is doing this so you know what is going on. If 
this save operation fails (because the disk is locked or full), insert an empty 
formatted disk in the internal drive and try again. 
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From time to time you may encounter error messages from ProWrite. Error 
messages will appear either in a requester, or (when there is not enough memory 
for a requester) in the screen's menu bar. These messages usually indicate 
ProWrite's inability to perform an operation that you have requested. The follow
ing is a list of the most common error messages, their cause, and what you can do 
to correct the problem. 

Not enough memory 
There was not enough memory to complete the requested operation. Note that this 
message has nothing to do with how much space you have left on your disk, but 
how much memory you have installed in your Amiga system itself. To free 
memory for ProWrite's use, close some Workbench windows, quit from other 
programs, and close unused ProWrite windows. Pressing the HELP key will indicate 
how much memory is available. 

Not enough memory - saving as 'ProWrite.Recover' on drive 0 
This message appears in the menu bar when ProWrite tries to display the "Save 
Changes?" or "Save As" requester but there is not enough memory to do so. When 
this happens, ProWrite will automatically try to save the document to the disk in 
the internal drive under the name "ProWrite.Recover" (in order to keep you from 
losing the document). If this save operation fails, you should try putting a blank 
formatted disk in the internal drive and try again. 

Unable to open file 
ProWrite was unable to open the file you specified. This message will usually be 
accompanied by a reason for the failure, either "Bad File Contents" or a DOS error 
number. Refer to your AmigaDOS user's manual for an explanation of DOS error 
codes. Make sure the file you are trying to load is either a ProWrite file, a Flow 
file, or a Text file., ProWrite does not recognize any other file types. 

Unable to save file 
ProWrite was unable to save the file using the name and disk/drawer location you 
specified. This message will usually be accompanied by a DOS error code 
explaining the reason for the failure. The usual reason is "Disk Write Protected" 
(214) or "Disk Full" (221). Check the write protect tab on the disk or delete some 
files on the disk to make some room. Refer to your AmigaDOS user's manual for 
an explanation of other DOS error codes. 

Improper page size 
You have specified a page size that is smaller than 2 inches, or larger than 44 
inches in either the horizontal or vertical direction. Enter a page size that is within 
this range. 
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Improper number of copies 
You have specified a value for the number of copies to print that is not a valid 
number. Enter a valid number. 

Improper page number 
You have specified a page number that is not a valid number. Enter a valid 
number. 

No such page 
You have specified a page number that does not exist in the document. Only enter 
existing page numbers, or (in the "Print" requester) click on the "All" option to 
print all pages. 

Unable to print 
ProWrite is unable to print your document. Either the printer is being used by 
another program, or the printer is not responding to the computer, or there is not 
enough memory available to print. Check that the printer is properly hooked up 
and turned on, and that no other programs are using it. Also, printing in 
"PostScript" or "Normal" mode takes quite a bit more memory than printing in 
either "NLQ" or "Draft" modes. You can try to free some memory by closing all 
Workbench windows (including CLI windows), quitting from other programs, and 
closing unused ProWrite windows. 

Improper merge range 
You have specified a range of records to merge in a "Print Merge" operation that 
does not make sense. Type a proper value. 

Improper text entry 
You have clicked the "Find" button in the "Find" or "Change" requester without 
specifying any text to find. Enter the text you wish to find before starting the 
search. 

Text not found 
The text you specified in the "Find" or "Change" requester was not found. 

Unable to change text 
ProWrite was not able to perform the change operation you specified in the 
"Change" requester. This is usually due to ProWrite running out of memory. Free 
some memory by closing some Workbench windows, quitting from other pro
grams, and closing unused Pro Write windows. 

Unable to get font 
ProWrite was not able to load the specified font. This is caused either by not 
having enough memory, or having a corrupt fonts directory. To free some 
memory, close some Workbench windows, quit from other programs, and close 
unused ProWrite windows. Also, make sure you have installed the fonts correctly 
on your disk. 
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Improper line height 
You have typed a line height that is less than I or greater than 127 pixels. Type a 
value that is within this range. 

Improper margin values 
You have entered document margin values that are incompatible with the page 
size. Type margin values that total less than the page dimensions. 

Unable to find dictionary 
ProWrite is not able to locate the "Main Dictionary" for its spelling checker. The 
dictionary must be either on the RAM disk, or in the same disk and drawer as the 
ProWrite program, and it must be called "Main Dictionary." Altematively, you can 
use ProWrite's Change Diet command to locate the dictionary you wish to use. 

Unable to save dictionary 
ProWrite was not able to save the changes to your user dictionary. The usual 
reasons for this are either the disk is full, or it is write protected. The user dictio
nary is written to the same disk and drawer that the ProWrite program is in. Check 
the write protect tab on this disk, or delete some files to make room on the disk. 

Unable to change dictionary 
ProW rite is unable to switch to the dictionary you specified, either you are out of 
memory or there is a problem with the dictionary file. Try using a different 
dictionary, or close some windows to free up memory space. 

Unable to find thesaurus 
ProWrite is not able to locate the "Thesaurus" file. The thesaurus must be either on 
the RAM disk, or in the same disk and drawer as the ProWrite program, and it 
must be called "Thesaurus." 

AREXX not present 
The AREXX system is not present in your system, so macros are unavailable. 
Make sure you have the REXX libraries in your libs: directory, and that you have 
run the RexxMast program. 

Macro execution failed 
The ARexx macro you were executing has retumed with a failure code. Try 
executing the macro with the "rx" CLI command and detennine where the error is 
occurring. 
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Appendix F: Troubleshooting 

This appendix lists some suggestions for dealing with the most common problems 
encountered while using ProWrite. If you aren't able to find the answer to your 
problem here or elsewhere in this manual, please call or write to us for assistance. 

Technical support address: 

Phone number: 

New Horizons Software, Inc. 
Attention: Customer Support 

206 Wild Basin Road, Suite 109 
Austin, TX 78746 

(512) 328-6650 

"Unable To Print" is displayed when trying to print 

This message usually arises when you trying to print in "Normal" mode and there 
is not enough memory to do so. Because "Normal" mode is a graphics output to 
the printer, it takes considerably more memory to print in this mode than it does to 
print in "NLQ" or "Draft" mode. Refer to Appendix C: Memory Considerations 
for suggestions on how to free additional memory. 

"Printing in Progress" is displayed, but nothing is being printed 

This usually means you have not set up Amiga Preferences properly. Make sure 
you have made the settings discussed in Appendix B: Printing Considerations. 
Double check to see that your printer is properly connected, and that Preferences is 
set appropriately for Parallel or Serial operation. If you are using a serial printer, 
go to the "Serial" section of Preferences and make sure the baud rate, parity, stop 
bits, and handshaking match your printer's settings. 

When printing in NLQ or Draft mode, extra blank lines are printed or 
the word spacing is not correct 

This happens when you are not using printer fonts (such as Pica, Elite, Condensed, 
or UltraCondensed) for your entire document. Other fonts will only print correctly 
in "Normal" mode. You will also encounter similar problems if you use character 
font pitches which your printer does not support (usually either Condensed or 
UltraCondensed), or if you use superscripts and/or subscripts in a paragraph 
without setting an appropriate fixed line height for that paragraph. Some word 
spacing problems may occur in any case unless you set "Optimal Spacing" in the 
"Page Setup" requester, and line spacing will not necessarily be ideal unless you 
select "Print Pictures." 
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When printing in Normal or High mode printing is very slow-it takes 
several minutes to print each page 

Either you are not using the Workbench 1.3 printing system software 
(printer.device and printer drivers), or your the custom printer driver you are using 
does not support the AmigaDOS 1.3 printing mechanism. 

The printing software and drivers on ProWrite's System disk are all up-to-date 
with the 1.3 version of Workbench. If you are using a different disk to start your 
computer you should copy this new software to your start-up disk. Refer to 
Appendix A: Moving System Files for information on how to copy system files. 

If you are using the new printing system software but are also using a custom 
printer driver (one that did not come on ProWrite's System disk), you should 
contact the company that developed the driver you are using and ask for a version 
that supports the faster version 1.3 graphics printing. 

Printing will also be slower if you have set a high printer resolution for graphics 
printing (in ProWrite's "Page Setup" requester), or if you have selected the 
"Smooth" option in the "Print" requester, or are using the print reduction technique 
discussed in Appendix B: Printing Considerations. 

My printer leaves tiny white lines between each horizontal strip of 
eight dots. 

Some Epson, Epson compatible, and IBM compatible printers have poor line 
spacing in graphics mode. Try selecting a Paper Type of "Single" in Preferences. 
This tells the printer driver to advance the paper by 23/216 of an inch instead of 
the standard 24/216 of an inch. This option has been implemented on the EpsonX 
and CBM MPS 1000 drivers. 
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